• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            The kth great number, The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

            The kth great number

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

            Problem Description
            Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
             

            Input
            There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
             

            Output
            The output consists of one integer representing the largest number of islands that all lie on one line. 
             

            Sample Input
            8 3
            I 1
            I 2
            I 3
            Q
            I 5
            Q
            I 4
            Q
             

            Sample Output
            1
            2
            3

            Hint
            Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
             


            打個醬油。
            小根堆保存最多 K 個元素,對每次詢問輸出堆頂元素。



             1 #include <iostream>
             2 #include <cstdio>
             3 #include <algorithm>
             4 #include <queue>
             5 
             6 using namespace std;
             7 
             8 typedef  priority_queue< int, vector< int >, greater< int > >  Heap;
             9 
            10 int main() {
            11         Heap mh;
            12         int n, k, x;
            13         char cmd[ 3 ];
            14         while ( 2 == scanf( "%d%d"&n, &k ) ) {
            15                 while ( ! mh.empty() ) {
            16                         mh.pop();
            17                 }
            18                 while ( n-- > 0 ) {
            19                         scanf( "%s", cmd );
            20                         if ( 'I' == cmd[ 0 ] ) {
            21                                 scanf( "%d"&x );
            22                                 mh.push( x );
            23                                 while ( mh.size() > k ) {
            24                                         mh.pop();
            25                                 }
            26                         }
            27                         else {
            28                                 printf( "%d\n", mh.top() );
            29                         }
            30                 }
            31         }
            32         return 0;
            33 }
            34 

            posted on 2011-09-03 18:17 coreBugZJ 閱讀(362) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            天天爽天天爽天天片a久久网| 久久无码国产专区精品| 久久久久亚洲AV片无码下载蜜桃| 久久久久久无码Av成人影院| 久久AV高清无码| 久久国产福利免费| 伊人久久综合无码成人网| 久久成人国产精品二三区| 久久91这里精品国产2020| 国产精品成人久久久| 成人综合伊人五月婷久久| 无码精品久久一区二区三区| 久久久久国产精品人妻| 99久久婷婷国产综合精品草原| 2021国产精品久久精品| 久久青青草原精品影院| 久久无码专区国产精品发布| 91亚洲国产成人久久精品网址| 久久久无码精品亚洲日韩京东传媒 | 日本一区精品久久久久影院| 亚洲精品国精品久久99热| 精品午夜久久福利大片| 亚洲综合伊人久久大杳蕉| 亚洲国产成人乱码精品女人久久久不卡 | 久久99精品久久久久久齐齐 | 亚洲人AV永久一区二区三区久久| 精品国产一区二区三区久久久狼| 久久久久久国产a免费观看黄色大片| 久久精品国产亚洲AV高清热| 亚洲女久久久噜噜噜熟女| 久久夜色精品国产| 久久精品国产精品亚洲| 91久久香蕉国产熟女线看| 久久九九亚洲精品| 国内精品久久久久久久97牛牛| 亚洲色大成网站WWW久久九九| 午夜精品久久久久9999高清| 九九久久精品无码专区| 久久国产精品一区| 久久免费国产精品| 老男人久久青草av高清|