• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            The kth great number, The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

            The kth great number

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

            Problem Description
            Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
             

            Input
            There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
             

            Output
            The output consists of one integer representing the largest number of islands that all lie on one line. 
             

            Sample Input
            8 3
            I 1
            I 2
            I 3
            Q
            I 5
            Q
            I 4
            Q
             

            Sample Output
            1
            2
            3

            Hint
            Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
             


            打個醬油。
            小根堆保存最多 K 個元素,對每次詢問輸出堆頂元素。



             1 #include <iostream>
             2 #include <cstdio>
             3 #include <algorithm>
             4 #include <queue>
             5 
             6 using namespace std;
             7 
             8 typedef  priority_queue< int, vector< int >, greater< int > >  Heap;
             9 
            10 int main() {
            11         Heap mh;
            12         int n, k, x;
            13         char cmd[ 3 ];
            14         while ( 2 == scanf( "%d%d"&n, &k ) ) {
            15                 while ( ! mh.empty() ) {
            16                         mh.pop();
            17                 }
            18                 while ( n-- > 0 ) {
            19                         scanf( "%s", cmd );
            20                         if ( 'I' == cmd[ 0 ] ) {
            21                                 scanf( "%d"&x );
            22                                 mh.push( x );
            23                                 while ( mh.size() > k ) {
            24                                         mh.pop();
            25                                 }
            26                         }
            27                         else {
            28                                 printf( "%d\n", mh.top() );
            29                         }
            30                 }
            31         }
            32         return 0;
            33 }
            34 

            posted on 2011-09-03 18:17 coreBugZJ 閱讀(362) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            午夜不卡久久精品无码免费| 亚洲另类欧美综合久久图片区| 伊人久久亚洲综合影院| 日韩欧美亚洲国产精品字幕久久久| 久久久久人妻一区精品果冻| 精品熟女少妇AV免费久久| 久久久国产精品亚洲一区| 91久久精品国产免费直播| 欧美一级久久久久久久大| 99国产精品久久久久久久成人热| 99久久夜色精品国产网站| 97久久国产露脸精品国产 | 国产精品久久久99| 久久人人爽人人爽人人爽 | 久久天天躁狠狠躁夜夜不卡| 久久精品国产99国产电影网| 中文成人无码精品久久久不卡| 国产一区二区三区久久| 7777精品久久久大香线蕉| 精品久久久久久无码国产| 69久久精品无码一区二区| 女人高潮久久久叫人喷水| 国内精品久久久久影院网站| 无码专区久久综合久中文字幕 | 久久91精品国产91久久小草 | 久久婷婷国产综合精品| 久久精品国产精品亚洲下载| 精品一区二区久久| 99久久这里只有精品| 久久夜色精品国产噜噜噜亚洲AV| 免费精品久久久久久中文字幕| 99久久伊人精品综合观看| a高清免费毛片久久| 色综合久久久久久久久五月| 久久精品免费一区二区| 欧美精品九九99久久在观看| 久久亚洲AV无码西西人体| 久久久久国产亚洲AV麻豆| 久久久精品国产Sm最大网站| 久久久久噜噜噜亚洲熟女综合| 久久久久久亚洲精品不卡|