• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            Vote, FZU 2011年3月月賽之 F, FZU 2015

            Problem 2015 Vote

            Time Limit: 1000 mSec    Memory Limit : 32768 KB

            Problem Description

            Here are n Candidates in one election. Every Candidate could vote any one (of course himself/herself). In this election, the one who gets more than half of n become the winner! However, sometimes no winner could be determined (No one gets more than half of n votes)!

            Now you are given the number of Candidates and the final winner m, here if m is equal to -1, then it means that no one wins, otherwise m is the index of the Candidate. (The index of Candidates is 0, 1, 2, … n – 1 respectively) Abcdxyzk wants to know the number of possible ways of the final result if the winner if m. (m = -1 for no winner of course) However, the answer maybe large, so abcdxyzk just want the remainder of the answer after divided by 1000000007.

            Input

            There are several test cases.

            For each case, only two integers n and m in a single line indicates n Candidates and the final winner m. (1 <= n <= 100, -1 <= m < n)

            Output

            For each test case, output the number of possible ways of the final election!

            Sample Input

            2 1
            3 -1
            4 1

            Sample Output

            1
            1
            4

            Hint

            In case 1, only one possible ways of the final result because both 0 and 1 vote to 1.

            In case 2, only one possible ways of the final result because all of 0, 1, and 2 get one vote.

            In case 3, there are 4 possible ways of final result:

            (1) 0: 1 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            (2) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 1 (vote(s)) 3: 0 (vote(s))

            (3) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 1 (vote(s))

            (4) 0: 0 (vote(s)) 1: 4 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            Source

            FOJ有獎月賽-2011年03月


            組合數(shù)。

            我的代碼:
             1 #include <stdio.h>
             2 
             3 typedef  long  long  Lint;
             4 
             5 #define  L  203
             6 #define  MOD  1000000007
             7 
             8 int c[ L ][ L ];
             9 
            10 int main() {
            11         int n, m, i, j, ans;
            12         for ( i = 0; i < L; ++i ) {
            13                 c[ i ][ 0 ] = c[ i ][ i ] = 1;
            14                 for ( j = 1; j < i; ++j ) {
            15                         c[ i ][ j ] = ( c[ i - 1 ][ j - 1 ] + c[ i - 1 ][ j ] ) % MOD;
            16                 }
            17         }
            18         while ( scanf( "%d%d"&n, &m ) == 2 ) {
            19                 if ( m < 0 ) {
            20                         ans = ( c[n+n-1][n] + (Lint)(MOD-c[(n-1)+(n-n/2-1)][n-1]) * n ) % MOD;
            21                 }
            22                 else {
            23                         ans = c[ (n-1+ (n-n/2-1) ][ n-1 ];
            24                 }
            25                 printf( "%d\n", ans );
            26         }
            27         return 0;
            28 }
            29 

            posted on 2011-03-23 22:46 coreBugZJ 閱讀(1462) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            久久青青草原精品国产软件| 国产99久久久国产精免费| 久久亚洲精品无码观看不卡| 久久久这里有精品| 久久AV高潮AV无码AV| 狠狠色丁香久久婷婷综合_中| 久久亚洲精品无码VA大香大香| 亚洲精品无码成人片久久| 久久国产欧美日韩精品| 精品久久久久久国产牛牛app| 中文国产成人精品久久亚洲精品AⅤ无码精品| 亚州日韩精品专区久久久| 久久精品国产亚洲AV香蕉| 久久久久久A亚洲欧洲AV冫| 午夜天堂精品久久久久| 久久亚洲AV永久无码精品| 久久精品中文无码资源站 | 久久国语露脸国产精品电影| 国产精品免费看久久久| 亚洲国产精品狼友中文久久久| 国内精品久久久久影院优| 欧美伊人久久大香线蕉综合| 九九久久精品国产| 国产精品久久久久AV福利动漫| 2021国产精品久久精品| 久久久艹| 国产视频久久| 国产激情久久久久影院| 色婷婷综合久久久久中文一区二区| 久久成人永久免费播放| 色综合久久中文色婷婷| 日韩人妻无码精品久久免费一 | 亚洲国产精品无码久久青草| 久久国产精品一区二区| 久久精品国产99久久无毒不卡 | 国产A三级久久精品| 婷婷久久综合九色综合绿巨人| 久久精品一区二区三区中文字幕| 91精品观看91久久久久久| 99久久人人爽亚洲精品美女| 久久精品嫩草影院|