• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            Vote, FZU 2011年3月月賽之 F, FZU 2015

            Problem 2015 Vote

            Time Limit: 1000 mSec    Memory Limit : 32768 KB

            Problem Description

            Here are n Candidates in one election. Every Candidate could vote any one (of course himself/herself). In this election, the one who gets more than half of n become the winner! However, sometimes no winner could be determined (No one gets more than half of n votes)!

            Now you are given the number of Candidates and the final winner m, here if m is equal to -1, then it means that no one wins, otherwise m is the index of the Candidate. (The index of Candidates is 0, 1, 2, … n – 1 respectively) Abcdxyzk wants to know the number of possible ways of the final result if the winner if m. (m = -1 for no winner of course) However, the answer maybe large, so abcdxyzk just want the remainder of the answer after divided by 1000000007.

            Input

            There are several test cases.

            For each case, only two integers n and m in a single line indicates n Candidates and the final winner m. (1 <= n <= 100, -1 <= m < n)

            Output

            For each test case, output the number of possible ways of the final election!

            Sample Input

            2 1
            3 -1
            4 1

            Sample Output

            1
            1
            4

            Hint

            In case 1, only one possible ways of the final result because both 0 and 1 vote to 1.

            In case 2, only one possible ways of the final result because all of 0, 1, and 2 get one vote.

            In case 3, there are 4 possible ways of final result:

            (1) 0: 1 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            (2) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 1 (vote(s)) 3: 0 (vote(s))

            (3) 0: 0 (vote(s)) 1: 3 (vote(s)) 2: 0 (vote(s)) 3: 1 (vote(s))

            (4) 0: 0 (vote(s)) 1: 4 (vote(s)) 2: 0 (vote(s)) 3: 0 (vote(s))

            Source

            FOJ有獎月賽-2011年03月


            組合數。

            我的代碼:
             1 #include <stdio.h>
             2 
             3 typedef  long  long  Lint;
             4 
             5 #define  L  203
             6 #define  MOD  1000000007
             7 
             8 int c[ L ][ L ];
             9 
            10 int main() {
            11         int n, m, i, j, ans;
            12         for ( i = 0; i < L; ++i ) {
            13                 c[ i ][ 0 ] = c[ i ][ i ] = 1;
            14                 for ( j = 1; j < i; ++j ) {
            15                         c[ i ][ j ] = ( c[ i - 1 ][ j - 1 ] + c[ i - 1 ][ j ] ) % MOD;
            16                 }
            17         }
            18         while ( scanf( "%d%d"&n, &m ) == 2 ) {
            19                 if ( m < 0 ) {
            20                         ans = ( c[n+n-1][n] + (Lint)(MOD-c[(n-1)+(n-n/2-1)][n-1]) * n ) % MOD;
            21                 }
            22                 else {
            23                         ans = c[ (n-1+ (n-n/2-1) ][ n-1 ];
            24                 }
            25                 printf( "%d\n", ans );
            26         }
            27         return 0;
            28 }
            29 

            posted on 2011-03-23 22:46 coreBugZJ 閱讀(1462) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            久久久久国产一区二区| 91亚洲国产成人久久精品网址| 久久精品无码一区二区三区免费 | 99久久精品费精品国产| 久久精品国产半推半就| 久久久久99精品成人片| 精品伊人久久久| 91精品久久久久久无码| 国产成人精品久久| 久久精品国产黑森林| 色婷婷综合久久久久中文一区二区 | 久久精品国产精品亚洲| 中文字幕无码免费久久| 精品人妻伦一二三区久久| 久久久久免费精品国产| 国产亚州精品女人久久久久久 | 精品久久久久久无码免费| 精品熟女少妇AV免费久久| 久久人人超碰精品CAOPOREN| 亚洲欧美日韩久久精品第一区| 岛国搬运www久久| 99久久精品费精品国产一区二区| 久久久无码精品亚洲日韩软件| 成人国内精品久久久久一区| 伊人久久综合精品无码AV专区| 久久久国产精品| 久久精品国产一区二区电影| 久久美女网站免费| 久久午夜羞羞影院免费观看| 久久天天躁狠狠躁夜夜2020一 | 九九99精品久久久久久| 久久久久久亚洲AV无码专区| 亚洲精品乱码久久久久久久久久久久 | 久久精品桃花综合| 一个色综合久久| 亚洲精品第一综合99久久| 中文字幕久久精品| 狠狠色婷婷久久一区二区| 久久精品久久久久观看99水蜜桃| 久久精品国产亚洲AV久| 久久精品99久久香蕉国产色戒 |