• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            coreBugZJ

            此 blog 已棄。

            Let it Bead,POJ 2409

            Let it Bead
            Time Limit: 1000MS
            Memory Limit: 65536K
            Total Submissions: 2318
            Accepted: 1448

            Description

            "Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

            A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

            Input

            Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

            Output

            For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

            Sample Input

            1 1
            2 1
            2 2
            5 1
            2 5
            2 6
            6 2
            0 0

            Sample Output

            1
            2
            3
            5
            8
            13
            21

            Source

            Ulm Local 2000


            赤裸裸的 Polya,旋轉(zhuǎn) i 的循環(huán)個數(shù)為 gcd( i, n )


             1 #include <iostream>
             2 
             3 using namespace std;
             4 
             5 typedef long long Lint;
             6 
             7 Lint gcd( Lint a, Lint b ) {
             8         return ( (b==0? a : gcd(b,a%b) );
             9 }
            10 
            11 Lint power( Lint a, Lint b ) {
            12         Lint ans = 1;
            13         while ( b-- > 0 ) {
            14                 ans *= a;
            15         }
            16         return ans;
            17 }
            18 
            19 Lint solve( Lint n, Lint m ) {
            20         Lint i, ans = 0;
            21         for ( i = 1; i <= n; ++i ) {
            22                 ans += power( m, gcd(n,i) );
            23         }
            24         if ( n & 1 ) {
            25                 ans += n * power( m, n/2+1 );
            26         }
            27         else {
            28                 ans += power( m, n/2 ) * n / 2 + power( m, n/2+1 ) * n / 2;
            29         }
            30         ans /= n + n;
            31         return ans;
            32 }
            33 
            34 int main() {
            35         Lint n, m;
            36         for ( ; ; ) {
            37                 cin >> m >> n;
            38                 if ( (m<1&& (n<1) ) {
            39                         break;
            40                 }
            41                 cout << solve( n, m ) << "\n";
            42         }
            43         return 0;
            44 }
            45 


            posted on 2011-04-17 22:11 coreBugZJ 閱讀(439) 評論(0)  編輯 收藏 引用 所屬分類: ACM

            久久最新精品国产| 99久久99久久| 国产亚洲成人久久| 久久久精品午夜免费不卡| 久久精品国产99久久无毒不卡 | 日本精品久久久久影院日本| 国产成人综合久久综合 | 亚洲国产精品无码久久久蜜芽 | 91精品国产91久久久久久青草 | 成人精品一区二区久久| 99久久免费国产精品| 国产精品美女久久久久av爽| 国内精品伊人久久久久网站| 亚洲国产成人久久精品99 | 人妻无码αv中文字幕久久琪琪布| 久久精品人妻中文系列| 麻豆AV一区二区三区久久 | 国产精品久久久久影院嫩草| 香蕉久久一区二区不卡无毒影院 | 国产精品无码久久综合网| 久久996热精品xxxx| 久久人妻无码中文字幕| 日日噜噜夜夜狠狠久久丁香五月| 国产精品久久久久久搜索| 国产99久久九九精品无码| 国产精品久久久久免费a∨| 欧美va久久久噜噜噜久久| 久久久久久久尹人综合网亚洲| 国产综合精品久久亚洲| 国产激情久久久久久熟女老人| 久久99精品久久久久子伦| 久久99精品久久久久久不卡| 77777亚洲午夜久久多喷| 免费观看成人久久网免费观看| 人人狠狠综合久久亚洲高清| 久久精品国产亚洲精品2020| 久久久久久无码国产精品中文字幕 | 伊人久久大香线焦综合四虎| 久久亚洲sm情趣捆绑调教| 久久这里只精品国产99热| 国内精品久久久久影院薰衣草 |