• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2012年3月>
            26272829123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            HDOJ 2714 HDU 2714 ISBN ACM 2714 IN HDU

            Posted on 2010-09-25 20:25 MiYu 閱讀(441) 評論(1)  編輯 收藏 引用 所屬分類: ACM ( 水題 )

            MiYu原創(chuàng), 轉帖請注明 : 轉載自 ______________白白の屋    

            題目地址 :

            http://acm.hdu.edu.cn/showproblem.php?pid=2714

            題目描述:

            ISBN

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
            Total Submission(s): 566    Accepted Submission(s): 172


            Problem Description
            Farmer John's cows enjoy reading books, and FJ has discovered that his cows produce more milk when they read books of a somewhat intellectual nature. He decides to update the barn library to replace all of the cheap romance novels with textbooks on algorithms and mathematics. Unfortunately, a shipment of these new books has fallen in the mud and their ISBN numbers are now hard to read.

            An ISBN (International Standard Book Number) is a ten digit code that uniquely identifies a book. The first nine digits represent the book and the last digit is used to make sure the ISBN is correct. To verify that an ISBN number is correct, you calculate a sum that is 10 times the first digit plus 9 times the second digit plus 8 times the third digit ... all the way until you add 1 times the last digit. If the final number leaves no remainder when divided by 11, the code is a valid ISBN.

            For example 0201103311 is a valid ISBN, since
            10*0 + 9*2 + 8*0 + 7*1 + 6*1 + 5*0 + 4*3 + 3*3 + 2*1 + 1*1 = 55.

            Each of the first nine digits can take a value between 0 and 9. Sometimes it is necessary to make the last digit equal to ten; this is done by writing the last digit as X. For example, 156881111X is a valid ISBN number.

            Your task is to fill in the missing digit from a given ISBN number where the missing digit is represented as '?'.
             

            Input
            * Line 1: A single line with a ten digit ISBN number that contains '?' in a single position
             

            Output
            * Line 1: The missing digit (0..9 or X). Output -1 if there is no acceptable digit for the position marked '?' that gives a valid ISBN.
             

            Sample Input
            15688?111X
             

            Sample Output
            1
             

            Source
             

             

            題目分析 :

            水題, 不錯還是 WA 了2次 , 很郁悶 , 主要是沒有注意到 題目描述中點一句話 :

            Each of the first nine digits can take a value between 0 and 9. Sometimes it is necessary to make the last digit equal to ten; this is done by writing the last digit as X. For example, 156881111X is a valid ISBN number.

            這句話是關鍵 , 意思就是 除了最后一個數(shù)字 可能是 X 外  其他的都只能為 0-9的數(shù)字.

             

            代碼如下 :

             /*

            Coded By  : MiYu

            Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu

            Author By : MiYu

            Test      : 1

            Program   : 2714

            */

            //#pragma warning( disable:4789 )

            #include <iostream>

            #include <algorithm>

            #include <string>

            #include <set>

            #include <map>

            #include <utility>

            #include <queue>

            #include <stack>

            #include <list>

            #include <vector>

            #include <cstdio>

            #include <cstdlib>

            #include <cstring>

            #include <cmath>

            using namespace std;

            int main ()

            {

                string str;

                while ( cin >> str )

                {

                      int N = str.size();

                      int sum = 0, ask = 0;

                      for ( int i = 1; i <= N; ++ i )

                      {

                           switch ( str[i-1] )

                           {

                                   case 'X':

                                            sum += (10-i+1) * 10;  break;

                                   case '?':

                                            ask = 10-i+1;  break;

                                   default :

                                            sum += (10-i+1) * (str[i-1] - '0');  break;      

                           }

                      } 

                      int pos = -1;

                      for ( int i = 0; i <= 10; ++ i )  

                      {

                           if ( ( sum + ask * i ) % 11 == 0 )

                           {

                                pos = i;

                                break;     

                           }    

                      } 

                      if ( ask != 1 && pos == 10 ) pos = -1; //沒有這句代碼 WA  2次  很郁悶.

                      if ( pos == 10 )

                         cout << 'X' << endl;  

                      else

                          cout << pos << endl;

                }

                return 0;

            }


             

            Feedback

            # re: HDOJ 2714 HDU 2714 ISBN ACM 2714 IN HDU  回復  更多評論   

            2012-03-09 21:40 by ACM小鳥~
            謝謝 你的慷慨幫助。
            99久久亚洲综合精品网站| 亚洲国产视频久久| 精品无码久久久久久午夜| 国产成人综合久久久久久| 久久国产精品-国产精品| 久久91精品国产91久| 91久久精品视频| 一本大道久久东京热无码AV| 久久亚洲高清观看| 色综合久久综合中文综合网| 久久免费大片| 久久se精品一区二区影院| 国产成人久久精品激情 | 久久亚洲国产最新网站| 亚洲色婷婷综合久久| 久久久久久久女国产乱让韩| 人人狠狠综合88综合久久| 精品久久人人爽天天玩人人妻 | 66精品综合久久久久久久| 亚洲国产精品综合久久一线| 波多野结衣中文字幕久久| 精品国产日韩久久亚洲| 国产激情久久久久影院| 狼狼综合久久久久综合网| 久久精品午夜一区二区福利| 99久久99久久精品免费看蜜桃| 狠狠色丁香久久婷婷综合五月| 久久天天躁狠狠躁夜夜av浪潮| 国产精品久久久久天天影视| 久久WWW免费人成一看片| 欧美日韩精品久久久免费观看| 伊人久久免费视频| 国产精品久久久久久久| 久久久女人与动物群交毛片| 久久人人爽人人爽人人av东京热| 色综合久久天天综线观看| 久久精品国产只有精品66| 99久久99久久精品国产片果冻| 亚洲精品乱码久久久久久蜜桃| 久久久免费观成人影院 | 久久久久九国产精品|