锘??xml version="1.0" encoding="utf-8" standalone="yes"?>久久青青国产,久久国产精品成人免费,国产精品久久久久久久apphttp://www.shnenglu.com/MiYu/category/14404.html ______________鐧界櫧銇眿zh-cnFri, 10 Sep 2010 10:27:34 GMTFri, 10 Sep 2010 10:27:34 GMT60HDOJ 1063 HDU 1063 Exponentiation JAVA 緙栧啓 ACM 1063 IN HDUhttp://www.shnenglu.com/MiYu/archive/2010/09/10/126325.htmlMiYuMiYuFri, 10 Sep 2010 09:01:00 GMThttp://www.shnenglu.com/MiYu/archive/2010/09/10/126325.htmlhttp://www.shnenglu.com/MiYu/comments/126325.htmlhttp://www.shnenglu.com/MiYu/archive/2010/09/10/126325.html#Feedback0http://www.shnenglu.com/MiYu/comments/commentRss/126325.htmlhttp://www.shnenglu.com/MiYu/services/trackbacks/126325.htmlMiYu鍘熷垱, 杞笘璇鋒敞鏄?: 杞澆鑷?nbsp;______________鐧界櫧銇眿    

 

棰樼洰鍦板潃:  http://acm.hdu.edu.cn/showproblem.php?pid=1063

棰樼洰鎻忚堪:

Exponentiation

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1696    Accepted Submission(s): 376


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
 

Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
 

Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
 

榪欎袱澶╃獊鐒舵兂瀛︿範涓婮AVA 鐨勫ぇ鏁?nbsp; 灝卞涔犱簡涓涓? 榪欓亾棰樺湪PKU A鎺変簡鐨? 涓嶈繃鍦?HDU 涓鐩存病榪? 涓嶇煡閬撴湁浠涔堟伓蹇冪殑鏁版嵁鎶婃垜緇欐伓蹇冩帀浜? 寰堥儊闂?

涓嶈繃 鐢↗AVA鐩存帴 1 A 浜?.......... 寰堢畝鍗曠殑璇?/p>

 

浠g爜濡備笅 :

 

/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */
import java.util.Scanner;
import java.math.*;

/**
 *
 * @author baiyun
 */
public class Main {

    /**
     * @param args the command line arguments
     */
    public static void main(String[] args) {
        Scanner in = new Scanner ( System.in );
        BigDecimal num;
        int exp;
        while ( in.hasNext() ){
            num = in.nextBigDecimal();
            exp = in.nextInt();
            num = num.pow ( exp );
            num = num.stripTrailingZeros();
            String out = num.toPlainString();
            if ( out.charAt(0) == '0' )
                 out = out.substring(1);
            System.out.println( out );
        }
    }
}

 


 



MiYu 2010-09-10 17:01 鍙戣〃璇勮
]]>
91精品国产综合久久婷婷| 国内精品久久久久久久涩爱 | 亚洲人成网站999久久久综合 | 免费一级做a爰片久久毛片潮| 久久综合狠狠综合久久97色| 久久人人爽人人爽人人片AV不 | 久久久久久国产精品免费免费 | 蜜臀av性久久久久蜜臀aⅴ | 久久99精品久久久久婷婷| 一本色道久久88加勒比—综合| 欧美久久久久久精选9999| 麻豆精品久久久久久久99蜜桃 | 亚洲伊人久久成综合人影院 | 精品多毛少妇人妻AV免费久久| 国产精品久久久亚洲| 国产精品99久久久久久宅男小说| 浪潮AV色综合久久天堂| 久久久不卡国产精品一区二区| 亚洲精品乱码久久久久久蜜桃图片 | 久久久久久国产a免费观看黄色大片| 久久久一本精品99久久精品88| 久久99精品九九九久久婷婷| 久久中文骚妇内射| 久久亚洲日韩看片无码| 日本久久久久久久久久| 91性高湖久久久久| 99久久er这里只有精品18| 无码久久精品国产亚洲Av影片| 亚洲人成无码www久久久| 成人精品一区二区久久久| 国产精品久久久天天影视| 久久精品无码一区二区无码| 中文字幕乱码久久午夜| 一级a性色生活片久久无 | 久久久久亚洲精品无码蜜桃| 亚洲国产成人久久笫一页| 久久国产精品无码网站| 久久午夜综合久久| 欧美日韩中文字幕久久久不卡| 久久久久婷婷| 无码任你躁久久久久久老妇|