• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年9月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋    

             

            題目地址:  http://acm.hdu.edu.cn/showproblem.php?pid=1063

            題目描述:

            Exponentiation

            Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
            Total Submission(s): 1696    Accepted Submission(s): 376


            Problem Description
            Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

            This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
             

            Input
            The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
             

            Output
            The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
             

            Sample Input
            95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
             

            Sample Output
            548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
             

            這兩天突然想學習下JAVA 的大數  就學習了一下, 這道題在PKU A掉了的, 不過在 HDU 一直沒過, 不知道有什么惡心的數據把我給惡心掉了, 很郁悶.

            不過 用JAVA直接 1 A 了........... 很簡單的說

             

            代碼如下 :

             

            /*
             * To change this template, choose Tools | Templates
             * and open the template in the editor.
             */
            import java.util.Scanner;
            import java.math.*;

            /**
             *
             * @author baiyun
             */
            public class Main {

                /**
                 * @param args the command line arguments
                 */
                public static void main(String[] args) {
                    Scanner in = new Scanner ( System.in );
                    BigDecimal num;
                    int exp;
                    while ( in.hasNext() ){
                        num = in.nextBigDecimal();
                        exp = in.nextInt();
                        num = num.pow ( exp );
                        num = num.stripTrailingZeros();
                        String out = num.toPlainString();
                        if ( out.charAt(0) == '0' )
                             out = out.substring(1);
                        System.out.println( out );
                    }
                }
            }

             


             

            99久久亚洲综合精品成人| 亚洲国产一成久久精品国产成人综合| 久久国产免费直播| 久久人爽人人爽人人片AV| 久久久久久国产精品免费无码| 九九久久99综合一区二区| 久久久久久av无码免费看大片| 一本一道久久综合狠狠老| 国产精品一久久香蕉国产线看| 99久久精品国产毛片| 亚洲午夜福利精品久久| 99久久精品日本一区二区免费| 久久天天躁狠狠躁夜夜2020 | 伊人久久大香线蕉av不卡| 国产精品青草久久久久婷婷| 久久精品国产精品亚洲| 久久青青草原精品国产| 亚洲国产成人久久综合一区77 | 日本精品久久久久中文字幕8| 久久精品国产清自在天天线| 精品久久久久久国产潘金莲| 一97日本道伊人久久综合影院| 精品久久久久久中文字幕| 亚洲人成精品久久久久| 亚洲欧美日韩久久精品| 久久996热精品xxxx| 久久精品视频免费| 久久精品国产亚洲av麻豆小说| 天天做夜夜做久久做狠狠| 久久婷婷综合中文字幕| 久久精品人人做人人爽电影蜜月 | 久久成人国产精品免费软件| 狠狠色丁香久久综合五月| 麻豆成人久久精品二区三区免费| 亚洲国产日韩欧美久久| 九九热久久免费视频| 亚洲综合婷婷久久| 国产福利电影一区二区三区久久久久成人精品综合 | 一本色道久久88综合日韩精品| 91精品观看91久久久久久 | 久久嫩草影院免费看夜色|