Posted on 2010-09-10 17:01
MiYu 閱讀(669)
評(píng)論(0) 編輯 收藏 引用 所屬分類:
JAVA 、
ACM ( 大數(shù) )
MiYu原創(chuàng), 轉(zhuǎn)帖請(qǐng)注明 : 轉(zhuǎn)載自 ______________白白の屋
題目地址: http://acm.hdu.edu.cn/showproblem.php?pid=1063
題目描述:
Exponentiation
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1696 Accepted Submission(s): 376
Problem Description
Problems
involving the computation of exact values of very large magnitude and
precision are common. For example, the computation of the national debt
is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input
The
input will consist of a set of pairs of values for R and n. The R
value will occupy columns 1 through 6, and the n value will be in
columns 8 and 9.
Output
The
output will consist of one line for each line of input giving the
exact value of R^n. Leading zeros should be suppressed in the output.
Insignificant trailing zeros must not be printed. Don't print the
decimal point if the result is an integer.
Sample Input
95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12
Sample Output
548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201
這兩天突然想學(xué)習(xí)下JAVA 的大數(shù) 就學(xué)習(xí)了一下, 這道題在PKU A掉了的, 不過在 HDU 一直沒過, 不知道有什么惡心的數(shù)據(jù)把我給惡心掉了, 很郁悶.
不過 用JAVA直接 1 A 了........... 很簡(jiǎn)單的說(shuō)
代碼如下 :
/*
* To change this template, choose Tools | Templates
* and open the template in the editor.
*/
import java.util.Scanner;
import java.math.*;
/**
*
* @author baiyun
*/
public class Main {
/**
* @param args the command line arguments
*/
public static void main(String[] args) {
Scanner in = new Scanner ( System.in );
BigDecimal num;
int exp;
while ( in.hasNext() ){
num = in.nextBigDecimal();
exp = in.nextInt();
num = num.pow ( exp );
num = num.stripTrailingZeros();
String out = num.toPlainString();
if ( out.charAt(0) == '0' )
out = out.substring(1);
System.out.println( out );
}
}
}