• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年8月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU

            Posted on 2010-09-18 11:29 MiYu 閱讀(1870) 評論(2)  編輯 收藏 引用 所屬分類: ACM ( 水題 )

            MiYu原創(chuàng), 轉(zhuǎn)帖請注明 : 轉(zhuǎn)載自 ______________白白の屋    

             

            題目地址:

              http://acm.hdu.edu.cn/showproblem.php?pid=1070

            題目描述:

            Milk

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
            Total Submission(s): 4483    Accepted Submission(s): 983


            Problem Description
            Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

            Here are some rules:
            1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
            2. Ignatius drinks 200mL milk everyday.
            3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
            4. All the milk in the supermarket is just produced today.

            Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
            Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
             

            Input
            The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
            Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
             

            Output
            For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
             

            Sample Input
            2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
             

            Sample Output
            Mengniu Mengniu
            Hint
            In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
             

             

            題目分析 :

              SHIT!!!!

              很簡單的一道水題!!   竟然 讓我 WA 7 次.  日了 .    

              沒仔細看清題目啊 ,  以為是水題就大意了..............    注意輸出的 后面有一點  TIP :   

                If there are more than one cheapest brand, you should output the one which has the largest volume.

               其他的就是 算出 平均每天的 花費 排個序就OK了 .  但是這里又 讓我 惡心了 :

                對DOUBLE 型排序 用  :

                   if ( a.wei - b.wei > 1e-7 )

                    return true;

                  else if ( a.wei - b.wei < 1e-7 )

                    return false;

                  else return a.vol > b.vol;

                竟然是 WA  !!!!!!  硬是改用:

                   if ( a.wei != b.wei )  //  double  這樣比不會有精度問題 ???

                          return a.wei < b.wei;

                      else return a.vol > b.vol; 

                就AC 了 !!! ....做了這么久的題才發(fā)現(xiàn) 原來 DOUBLE  是這樣比的?!?!??!?!?   

                求 解釋.............. 

             

            AC  代碼如下 :

             /*

            Coded By  : MiYu

            Link      : Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu

            Author By : MiYu

            Test      : 1

            Program   : 1070

            */

            //#pragma warning( disable:4789 )

            #include <iostream>

            #include <algorithm>

            #include <string>

            #include <set>

            #include <map>

            #include <utility>

            #include <queue>

            #include <stack>

            #include <list>

            #include <vector>

            #include <cstdio>

            #include <cstdlib>

            #include <cstring>

            #include <cmath>

            using namespace std;

            typedef struct milk {

                   char name[110];

                   int pay;

                   int vol; 

                   double wei;    

            }ML;

            ML M;

            bool cmp ( const ML &a, const ML &b ){

                 if ( a.wei != b.wei )

                    return a.wei < b.wei;

                 else return a.vol > b.vol;  

            int main ()

            {

                int T;

                cin >> T; 

                while ( T -- ){

                      int N;

                      vector <ML> vec;

                      cin >> N;

                      for ( int i = 0; i < N; ++ i ){

                           cin >> M.name >> M.pay >> M.vol;

                           int d = 0;

                           int t = M.vol;

                           while ( t >= 200 && d <= 4 ){

                                 d ++;

                                 t -= 200;  

                           }

                           if ( d ) {

                               M.wei = M.pay * 1.0 / d; 

                               vec.push_back ( M );

                           }

                      }       

                      sort ( vec.begin(), vec.end(), cmp );

                      cout << vec[0].name << endl;

                }

                return 0;

            }


             

             

             

            Feedback

            # re: HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU  回復(fù)  更多評論   

            2010-09-24 12:19 by Tanky Woo
            代碼這么少,我等會也去做做。

            # re: HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU  回復(fù)  更多評論   

            2010-09-25 20:27 by MiYu
            很水的題, 就是那個 cmp 函數(shù) 害我錯 7次, 不知道為什么, 以前一直哪有寫的沒錯, 這題就錯了 ................double 還能用 != 比較, 0rz............
            精品国产热久久久福利| 久久天天躁狠狠躁夜夜2020| 久久天天躁狠狠躁夜夜2020 | 欧美黑人又粗又大久久久| 久久精品国产第一区二区| 91精品国产高清久久久久久91| 久久精品国产久精国产思思| 久久久女人与动物群交毛片| 久久天天躁狠狠躁夜夜躁2O2O| 久久久久人妻精品一区| 国产精品一区二区久久国产| 国产成人久久AV免费| 久久亚洲国产精品一区二区| 国产A级毛片久久久精品毛片| 久久久精品一区二区三区| 久久最新精品国产| 欧美粉嫩小泬久久久久久久| 久久青青草原综合伊人| 久久九九青青国产精品| 精品99久久aaa一级毛片| 久久久国产视频| 丁香色欲久久久久久综合网| 久久国产精品无码一区二区三区| 丰满少妇人妻久久久久久| 久久91精品综合国产首页| 四虎国产精品成人免费久久| 久久亚洲中文字幕精品有坂深雪 | 久久精品女人天堂AV麻| 久久久久久国产精品无码下载 | 久久精品国产亚洲AV无码偷窥| 色综合久久中文综合网| 麻豆国内精品久久久久久| 亚洲人成伊人成综合网久久久 | 亚洲精品无码久久毛片| 精品无码久久久久国产| 理论片午午伦夜理片久久 | 97视频久久久| 91精品国产91久久| 三级三级久久三级久久| 久久996热精品xxxx| 国产精品久久久久AV福利动漫|