• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年8月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋    

             

            題目地址:

            http://poj.org/problem?id=1258

            題目描述:

            Agri-Net
            Time Limit: 1000MSMemory Limit: 10000K
            Total Submissions: 16557Accepted: 6745

            Description

            Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
            Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
            Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
            The distance between any two farms will not exceed 100,000. 

            Input

            The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

            Output

            For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

            Sample Input

            4
            0 4 9 21
            4 0 8 17
            9 8 0 16
            21 17 16 0
            

            Sample Output

            28

            題目分析 :
             	MST 水題, 用KRUSKARL 或 PRIM 輕松能過.
            代碼如下 :
            /*
            Mail to   : miyubai@gamil.com
            MyBlog    : http://baiyun.me
            Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu
            Author By : MiYu
            Test      : 1
            Complier  : g++ mingw32-3.4.2
            Program   : Agri-Net
            Doc Name  : PKU_1258
            */
            //#pragma warning( disable:4789 )
            #include <iostream>
            #include <fstream>
            #include <sstream>
            #include <algorithm>
            #include <string>
            #include <set>
            #include <map>
            #include <utility>
            #include <queue>
            #include <stack>
            #include <list>
            #include <vector>
            #include <cstdio>
            #include <cstdlib>
            #include <cstring>
            #include <cmath>
            #include <ctime>
            using namespace std;
            const int MAX = 105;
            int st[105];
            int N, x, y, w;
            struct vv {
                   int x, y, val;
                   void set ( int a, int b, int w ) { x=a,y=b,val=w; }
            
            }v[10005];       
            bool cmp ( const vv &a, const vv &b ) {
                      return a.val < b.val;     
            }
            void creat () {
                 for ( int i = 0; i <= N; ++ i )
                      st[i] = i;     
            }
            int find ( int x ) {
                return x != st[x] ? find ( st[x] ) : x;    
            }
            void merge ( int x, int y ) {
                 x = find ( x );
                 y = find ( y );
                 if ( x == y ) return;
                 st[y] = x;     
            }
            int main ()
            {
                while ( scanf ( "%d", &N )==1) {
                       creat ();
                       memset ( v, 0, sizeof ( v ) );
                       int c = 0;
                       for ( int i = 1; i <= N; ++ i ) {
                            for ( int j = 1; j <= N; ++ j ) {
                                 scanf ( "%d", &w );  
                                 v[c++].set ( i,j,w );  
                            }    
                       }     
                       sort ( v, v + c, cmp );
                       int sum = 0;
                       for ( int i = 0 ; i < c; ++ i ) {
                            if ( find ( v[i].x ) != find ( v[i].y ) ) {
                                sum += v[i].val;  
                                merge ( v[i].x, v[i].y );
                            }    
                       }
                       printf ( "%d\n", sum );
                }
                return 0;
            }
            

             

            久久精品国产清高在天天线| 91精品观看91久久久久久 | 奇米影视7777久久精品人人爽| 久久99精品国产麻豆不卡| 要久久爱在线免费观看| 久久精品国产精品亚洲毛片| 久久国产精品一区| 亚洲精品无码久久千人斩| 欧美伊香蕉久久综合类网站| 久久综合九色综合久99| 99久久久精品免费观看国产| 久久久久久亚洲精品不卡| 99国产欧美精品久久久蜜芽| 亚洲日韩欧美一区久久久久我| 国产精品久久久久久影院 | 国产精品久久久久久久久鸭| 久久国产高清一区二区三区| 新狼窝色AV性久久久久久| 欧美精品丝袜久久久中文字幕| 97精品久久天干天天天按摩| 久久无码中文字幕东京热| 国产成人精品久久综合| MM131亚洲国产美女久久| 丁香色欲久久久久久综合网| 久久精品国产国产精品四凭| 久久精品国内一区二区三区| 奇米影视7777久久精品| 中文精品久久久久人妻不卡| 日本国产精品久久| 中文字幕精品久久| 色妞色综合久久夜夜| 中文字幕无码av激情不卡久久| 日韩欧美亚洲国产精品字幕久久久 | 国产色综合久久无码有码| 欧美大战日韩91综合一区婷婷久久青草| av无码久久久久不卡免费网站| 亚洲欧洲日产国码无码久久99| 久久99精品国产麻豆宅宅| 久久九九兔免费精品6| 久久99精品国产麻豆宅宅| 亚洲中文字幕无码久久综合网|