• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年11月>
            31123456
            78910111213
            14151617181920
            21222324252627
            2829301234
            567891011

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            HDOJ 2714 HDU 2714 ISBN ACM 2714 IN HDU

            Posted on 2010-09-25 20:25 MiYu 閱讀(442) 評論(1)  編輯 收藏 引用 所屬分類: ACM ( 水題 )

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋    

            題目地址 :

            http://acm.hdu.edu.cn/showproblem.php?pid=2714

            題目描述:

            ISBN

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
            Total Submission(s): 566    Accepted Submission(s): 172


            Problem Description
            Farmer John's cows enjoy reading books, and FJ has discovered that his cows produce more milk when they read books of a somewhat intellectual nature. He decides to update the barn library to replace all of the cheap romance novels with textbooks on algorithms and mathematics. Unfortunately, a shipment of these new books has fallen in the mud and their ISBN numbers are now hard to read.

            An ISBN (International Standard Book Number) is a ten digit code that uniquely identifies a book. The first nine digits represent the book and the last digit is used to make sure the ISBN is correct. To verify that an ISBN number is correct, you calculate a sum that is 10 times the first digit plus 9 times the second digit plus 8 times the third digit ... all the way until you add 1 times the last digit. If the final number leaves no remainder when divided by 11, the code is a valid ISBN.

            For example 0201103311 is a valid ISBN, since
            10*0 + 9*2 + 8*0 + 7*1 + 6*1 + 5*0 + 4*3 + 3*3 + 2*1 + 1*1 = 55.

            Each of the first nine digits can take a value between 0 and 9. Sometimes it is necessary to make the last digit equal to ten; this is done by writing the last digit as X. For example, 156881111X is a valid ISBN number.

            Your task is to fill in the missing digit from a given ISBN number where the missing digit is represented as '?'.
             

            Input
            * Line 1: A single line with a ten digit ISBN number that contains '?' in a single position
             

            Output
            * Line 1: The missing digit (0..9 or X). Output -1 if there is no acceptable digit for the position marked '?' that gives a valid ISBN.
             

            Sample Input
            15688?111X
             

            Sample Output
            1
             

            Source
             

             

            題目分析 :

            水題, 不錯還是 WA 了2次 , 很郁悶 , 主要是沒有注意到 題目描述中點一句話 :

            Each of the first nine digits can take a value between 0 and 9. Sometimes it is necessary to make the last digit equal to ten; this is done by writing the last digit as X. For example, 156881111X is a valid ISBN number.

            這句話是關鍵 , 意思就是 除了最后一個數字 可能是 X 外  其他的都只能為 0-9的數字.

             

            代碼如下 :

             /*

            Coded By  : MiYu

            Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu

            Author By : MiYu

            Test      : 1

            Program   : 2714

            */

            //#pragma warning( disable:4789 )

            #include <iostream>

            #include <algorithm>

            #include <string>

            #include <set>

            #include <map>

            #include <utility>

            #include <queue>

            #include <stack>

            #include <list>

            #include <vector>

            #include <cstdio>

            #include <cstdlib>

            #include <cstring>

            #include <cmath>

            using namespace std;

            int main ()

            {

                string str;

                while ( cin >> str )

                {

                      int N = str.size();

                      int sum = 0, ask = 0;

                      for ( int i = 1; i <= N; ++ i )

                      {

                           switch ( str[i-1] )

                           {

                                   case 'X':

                                            sum += (10-i+1) * 10;  break;

                                   case '?':

                                            ask = 10-i+1;  break;

                                   default :

                                            sum += (10-i+1) * (str[i-1] - '0');  break;      

                           }

                      } 

                      int pos = -1;

                      for ( int i = 0; i <= 10; ++ i )  

                      {

                           if ( ( sum + ask * i ) % 11 == 0 )

                           {

                                pos = i;

                                break;     

                           }    

                      } 

                      if ( ask != 1 && pos == 10 ) pos = -1; //沒有這句代碼 WA  2次  很郁悶.

                      if ( pos == 10 )

                         cout << 'X' << endl;  

                      else

                          cout << pos << endl;

                }

                return 0;

            }


             

            Feedback

            # re: HDOJ 2714 HDU 2714 ISBN ACM 2714 IN HDU  回復  更多評論   

            2012-03-09 21:40 by ACM小鳥~
            謝謝 你的慷慨幫助。
            久久青青草原精品影院| 久久久久久久久久久| 久久精品久久久久观看99水蜜桃| 88久久精品无码一区二区毛片| 久久青青草原亚洲av无码app| 久久久久久亚洲精品影院| 色综合久久久久综合99| 精品乱码久久久久久夜夜嗨| 国产精品久久久久久影院 | 国内精品伊人久久久久| 久久久久久国产精品无码超碰| 国产69精品久久久久9999APGF| 久久99久久99精品免视看动漫| 久久婷婷五月综合成人D啪| 久久精品极品盛宴观看| 亚洲综合伊人久久大杳蕉| 亚洲国产精品无码久久久不卡| 久久精品免费一区二区| 久久久久人妻精品一区| 久久精品www| 精品欧美一区二区三区久久久| 亚洲v国产v天堂a无码久久| 久久人人爽人人爽人人片AV麻烦| 日韩人妻无码精品久久久不卡| 久久免费的精品国产V∧| 99热精品久久只有精品| 久久人人爽人人精品视频| 久久精品国产精品亚洲精品| 77777亚洲午夜久久多喷| 久久久WWW免费人成精品| 香蕉久久久久久狠狠色| 久久久久AV综合网成人| 一本久久久久久久| 国产精品99久久久精品无码 | 久久精品国产第一区二区| 亚洲国产精品无码久久久久久曰 | 亚洲精品无码久久一线| 狠狠狠色丁香婷婷综合久久五月| 久久免费香蕉视频| 精品国际久久久久999波多野| 品成人欧美大片久久国产欧美...|