• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年10月>
            262728293012
            3456789
            10111213141516
            17181920212223
            24252627282930
            31123456

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU

            Posted on 2010-09-18 11:29 MiYu 閱讀(1871) 評論(2)  編輯 收藏 引用 所屬分類: ACM ( 水題 )

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋    

             

            題目地址:

              http://acm.hdu.edu.cn/showproblem.php?pid=1070

            題目描述:

            Milk

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
            Total Submission(s): 4483    Accepted Submission(s): 983


            Problem Description
            Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

            Here are some rules:
            1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
            2. Ignatius drinks 200mL milk everyday.
            3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
            4. All the milk in the supermarket is just produced today.

            Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
            Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
             

            Input
            The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
            Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
             

            Output
            For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
             

            Sample Input
            2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
             

            Sample Output
            Mengniu Mengniu
            Hint
            In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
             

             

            題目分析 :

              SHIT!!!!

              很簡單的一道水題!!   竟然 讓我 WA 7 次.  日了 .    

              沒仔細看清題目啊 ,  以為是水題就大意了..............    注意輸出的 后面有一點  TIP :   

                If there are more than one cheapest brand, you should output the one which has the largest volume.

               其他的就是 算出 平均每天的 花費 排個序就OK了 .  但是這里又 讓我 惡心了 :

                對DOUBLE 型排序 用  :

                   if ( a.wei - b.wei > 1e-7 )

                    return true;

                  else if ( a.wei - b.wei < 1e-7 )

                    return false;

                  else return a.vol > b.vol;

                竟然是 WA  !!!!!!  硬是改用:

                   if ( a.wei != b.wei )  //  double  這樣比不會有精度問題 ???

                          return a.wei < b.wei;

                      else return a.vol > b.vol; 

                就AC 了 !!! ....做了這么久的題才發現 原來 DOUBLE  是這樣比的?!?!??!?!?   

                求 解釋.............. 

             

            AC  代碼如下 :

             /*

            Coded By  : MiYu

            Link      : Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu

            Author By : MiYu

            Test      : 1

            Program   : 1070

            */

            //#pragma warning( disable:4789 )

            #include <iostream>

            #include <algorithm>

            #include <string>

            #include <set>

            #include <map>

            #include <utility>

            #include <queue>

            #include <stack>

            #include <list>

            #include <vector>

            #include <cstdio>

            #include <cstdlib>

            #include <cstring>

            #include <cmath>

            using namespace std;

            typedef struct milk {

                   char name[110];

                   int pay;

                   int vol; 

                   double wei;    

            }ML;

            ML M;

            bool cmp ( const ML &a, const ML &b ){

                 if ( a.wei != b.wei )

                    return a.wei < b.wei;

                 else return a.vol > b.vol;  

            int main ()

            {

                int T;

                cin >> T; 

                while ( T -- ){

                      int N;

                      vector <ML> vec;

                      cin >> N;

                      for ( int i = 0; i < N; ++ i ){

                           cin >> M.name >> M.pay >> M.vol;

                           int d = 0;

                           int t = M.vol;

                           while ( t >= 200 && d <= 4 ){

                                 d ++;

                                 t -= 200;  

                           }

                           if ( d ) {

                               M.wei = M.pay * 1.0 / d; 

                               vec.push_back ( M );

                           }

                      }       

                      sort ( vec.begin(), vec.end(), cmp );

                      cout << vec[0].name << endl;

                }

                return 0;

            }


             

             

             

            Feedback

            # re: HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU  回復  更多評論   

            2010-09-24 12:19 by Tanky Woo
            代碼這么少,我等會也去做做。

            # re: HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU  回復  更多評論   

            2010-09-25 20:27 by MiYu
            很水的題, 就是那個 cmp 函數 害我錯 7次, 不知道為什么, 以前一直哪有寫的沒錯, 這題就錯了 ................double 還能用 != 比較, 0rz............
            国产成人精品综合久久久久| 久久天天躁狠狠躁夜夜2020 | 奇米影视7777久久精品| 久久久久亚洲AV无码专区体验| 成人久久精品一区二区三区| 国产精品青草久久久久福利99| 久久影院亚洲一区| www.久久热.com| 东方aⅴ免费观看久久av| 成人a毛片久久免费播放| 伊人久久成人成综合网222| 久久91综合国产91久久精品| 亚洲va久久久久| 国产精品伊人久久伊人电影| 亚洲欧美日韩中文久久 | 国产成人精品久久免费动漫| 亚洲国产成人久久综合碰| 久久精品国产久精国产| 性欧美丰满熟妇XXXX性久久久 | 精品无码人妻久久久久久| 精品久久久无码人妻中文字幕豆芽| 久久久久婷婷| 99久久精品免费看国产一区二区三区| 亚洲午夜久久久久妓女影院| 亚洲欧美国产精品专区久久| 狠狠色丁香婷综合久久| 精品国产乱码久久久久久郑州公司| 亚洲人成无码www久久久| 久久免费国产精品| 国产精品美女久久久久av爽| 亚洲一本综合久久| 久久精品免费一区二区三区| 狠狠色婷婷综合天天久久丁香| 久久婷婷五月综合成人D啪 | 日韩亚洲国产综合久久久| 国内精品久久久久影院网站 | 久久亚洲精品无码aⅴ大香 | 欧美成a人片免费看久久| 97精品国产91久久久久久| 日韩精品久久无码中文字幕| 久久强奷乱码老熟女网站|