• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年9月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU

            Posted on 2010-09-18 11:29 MiYu 閱讀(1870) 評論(2)  編輯 收藏 引用 所屬分類: ACM ( 水題 )

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋    

             

            題目地址:

              http://acm.hdu.edu.cn/showproblem.php?pid=1070

            題目描述:

            Milk

            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
            Total Submission(s): 4483    Accepted Submission(s): 983


            Problem Description
            Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

            Here are some rules:
            1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
            2. Ignatius drinks 200mL milk everyday.
            3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
            4. All the milk in the supermarket is just produced today.

            Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
            Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
             

            Input
            The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
            Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
             

            Output
            For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
             

            Sample Input
            2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
             

            Sample Output
            Mengniu Mengniu
            Hint
            In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
             

             

            題目分析 :

              SHIT!!!!

              很簡單的一道水題!!   竟然 讓我 WA 7 次.  日了 .    

              沒仔細看清題目啊 ,  以為是水題就大意了..............    注意輸出的 后面有一點  TIP :   

                If there are more than one cheapest brand, you should output the one which has the largest volume.

               其他的就是 算出 平均每天的 花費 排個序就OK了 .  但是這里又 讓我 惡心了 :

                對DOUBLE 型排序 用  :

                   if ( a.wei - b.wei > 1e-7 )

                    return true;

                  else if ( a.wei - b.wei < 1e-7 )

                    return false;

                  else return a.vol > b.vol;

                竟然是 WA  !!!!!!  硬是改用:

                   if ( a.wei != b.wei )  //  double  這樣比不會有精度問題 ???

                          return a.wei < b.wei;

                      else return a.vol > b.vol; 

                就AC 了 !!! ....做了這么久的題才發現 原來 DOUBLE  是這樣比的?!?!??!?!?   

                求 解釋.............. 

             

            AC  代碼如下 :

             /*

            Coded By  : MiYu

            Link      : Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu

            Author By : MiYu

            Test      : 1

            Program   : 1070

            */

            //#pragma warning( disable:4789 )

            #include <iostream>

            #include <algorithm>

            #include <string>

            #include <set>

            #include <map>

            #include <utility>

            #include <queue>

            #include <stack>

            #include <list>

            #include <vector>

            #include <cstdio>

            #include <cstdlib>

            #include <cstring>

            #include <cmath>

            using namespace std;

            typedef struct milk {

                   char name[110];

                   int pay;

                   int vol; 

                   double wei;    

            }ML;

            ML M;

            bool cmp ( const ML &a, const ML &b ){

                 if ( a.wei != b.wei )

                    return a.wei < b.wei;

                 else return a.vol > b.vol;  

            int main ()

            {

                int T;

                cin >> T; 

                while ( T -- ){

                      int N;

                      vector <ML> vec;

                      cin >> N;

                      for ( int i = 0; i < N; ++ i ){

                           cin >> M.name >> M.pay >> M.vol;

                           int d = 0;

                           int t = M.vol;

                           while ( t >= 200 && d <= 4 ){

                                 d ++;

                                 t -= 200;  

                           }

                           if ( d ) {

                               M.wei = M.pay * 1.0 / d; 

                               vec.push_back ( M );

                           }

                      }       

                      sort ( vec.begin(), vec.end(), cmp );

                      cout << vec[0].name << endl;

                }

                return 0;

            }


             

             

             

            Feedback

            # re: HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU  回復  更多評論   

            2010-09-24 12:19 by Tanky Woo
            代碼這么少,我等會也去做做。

            # re: HDOJ 1070 HDU 1070 Milk ACM 1070 IN HDU  回復  更多評論   

            2010-09-25 20:27 by MiYu
            很水的題, 就是那個 cmp 函數 害我錯 7次, 不知道為什么, 以前一直哪有寫的沒錯, 這題就錯了 ................double 還能用 != 比較, 0rz............
            久久无码人妻一区二区三区| 久久精品国产精品亜洲毛片| 久久国产亚洲精品无码| 狠色狠色狠狠色综合久久| 久久精品国产一区二区电影| 亚洲精品白浆高清久久久久久| 97热久久免费频精品99| 久久久久97国产精华液好用吗| 三级三级久久三级久久| 国产亚洲欧美成人久久片 | 亚洲国产精品久久电影欧美| 99久久成人国产精品免费| 久久综合狠狠综合久久97色| 97久久精品午夜一区二区| 亚洲欧美日韩久久精品| 伊人久久大香线焦综合四虎| 久久无码专区国产精品发布| 国产AV影片久久久久久| 久久久久人妻精品一区二区三区 | 狠狠色噜噜色狠狠狠综合久久| 青青草国产成人久久91网| 久久综合偷偷噜噜噜色| 国产精品九九久久免费视频| 久久精品人人做人人爽97| 怡红院日本一道日本久久| 精产国品久久一二三产区区别| 久久精品中文字幕一区| 国产亚洲婷婷香蕉久久精品| 久久棈精品久久久久久噜噜| 怡红院日本一道日本久久| 99久久精品久久久久久清纯| www久久久天天com| 久久亚洲私人国产精品vA| 波多野结衣AV无码久久一区| 尹人香蕉久久99天天拍| 欧美一级久久久久久久大| 久久免费视频6| 亚洲色欲久久久久综合网| 欧美久久综合九色综合| 亚洲国产精品狼友中文久久久| 久久99精品九九九久久婷婷|