Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3841 Accepted Submission(s): 1675
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
Sample Output
Case 1: The total value of the hook is 24.
標(biāo)準(zhǔn)的線段樹, 成段更新 ,...... 具體看 代碼 注釋 .
代碼如下 :
/*
Coded By : MiYu
Link : http://www.cnblogs.com/MiYu || http://www.shnenglu.com/MiYu
Author By : MiYu
Test : 1
Program : 1698
*/
//#pragma warning( disable:4789 )
#include <iostream>
#include <algorithm>
#include <string>
#include <set>
#include <map>
#include <utility>
#include <queue>
#include <stack>
#include <list>
#include <vector>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;
typedef struct seg_tree{
int left, right, col;
bool cov; //標(biāo)記當(dāng)前線段是否被覆蓋, 如果true, 表示這一段線段的值都為 col. false則相反
int mid (){ return (left + right) >> 1; }
}SEG;
SEG seg[300010];
void creat ( int beg, int end, int rt = 1 ){
seg[rt].left = beg;
seg[rt].right = end;
seg[rt].col = 1;
seg[rt].cov = true;
if ( beg == end ) return;
int mid = seg[rt].mid();
creat ( beg, mid, rt << 1 );
creat ( mid + 1, end, ( rt << 1 ) + 1 );
}
void modify ( int beg, int end, int val, int rt = 1 ){
int LL = rt << 1;
int RR = ( rt << 1 ) + 1;
if ( seg[rt].left == beg && seg[rt].right == end ){ //線段被覆蓋, 標(biāo)記 cov 為true
seg[rt].cov = true;
seg[rt].col = val;
return ;
}
if ( seg[rt].cov ){ //如果線段曾經(jīng)被覆蓋, 標(biāo)記 false, 將col往下傳
seg[rt].cov = false;
seg[LL].col = seg[RR].col = seg[rt].col;
seg[LL].cov = seg[RR].cov = true;
}
int mid = seg[rt].mid();
if ( end <= mid ){
modify ( beg, end, val, LL );
} else if ( beg > mid ) {
modify ( beg, end, val, RR );
} else {
modify ( beg, mid, val, LL );
modify ( mid + 1, end, val, RR );
}
}
int quy ( int beg, int end, int rt = 1 ){
if ( seg[rt].cov ){ // 線段如果是被覆蓋的 , 直接返回這一段區(qū)間的值
return ( seg[rt].right - seg[rt].left + 1 ) * seg[rt].col;
}
int mid = seg[rt].mid();
return quy ( beg, mid, rt << 1 ) + quy ( mid + 1, end, ( rt << 1 ) + 1 );
}
int main ()
{
int T, ca = 1;
scanf ( "%d", &T );
while ( T -- ){
int N;
scanf ( "%d", &N );
creat ( 1, N );
int M;
scanf ( "%d", &M );
for ( int i = 1; i <= M; ++ i ){
int beg, end, val;
scanf ( "%d%d%d", &beg, &end, &val );
modify ( beg, end, val );
}
printf ( "Case %d: The total value of the hook is %d.\n", ca++,quy( 1, N ) );
}
return 0;
}
/*
1
10
2
1 5 2
5 9 3
*/
/* 此為一牛人代碼 , 速度 非常快 !!!! 0rz.........
#include<stdio.h>
int a[100001][3],c[100001];
int main()
{
int t,i,j,n,m,sum,v,w=1;
scanf("%d",&t);
while(t--&&scanf("%d %d",&n,&m))
{
sum=0;
for(i=1;i<=m;i++)
scanf("%d %d %d",&a[i][0],&a[i][1],&a[i][2]);
for(i=1;i<=n;i++)
{
v=1;
for(j=m;j>=1;j--)
{
if(a[j][0]<=i&&a[j][1]>=i)
{
v=a[j][2];
break;
}
}
sum+=v;
}
printf("Case %d: The total value of the hook is %d.\n",w++,sum);
}
}
*/