• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設(shè)計(jì)空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            Organize Your Train part II
            Time Limit:1000MS? Memory Limit:65536K
            Total Submit:417 Accepted:211

            Description

            RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.


            Figure 1: Layout of the exchange lines

            A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

            Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

            For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

              [3:1]
            
            abc+d cba+d d+abc d+cba
            [2:2]
            ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
            [1:3]
            a+bcd a+dcb bcd+a dcb+a

            Excluding duplicates, 12 distinct configurations are possible.

            Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

            Input

            The entire input looks like the following.

            the number of datasets = m
            1st dataset
            2nd dataset
            ...
            m-th dataset

            Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

            Output

            For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

            Sample Input

            4
            aa
            abba
            abcd
            abcde

            Sample Output

            1
            6
            12
            18





            真不好意思 最近生病了 好幾天才回復(fù)你的問(wèn)題
            題目不難 簡(jiǎn)單模擬一下就可以了
            但是我覺(jué)得直接做比較麻煩 推薦STL做吧
            直接做可以用strrev等函數(shù)減少代碼量


            Solution
            //by Optimistic
            #include <string>
            #include <iostream>
            #include <algorithm>
            #include <vector>
            #include <set>
            using namespace std;
            int main()
            {
            ?int ns;
            ?vector<string> vs;
            ?int i;
            ?scanf("%d", &ns);
            ?while(ns--)
            ?{
            ??vs.clear();
            ??string s;
            ??cin >> s;
            ??for(i=1; i<s.length(); i++)
            ??{
            ???string a = s.substr(0, i);
            ???string b = s.substr(i);
            ???vs.push_back(a+b);
            ???vs.push_back(b+a);
            ???string ra(a);
            ???string rb(b);
            ???reverse(ra.begin(), ra.end());
            ???reverse(rb.begin(), rb.end());
            ???vs.push_back(a+rb);
            ???vs.push_back(ra+b);
            ???vs.push_back(rb+a);
            ???vs.push_back(b+ra);
            ???vs.push_back(ra+rb);
            ???vs.push_back(rb+ra);
            ??}
            ??set<string> ss(vs.begin(), vs.end());
            ??cout << ss.size() << endl;
            ?}
            ?return 0;
            }
            ?

            Feedback

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-04-16 05:12 by arena_zp
            TLE 啊。。。=___= 555555

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-04-16 13:14 by oyjpart
            o ?
            你的做法是這樣的嗎

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-09-21 11:54 by tec
            我直接把你的代碼復(fù)制上去 tle了

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II [未登錄](méi)  回復(fù)  更多評(píng)論   

            2008-09-25 02:19 by oyjpart
            加數(shù)據(jù)了吧,你把string換成char[]吧

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2009-08-04 00:58 by schindlerlee
            別用set了,把這兩句
            set<string> ss(vs.begin(), vs.end());
            cout << ss.size() << endl;
            換成
            sort(vs.begin(), vs.end());
            vector<string>::iterator iter = unique(vs.begin(), vs.end());
            cout << iter - vs.begin() << endl;

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2009-09-07 23:59 by oyjpart
            搞acm非要在乎這個(gè)參數(shù)時(shí)間的話,不如不用stl,直接去重好了:)
            中文字幕亚洲综合久久| 狠狠色婷婷久久综合频道日韩| 久久国产精品99久久久久久老狼| 国产成人精品久久| 77777亚洲午夜久久多喷| 狠狠色丁香婷婷综合久久来| 日本高清无卡码一区二区久久| 色诱久久久久综合网ywww| 国产免费久久久久久无码| 一本色道久久综合亚洲精品| 观看 国产综合久久久久鬼色 欧美 亚洲 一区二区 | 91精品观看91久久久久久| 久久久无码精品亚洲日韩蜜臀浪潮| 国内精品久久久久久野外| 久久精品国产男包| 久久黄视频| 91精品国产91热久久久久福利 | 久久亚洲AV无码精品色午夜| 国产成人精品久久一区二区三区| 伊人久久无码精品中文字幕| 久久99久久成人免费播放| 久久99精品久久久久婷婷| 人人妻久久人人澡人人爽人人精品| 国产午夜福利精品久久| 国产国产成人精品久久| 亚洲精品无码久久久久| 偷窥少妇久久久久久久久| 久久久久久久国产免费看| 国产成人精品久久亚洲| 免费观看成人久久网免费观看| 色诱久久久久综合网ywww| 亚洲AV无码1区2区久久| 成人久久免费网站| 久久久久国产精品嫩草影院| 亚洲午夜精品久久久久久app| 久久青青草原亚洲av无码| 国产精自产拍久久久久久蜜| 国产福利电影一区二区三区久久老子无码午夜伦不 | 男女久久久国产一区二区三区| 丁香色欲久久久久久综合网| 亚洲国产欧美国产综合久久|