• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設(shè)計(jì)空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            Organize Your Train part II
            Time Limit:1000MS? Memory Limit:65536K
            Total Submit:417 Accepted:211

            Description

            RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.


            Figure 1: Layout of the exchange lines

            A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

            Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

            For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

              [3:1]
            
            abc+d cba+d d+abc d+cba
            [2:2]
            ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
            [1:3]
            a+bcd a+dcb bcd+a dcb+a

            Excluding duplicates, 12 distinct configurations are possible.

            Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

            Input

            The entire input looks like the following.

            the number of datasets = m
            1st dataset
            2nd dataset
            ...
            m-th dataset

            Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

            Output

            For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

            Sample Input

            4
            aa
            abba
            abcd
            abcde

            Sample Output

            1
            6
            12
            18





            真不好意思 最近生病了 好幾天才回復(fù)你的問題
            題目不難 簡單模擬一下就可以了
            但是我覺得直接做比較麻煩 推薦STL做吧
            直接做可以用strrev等函數(shù)減少代碼量


            Solution
            //by Optimistic
            #include <string>
            #include <iostream>
            #include <algorithm>
            #include <vector>
            #include <set>
            using namespace std;
            int main()
            {
            ?int ns;
            ?vector<string> vs;
            ?int i;
            ?scanf("%d", &ns);
            ?while(ns--)
            ?{
            ??vs.clear();
            ??string s;
            ??cin >> s;
            ??for(i=1; i<s.length(); i++)
            ??{
            ???string a = s.substr(0, i);
            ???string b = s.substr(i);
            ???vs.push_back(a+b);
            ???vs.push_back(b+a);
            ???string ra(a);
            ???string rb(b);
            ???reverse(ra.begin(), ra.end());
            ???reverse(rb.begin(), rb.end());
            ???vs.push_back(a+rb);
            ???vs.push_back(ra+b);
            ???vs.push_back(rb+a);
            ???vs.push_back(b+ra);
            ???vs.push_back(ra+rb);
            ???vs.push_back(rb+ra);
            ??}
            ??set<string> ss(vs.begin(), vs.end());
            ??cout << ss.size() << endl;
            ?}
            ?return 0;
            }
            ?

            Feedback

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-04-16 05:12 by arena_zp
            TLE 啊。。。=___= 555555

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-04-16 13:14 by oyjpart
            o ?
            你的做法是這樣的嗎

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2008-09-21 11:54 by tec
            我直接把你的代碼復(fù)制上去 tle了

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II [未登錄]  回復(fù)  更多評(píng)論   

            2008-09-25 02:19 by oyjpart
            加數(shù)據(jù)了吧,你把string換成char[]吧

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2009-08-04 00:58 by schindlerlee
            別用set了,把這兩句
            set<string> ss(vs.begin(), vs.end());
            cout << ss.size() << endl;
            換成
            sort(vs.begin(), vs.end());
            vector<string>::iterator iter = unique(vs.begin(), vs.end());
            cout << iter - vs.begin() << endl;

            # re: Asked by Morpheus on PKU 3007 Organize Your Train part II   回復(fù)  更多評(píng)論   

            2009-09-07 23:59 by oyjpart
            搞acm非要在乎這個(gè)參數(shù)時(shí)間的話,不如不用stl,直接去重好了:)

            只有注冊用戶登錄后才能發(fā)表評(píng)論。
            網(wǎng)站導(dǎo)航: 博客園   IT新聞   BlogJava   博問   Chat2DB   管理


            久久久久一级精品亚洲国产成人综合AV区 | 午夜久久久久久禁播电影| 欧美无乱码久久久免费午夜一区二区三区中文字幕 | 久久国产精品久久国产精品| 久久亚洲国产午夜精品理论片| 中文字幕一区二区三区久久网站| 精品久久久久久久中文字幕 | 色诱久久久久综合网ywww | 99久久99久久| 久久久久这里只有精品| 一本色道久久综合狠狠躁| 久久国产一区二区| 狠狠精品久久久无码中文字幕| 99久久超碰中文字幕伊人| 国内精品伊人久久久影院| 色综合久久精品中文字幕首页| 久久久久久久97| 国产精品VIDEOSSEX久久发布| 色偷偷久久一区二区三区| 久久久精品国产亚洲成人满18免费网站| 久久久亚洲欧洲日产国码是AV| 91麻豆精品国产91久久久久久| 久久精品青青草原伊人| 久久人妻少妇嫩草AV蜜桃| 久久精品一区二区三区不卡| 色88久久久久高潮综合影院| 久久久久久极精品久久久| 人人狠狠综合久久亚洲88| 久久不见久久见免费影院www日本| 久久综合九色综合网站| 日本五月天婷久久网站| 久久国产精品波多野结衣AV | 一本色道久久88—综合亚洲精品| 久久er国产精品免费观看2| 亚洲国产欧美国产综合久久| 怡红院日本一道日本久久| 精品免费久久久久久久| 日韩人妻无码精品久久久不卡| 久久久噜噜噜久久中文字幕色伊伊| 香蕉aa三级久久毛片| 久久精品极品盛宴观看|