• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            隨筆 - 87  文章 - 279  trackbacks - 0
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            潛心看書研究!

            常用鏈接

            留言簿(19)

            隨筆分類(81)

            文章分類(89)

            相冊

            ACM OJ

            My friends

            搜索

            •  

            積分與排名

            • 積分 - 216652
            • 排名 - 117

            最新評論

            閱讀排行榜

            評論排行榜

            Post Office
            Time Limit:1000MS? Memory Limit:10000K
            Total Submit:1047 Accepted:456

            Description
            There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

            Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

            You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.

            Input
            Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

            Output
            The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

            Sample Input

            10 5
            1 2 3 6 7 9 11 22 44 50

            Sample Output

            9

            Source
            IOI 2000

            #include? < iostream >
            using ? namespace ?std;

            /*
            p表示i到j的建一個郵局的最小值
            q表示前i個地點建j個郵局的最小值?
            dp方程

            ?????????????????p[1][i]???????????????(j?==?1)
            ?q[i][j]?=?{????????????????????????????????????????????????????}
            ????????????????q[k][j-1]?+?p[k+1][i]??(j?>?1)?(k從j-1到i-1)

            */
            ?

            int ?p[ 301 ][ 301 ];
            int ?q[ 301 ][ 31 ];
            int ?a[ 301 ];

            int ?main()
            {
            ????
            int ?V,?P;
            ????
            int ?i,?j,?k,?l;
            ????
            int ?t[ 301 ];
            ????
            int ?tmp;
            ????scanf(
            " %d%d " ,? & V,? & P);
            ????
            ????
            for ?(i = 1 ;?i <= V;?i ++ )
            ????????scanf(
            " %d " ,? & a[i]);
            ????
            ????
            for ?(i = 1 ;?i <= V;?i ++ )
            ????????
            for ?(j = i;?j <= V;?j ++ )
            ????????
            {
            ????????????
            if ?(i? == ?j)
            ????????????????p[i][j]?
            = ? 0 ;
            ????????????
            else
            ????????????
            {
            ????????????????l?
            = ?(i? + ?j)? / ? 2 ;
            ????????????????p[i][j]?
            = ? 0 ;
            ????????????????
            for ?(k = i;?k <= l;?k ++ )
            ????????????????????p[i][j]?
            += ?a[l]? - ?a[k];
            ????????????????
            for ?(k = l + 1 ;?k <= j;?k ++ )
            ????????????????????p[i][j]?
            += ?a[k]? - ?a[l];
            ???????????????
            ????????????}

            ????????}

            ????????
            ????memset(q,?
            0 ,? sizeof (q));
            ????
            for ?(i = 1 ;?i <= V;?i ++ )
            ????????
            for ?(j = 1 ;?j <= P;?j ++ )
            ????????
            {
            ????????????
            if ?(j? == ? 1 )
            ????????????????q[i][j]?
            = ?p[ 1 ][i];
            ????????????
            else
            ????????????
            {
            ????????????????
            if ?(i? >= ?j)
            ????????????????
            {
            ????????????????????q[i][j]?
            = ?q[j - 1 ][j - 1 ]? + ?p[j][i];
            ????????????????????
            for ?(k = j;?k < i;?k ++ )
            ????????????????????
            {
            ????????????????????????
            if ?(q[i][j]? > ?q[k][j - 1 ]? + ?p[k + 1 ][i])
            ????????????????????????????q[i][j]?
            = ?q[k][j - 1 ]? + ?p[k + 1 ][i];
            ????????????????????}

            ????????????????}

            ????????????}

            ????????}

            ????????
            ????cout?
            << ?q[V][P]? << ?endl;
            ????system(
            " pause " );
            ????
            return ? 0 ;
            }

            posted on 2006-09-01 22:33 閱讀(446) 評論(0)  編輯 收藏 引用 所屬分類: ACM題目
            久久人妻AV中文字幕| 伊人久久大香线蕉成人| 一本色道久久88精品综合| 久久久WWW成人免费精品| 久久天天躁狠狠躁夜夜2020老熟妇| 国产欧美久久一区二区| 久久精品国产亚洲av高清漫画 | 国产免费久久久久久无码| 国产精品狼人久久久久影院| 91精品国产高清久久久久久91 | 国产女人aaa级久久久级| 久久免费精品视频| 国产99久久久国产精免费| 久久93精品国产91久久综合| www亚洲欲色成人久久精品| 精品久久久久久无码人妻热| 亚洲欧美久久久久9999| 国产精品久久久久久久app| 久久久国产精华液| 国产成人精品白浆久久69| 日韩一区二区久久久久久| 免费一级做a爰片久久毛片潮| 久久久黄色大片| 久久99热只有频精品8| 99久久久久| 无码人妻久久一区二区三区免费丨| 麻豆一区二区99久久久久| 午夜不卡888久久| 思思久久精品在热线热| 国产午夜久久影院| 老男人久久青草av高清| 99久久人妻无码精品系列蜜桃| 国产视频久久| 久久精品国产亚洲AV无码麻豆| 久久不见久久见免费影院www日本| 99久久香蕉国产线看观香| 97久久久久人妻精品专区| 欧美日韩成人精品久久久免费看| AV无码久久久久不卡蜜桃| 久久精品aⅴ无码中文字字幕不卡| 亚洲嫩草影院久久精品|