• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            隨筆 - 87  文章 - 279  trackbacks - 0
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            潛心看書研究!

            常用鏈接

            留言簿(19)

            隨筆分類(81)

            文章分類(89)

            相冊

            ACM OJ

            My friends

            搜索

            •  

            積分與排名

            • 積分 - 216643
            • 排名 - 117

            最新評論

            閱讀排行榜

            評論排行榜

            Post Office
            Time Limit:1000MS? Memory Limit:10000K
            Total Submit:1047 Accepted:456

            Description
            There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

            Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

            You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.

            Input
            Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

            Output
            The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

            Sample Input

            10 5
            1 2 3 6 7 9 11 22 44 50

            Sample Output

            9

            Source
            IOI 2000

            #include? < iostream >
            using ? namespace ?std;

            /*
            p表示i到j的建一個郵局的最小值
            q表示前i個地點建j個郵局的最小值?
            dp方程

            ?????????????????p[1][i]???????????????(j?==?1)
            ?q[i][j]?=?{????????????????????????????????????????????????????}
            ????????????????q[k][j-1]?+?p[k+1][i]??(j?>?1)?(k從j-1到i-1)

            */
            ?

            int ?p[ 301 ][ 301 ];
            int ?q[ 301 ][ 31 ];
            int ?a[ 301 ];

            int ?main()
            {
            ????
            int ?V,?P;
            ????
            int ?i,?j,?k,?l;
            ????
            int ?t[ 301 ];
            ????
            int ?tmp;
            ????scanf(
            " %d%d " ,? & V,? & P);
            ????
            ????
            for ?(i = 1 ;?i <= V;?i ++ )
            ????????scanf(
            " %d " ,? & a[i]);
            ????
            ????
            for ?(i = 1 ;?i <= V;?i ++ )
            ????????
            for ?(j = i;?j <= V;?j ++ )
            ????????
            {
            ????????????
            if ?(i? == ?j)
            ????????????????p[i][j]?
            = ? 0 ;
            ????????????
            else
            ????????????
            {
            ????????????????l?
            = ?(i? + ?j)? / ? 2 ;
            ????????????????p[i][j]?
            = ? 0 ;
            ????????????????
            for ?(k = i;?k <= l;?k ++ )
            ????????????????????p[i][j]?
            += ?a[l]? - ?a[k];
            ????????????????
            for ?(k = l + 1 ;?k <= j;?k ++ )
            ????????????????????p[i][j]?
            += ?a[k]? - ?a[l];
            ???????????????
            ????????????}

            ????????}

            ????????
            ????memset(q,?
            0 ,? sizeof (q));
            ????
            for ?(i = 1 ;?i <= V;?i ++ )
            ????????
            for ?(j = 1 ;?j <= P;?j ++ )
            ????????
            {
            ????????????
            if ?(j? == ? 1 )
            ????????????????q[i][j]?
            = ?p[ 1 ][i];
            ????????????
            else
            ????????????
            {
            ????????????????
            if ?(i? >= ?j)
            ????????????????
            {
            ????????????????????q[i][j]?
            = ?q[j - 1 ][j - 1 ]? + ?p[j][i];
            ????????????????????
            for ?(k = j;?k < i;?k ++ )
            ????????????????????
            {
            ????????????????????????
            if ?(q[i][j]? > ?q[k][j - 1 ]? + ?p[k + 1 ][i])
            ????????????????????????????q[i][j]?
            = ?q[k][j - 1 ]? + ?p[k + 1 ][i];
            ????????????????????}

            ????????????????}

            ????????????}

            ????????}

            ????????
            ????cout?
            << ?q[V][P]? << ?endl;
            ????system(
            " pause " );
            ????
            return ? 0 ;
            }

            posted on 2006-09-01 22:33 閱讀(446) 評論(0)  編輯 收藏 引用 所屬分類: ACM題目
            www亚洲欲色成人久久精品| 国产成人久久久精品二区三区| 日本亚洲色大成网站WWW久久| 国产伊人久久| 久久亚洲国产成人影院| 无码专区久久综合久中文字幕| 国产麻豆精品久久一二三| 久久精品国产亚洲AV不卡| 国产A三级久久精品| 91精品免费久久久久久久久| 久久久国产99久久国产一| 天天爽天天爽天天片a久久网| 婷婷久久综合九色综合九七| 99久久国产免费福利| 少妇熟女久久综合网色欲| 国产精品99久久久久久董美香| 人妻精品久久无码专区精东影业| 国内精品久久久久久久涩爱| 精品无码久久久久国产| 久久99国产综合精品| 久久婷婷成人综合色综合| 久久伊人精品一区二区三区| 要久久爱在线免费观看| 欧美午夜精品久久久久久浪潮| 国产叼嘿久久精品久久| 国产韩国精品一区二区三区久久| 国内精品九九久久久精品| 亚洲国产精品无码久久久不卡 | 欧美精品丝袜久久久中文字幕| 久久精品无码一区二区三区日韩 | 久久精品亚洲乱码伦伦中文| 久久精品成人免费网站| 大美女久久久久久j久久| 伊人 久久 精品| 久久99国产综合精品免费| 久久久精品午夜免费不卡| 无码人妻少妇久久中文字幕 | 亚洲色婷婷综合久久| 91精品国产91久久久久久青草| 久久性精品| 亚洲嫩草影院久久精品|