• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            隨筆 - 87  文章 - 279  trackbacks - 0
            <2006年10月>
            24252627282930
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            潛心看書研究!

            常用鏈接

            留言簿(19)

            隨筆分類(81)

            文章分類(89)

            相冊

            ACM OJ

            My friends

            搜索

            •  

            積分與排名

            • 積分 - 216468
            • 排名 - 117

            最新評論

            閱讀排行榜

            評論排行榜

            Dominoes
            Time Limit:1000MS? Memory Limit:65536K
            Total Submit:1022 Accepted:333

            Description
            A domino is a flat, thumbsized tile, the face of which is divided into two squares, each left blank or bearing from one to six dots. There is a row of dominoes laid out on a table:


            The number of dots in the top line is 6+1+1+1=9 and the number of dots in the bottom line is 1+5+3+2=11. The gap between the top line and the bottom line is 2. The gap is the absolute value of difference between two sums.

            Each domino can be turned by 180 degrees keeping its face always upwards.

            What is the smallest number of turns needed to minimise the gap between the top line and the bottom line?

            For the figure above it is sufficient to turn the last domino in the row in order to decrease the gap to 0. In this case the answer is 1.
            Write a program that: computes the smallest number of turns needed to minimise the gap between the top line and the bottom line.

            Input
            The first line of the input contains an integer n, 1 <= n <= 1000. This is the number of dominoes laid out on the table.

            Each of the next n lines contains two integers a, b separated by a single space, 0 <= a, b <= 6. The integers a and b written in the line i + 1 of the input file, 1 <= i <= 1000, are the numbers of dots on the i-th domino in the row, respectively, in the top line and in the bottom one.

            Output
            Output the smallest number of turns needed to minimise the gap between the top line and the bottom line.

            Sample Input

            4
            6 1
            1 5
            1 3
            1 2
            

            Sample Output

            1
            

            Source
            CEOI 1997

            #include? < iostream >
            using ? namespace ?std;

            const ? int ?MAXN? = ? 8000 ;
            const ? int ?INF? = ? 1 ? << ? 28 ;

            struct ?DATA? {
            ????
            int ?da[MAXN];
            ????
            int ?dx;
            ????
            int ?q;
            }
            ;

            DATA?dp[
            2 * MAXN];
            bool ?f[ 2 * MAXN];
            int ?queue[MAXN],?front,?rear;
            int ?main()
            {
            ????
            int ?n;
            ????
            int ?a[MAXN],?x,?y;
            ????
            int ?i,?j,?k,?w,?l;
            ????
            int ?d? = ? 0 ;
            ????
            int ?ans? = ?INF;
            ????scanf(
            " %d " ,? & n);
            ????
            for ?(i = 0 ;?i < n;?i ++ )? {
            ????????scanf(
            " %d%d " ,? & x,? & y);
            ????????a[i]?
            = ?x? - ?y;
            ????????d?
            += ?a[i];
            ????}

            ????memset(f,?
            false ,? sizeof (f));
            ????dp[d
            + 7500 ].dx? = ?d;?dp[d + 7500 ].q? = ? 0 ;?f[d + 7500 ]? = ? true ;
            ????
            for ?(i = 0 ;?i < n;?i ++ )?dp[d + 7500 ].da[i]? = ?a[i];
            ????front?
            = ? 0 ;?rear? = ? 0 ;?w? = ? 0 ;
            ????
            do ? {
            ????????
            for ?(i = 0 ;?i < n;?i ++ )? {
            ????????????j?
            = ?dp[d + 7500 ].da[i];
            ????????????k?
            = ?d?? - ?j? * ? 2 ;
            ????????????
            if ?( ! f[k + 7500 ]? || ?dp[k + 7500 ].q? > ?w? + ? 1 )? {
            ????????????????
            if ?(k? == ? 0 )? {
            ????????????????????printf(
            " %d\n " ,?w? + ? 1 );
            ????????????????????system(
            " pause " );
            ????????????????????
            return ? 0 ;
            ????????????????}

            ????????????????f[k
            + 7500 ]? = ? true ;
            ????????????????queue[rear
            ++ ]? = ?k;
            ????????????????dp[k
            + 7500 ].dx? = ?k;
            ????????????????dp[k
            + 7500 ].q? = ?w? + ? 1 ;
            ????????????????
            for ?(l = 0 ;?l < n;?l ++ )?dp[k + 7500 ].da[l]? = ?dp[d + 7500 ].da[l];
            ????????????????dp[k
            + 7500 ].da[i]? = ? - dp[d + 7500 ].da[i];
            ????????????}

            ????????}

            ????????d?
            = ?queue[front ++ ];
            ????????w?
            = ?dp[d + 7500 ].q;
            ????}
            ? while ?(front? <= ?rear);??
            ????j?
            = ? 7500 ;
            ????
            bool ?isFind? = ? false ;
            ????
            for ?(i = 0 ;?i < 7500 ;?i ++ )? {
            ????????
            if ?(f[j + i])? {
            ????????????isFind?
            = ? true ;
            ????????????
            if ?(ans? > ?dp[j + i].q)?ans? = ?dp[j + i].q;
            ????????}

            ????????
            if ?(f[j - i])? {
            ????????????isFind?
            = ? true ;
            ????????????
            if ?(ans? > ?dp[j - i].q)?ans? = ?dp[j - i].q;
            ????????}

            ????????
            if ?(isFind)? break ;
            ????}

            ????printf(
            " %d\n " ,?ans);
            ????system(
            " pause " );
            ????
            return ? 0 ;
            }

            posted on 2006-10-29 20:42 閱讀(801) 評論(0)  編輯 收藏 引用 所屬分類: ACM題目
            久久久久久久尹人综合网亚洲 | 欧美午夜精品久久久久久浪潮| 九九精品99久久久香蕉| 看久久久久久a级毛片| 久久综合久久综合九色| 一本久久免费视频| 99久久成人国产精品免费| 中文字幕亚洲综合久久| 久久久久久精品免费免费自慰| 久久精品国产亚洲AV大全| 久久天天日天天操综合伊人av| 亚洲香蕉网久久综合影视 | 亚洲欧洲久久久精品| 亚洲综合精品香蕉久久网97 | 97久久国产综合精品女不卡| 久久久精品免费国产四虎| 一本久久免费视频| 国产成人久久精品麻豆一区 | 欧美一区二区三区久久综合| 精品久久久久久无码免费| 久久久久久人妻无码| 成人综合久久精品色婷婷| 国产午夜精品理论片久久| 国产欧美久久一区二区| 久久久久久久久久久精品尤物| 久久久久久国产a免费观看不卡 | 欧美一区二区三区久久综合 | 国产精品无码久久久久久| 国内精品九九久久精品| 久久久午夜精品福利内容| 久久久久久A亚洲欧洲AV冫| 青青青伊人色综合久久| 国产成人综合久久综合| 狠狠色婷婷综合天天久久丁香| 无码超乳爆乳中文字幕久久| 久久国产精品99精品国产| 狠狠色噜噜狠狠狠狠狠色综合久久| 精品国产青草久久久久福利| 国内精品久久久久久久涩爱| 国产精品美女久久久久av爽| 色噜噜狠狠先锋影音久久|