• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 7,comments - 3,trackbacks - 0

            Max Xor Sub-sequence II 
            Time Limit:1000MS  Memory Limit:32768K

            Description:

            Give you a sequence of integer numbers which are 1 or 0. You are to find the number of consecutive sub-sequence, which the xor value between all these numbers has the maximum value. The first number of the sequence is 1 and the last is 1. There are (n+1) 1’s in the sequence. N numbers will be given. The i-th number is the index of (i+1)-th 1 minus the index of i-th 1. For example: if the sequence is 1010100010001, 4 2 2 4 4 will be given.

             

            Input:

            There are multiple cases. For each case: Line 1: A single integer N (1<=N<=20000). Followed N integers ranging from 1 to 20000.

            Output:

            For each case output the result in a single line.

            Sample Input:

            4
            2 2 4 4
            5
            3 1 2 4 5
            

            Sample Output:

            49
            70
            

            Hint:

            1.1 ^ 1 = 0, 1 ^ 0 = 1, 0 ^ 1 = 1, 0 ^ 0 = 0. 2.In the example, sub-sequence 10 has the maximum value ‘cause 1 xor 0 = 1;the same as 10101, 1010100010001, and so on.

            算不上DP的DP......就是處理01串的奇偶性.....
            DP[i][j]表示第i個1,j有6種情況。
            dp[i][0] = dp[i - 1][1] 表示偶數個1,且最后一個1在末尾。
            dp[i][1] = dp[i - 1][0] + dis 表示奇數個1,且最后一個1在末尾。
            dp[i][2] = f[i - 1][2] + f[i - 1][0] 表示偶數個1,且最后一個1不在末尾。
            dp[i][3] = f[i  - 1][3] + f[i - 1][1] 表示偶數個1,且最后一個1不在末尾。
            dp[i][4] = f[i - 1][4] + (dis - 1) * f[i - 1][0] 表示偶數個1,且最后一個是0不在末尾。
            dp[i][5] = f[i - 1][5] + (dis - 1) * f[i - 1][0] 表示偶數個1,且最后一個是0不在末尾。
            上面六個關系式列舉了所以情況,但是只用到了(dp[i][0], dp[i][1], dp[i][3], dp[i][5])四個式子。

            友情提示,ans是超過int的,用long long吧,我因為這個吃了三次WA.....

            代碼:

            #include <cstdio>
            #include <cstring>
            #include <iostream>
            using namespace std;

            int main()
            {
                long long dp[20010][7];
                long long n;
                long long dis;
                while (cin >> n)
                {
                    memset(dp, 0, sizeof(dp));
                    dp[1][0] = 0;
                    dp[1][1] = 1;
                    for (long long i = 2; i <= n + 1; ++i)
                    {
                        cin >> dis;
                        dp[i][0] = dp[i - 1][1];
                        dp[i][1] = dp[i - 1][0] + dis;
                        dp[i][3] = dp[i - 1][3] + dp[i - 1][1];
                        dp[i][5] = dp[i - 1][5] + (dis - 1) * dp[i - 1][1];
                    }
                    cout << dp[n + 1][1] + dp[n + 1][3] + dp[n + 1][5] << endl;
                }
                return 0;
            }

            posted on 2011-10-15 22:15 LLawliet 閱讀(232) 評論(0)  編輯 收藏 引用 所屬分類: 動態規劃
            69久久夜色精品国产69| 欧美久久一级内射wwwwww.| 四虎久久影院| 亚洲中文字幕无码久久精品1| 亚洲AV无码久久精品蜜桃| 99久久中文字幕| 精品久久久久一区二区三区| 久久综合亚洲鲁鲁五月天| 97久久超碰成人精品网站| 色99久久久久高潮综合影院| 久久婷婷五月综合色高清| 人妻无码久久精品| 国内精品久久久久影院日本| 欧美久久一区二区三区| 国产精品久久久久久搜索| 一本色道久久88综合日韩精品 | 香蕉99久久国产综合精品宅男自 | 久久亚洲国产中v天仙www| 亚洲日韩欧美一区久久久久我| 国产精品对白刺激久久久| 性欧美大战久久久久久久| 久久精品无码一区二区三区| 久久久久人妻一区二区三区| 久久WWW免费人成—看片| 久久99精品久久久久久| 国产成年无码久久久久毛片| 久久精品无码一区二区WWW| 久久天天躁狠狠躁夜夜2020| 久久精品人人做人人爽电影| 久久精品亚洲一区二区三区浴池 | 伊人久久大香线蕉综合网站| 一本伊大人香蕉久久网手机| 亚洲国产精品成人AV无码久久综合影院 | 久久这里有精品视频| 伊人久久大香线蕉影院95| 久久久免费精品re6| 狼狼综合久久久久综合网| 国产精品久久久久久久久久影院| 久久www免费人成看国产片| 久久99国产精品成人欧美| 久久精品成人|