Sightseeing Time Limit: 2000MS | | Memory Limit: 65536K | Total Submissions: 4917 | | Accepted: 1688 |
Description Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights. Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route. There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday. For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7. Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length. Input The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map. M lines, each with three integers A, B and L, separated by single spaces, with 1 ≤ A, B ≤ N, A ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L. The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B. One line with two integers S and F, separated by a single space, with 1 ≤ S, F ≤ N and S ≠ F: the starting city and the final city of the route. There will be at least one route from S to F.
Output For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000. Sample Input 2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1 Sample Output 3
2 Hint The first test case above corresponds to the picture in the problem description. Source |
思路:
依據描寫可知,本題的要求即便要求出最短路和比最短路長1的次短路,因而可用Dijkstra來處理。翔實做法如下:用兩組數離別登記最短路和次短路的長度(dist),條數(cnt),拜會符號(used),建一個優先隊列,元素單位包括節點序號(v),該節點路經長(len),以及登記路徑種類(ref),每次從優先隊列中取出管用節點后,用它所登記的路徑長更新待比擬路徑,離別用它和目前所登記的該節點的最短路徑以及此段路徑比擬,中意更新條件則登記路徑種類,并生成新節點加入優先隊列,同時更新目前節點處該種類路徑條數。萬一不中意條件然而中意混同聯系,則增加相應的條數到該節點所登記的路徑條數上。代碼:
#include <cstdio>
#include <memory.h>
#include <queue>
#define N 1001
#define M 10001
#define INF 0x7fffffff
#define clr(a) memset(a, 0, sizeof(a))
using namespace std;
struct Edge
{
int v, len, ref;
Edge *link;
Edge new_E(int v1, int l, int r)
{
v = v1, len = l, ref = r;
return *this;
}
} *E[N], mempool[M];
int dist[N][2], used[N][2], cnt[N][2];
int n, m, memh, S, T;
void AddEdge(int u, int v, int len)
{
Edge *e = &mempool[memh++];
e -> v = v;
e -> len = len;
e -> link = E[u];
E[u] = e;
}
bool operator < (Edge a, Edge b)
{
return a.len > b.len;
}
priority_queue <Edge, vector <Edge> > Q;
void InitData()
{
int i, u, v, len;
memh = 0;
scanf("%d%d", &n, &m);
clr(E);
for (i = 1; i <= m; ++i)
{
scanf("%d%d%d", &u, &v, &len);
AddEdge(u, v, len);
}
scanf("%d%d", &S, &T);
}
int Dijstra()
{
Edge D, P;
clr(cnt);
clr(used);
for (int i = 1; i <= n; ++i)
dist[i][0] = dist[i][1] = INF;
dist[S][0] = 0;
cnt[S][0] = 1;
while (!Q.empty())
Q.pop();
Q.push(D.new_E(S, 0, 0));
while (!Q.empty())
{
P = Q.top();
Q.pop();
if (!used[P.v][P.ref])
{
used[P.v][P.ref] = 1;
for (Edge *e = E[P.v]; e; e = e -> link)
{
int tmp = P.len + e -> len;
if (tmp < dist[e -> v][0])
{
if (dist[e -> v][0] != INF)
{
dist[e -> v][1] = dist[e -> v][0];
cnt[e -> v][1] = cnt[e -> v][0];
Q.push(D.new_E(e -> v, dist[e -> v][0], 1));
}
dist[e -> v][0] = tmp;
cnt[e -> v][0] = cnt[P.v][P.ref];
Q.push(D.new_E(e -> v, tmp, 0));
}
else
if (tmp == dist[e -> v][0])
{
cnt[e -> v][0] += cnt[P.v][P.ref];
}
else
if (tmp < dist[e -> v][1])
{
dist[e -> v][1] = tmp;
cnt[e -> v][1] = cnt[P.v][P.ref];
Q.push(D.new_E(e -> v, tmp, 1));
}
else
if (dist[e -> v][1] == tmp)
{
cnt[e -> v][1] += cnt[P.v][P.ref];
}
}
}
}
if (dist[T][1] - 1 == dist[T][0])
cnt[T][0] += cnt[T][1];
return cnt[T][0];
}
int main()
{
int T;
scanf("%d", &T);
while (T--)
{
InitData();
printf("%d\n", Dijstra());
}
}
posted on 2011-10-17 16:30
LLawliet 閱讀(467)
評論(0) 編輯 收藏 引用 所屬分類:
圖論