• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            MiYu原創(chuàng), 轉(zhuǎn)帖請注明 : 轉(zhuǎn)載自 ______________白白の屋    

            題目地址 :

            http://poj.org/problem?id=2352

            題目描述:

            Stars
            Time Limit: 1000MSMemory Limit: 65536K
            Total Submissions: 14814Accepted: 6404

            Description

            Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

            For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

            You are to write a program that will count the amounts of the stars of each level on a given map.

            Input

            The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

            Output

            The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

            Sample Input

            5
            1 1
            5 1
            7 1
            3 3
            5 5

            Sample Output

            1
            2
            1
            1
            0
             與樹狀數(shù)組的解法一樣,  查詢更新就可以了. 
            	樹狀數(shù)組 解法傳送門 : http://www.cnblogs.com/MiYu/archive/2010/08/26/1808963.html 
            代碼如下 : 
            /*
            Mail to   : miyubai@gamil.com
            Link      : http://www.cnblogs.com/MiYu  || http://www.shnenglu.com/MiYu
            Author By : MiYu
            Test      : 1
            Complier  : g++ mingw32-3.4.2
            Program   : POJ_2352
            Doc Name  : Stars
            */
            //#pragma warning( disable:4789 )
            #include <iostream>
            #include <fstream>
            #include <sstream>
            #include <algorithm>
            #include <string>
            #include <set>
            #include <map>
            #include <utility>
            #include <queue>
            #include <stack>
            #include <list>
            #include <vector>
            #include <cstdio>
            #include <cstdlib>
            #include <cstring>
            #include <cmath>
            #include <ctime>
            using namespace std;
            struct P{
                   int x, y;
            }p[15010];
            int seg[100000];
            int NN = 32768, res[15010];
            int get ( int &n ) {
                int i = 1;
                while ( i < n ) i << 1;
                return i;    
            }
            void modify ( int &pos ) {
                 pos += NN;
                 seg[pos] ++;
                 while ( pos > 1 ) {
                       if ( ~pos & 1 ) seg[pos>>1] ++;
                       pos >>= 1;
                 }
            }
            int query ( int pos ) {
                 pos += NN;  
                 int sum = seg[pos];
                 while ( pos > 1 ) {
                        if ( pos & 1 ) {
                             sum += seg[pos>>1];  
                        }      
                        pos >>= 1;
                 }   
                 return sum;
            }
            int main ()
            {
                int N;
                while ( scanf ( "%d", &N ) == 1 ) {
                       int pos;
                       memset ( res, 0, sizeof ( res ) );
                       memset ( seg, 0, sizeof ( seg ) );
                       for ( int i = 0; i < N; ++ i ) {
                              scanf ( "%d%*d", &pos );
                              res[ query ( pos ) ] ++;
                              modify ( pos );   
                       }   
                       for ( int i = 0; i < N; ++ i ) {
                            printf ( "%d\n", res[i] );     
                       } 
                }
                return 0;
            }
            

             

            久久精品国产亚洲网站| 中文字幕久久精品无码| 一本久道久久综合狠狠爱| 久久精品成人免费国产片小草| 久久久无码精品亚洲日韩按摩| 久久久婷婷五月亚洲97号色| 中文字幕无码免费久久| 久久国产劲爆AV内射—百度| 久久人人爽人人爽人人片AV不| 青草影院天堂男人久久| 久久一本综合| 国产亚洲综合久久系列| 亚洲精品午夜国产va久久| 狠狠色婷婷久久一区二区| 亚洲人成网亚洲欧洲无码久久 | 久久精品国产精品亚洲毛片| 亚洲国产精品18久久久久久| AAA级久久久精品无码片| 青青青青久久精品国产| 久久露脸国产精品| 亚洲成色www久久网站夜月| 久久精品国产精品青草app| 久久精品中文字幕有码| 综合人妻久久一区二区精品| 久久99精品久久久久久久久久 | 思思久久99热免费精品6| 久久成人国产精品| 青青热久久综合网伊人| 亚洲欧美日韩精品久久亚洲区| 国产91色综合久久免费分享| 久久中文字幕人妻丝袜| 一本久久综合亚洲鲁鲁五月天| 狠狠色综合网站久久久久久久高清| 精品久久久久久无码专区不卡| 久久精品中文字幕有码| 久久国产亚洲精品无码| 久久影视综合亚洲| 久久精品国产69国产精品亚洲| 中文精品99久久国产 | 99久久综合狠狠综合久久| 久久亚洲中文字幕精品有坂深雪|