• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ACM___________________________

            ______________白白の屋
            posts - 182, comments - 102, trackbacks - 0, articles - 0
            <2010年8月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            常用鏈接

            留言簿(24)

            隨筆分類(332)

            隨筆檔案(182)

            FRIENDS

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            評論排行榜

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋    

             

            題目地址:

                  http://acm.hdu.edu.cn/showproblem.php?pid=1800 

            題目描述:

            Problem Description

            In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
            For example : 
            There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
            One method :
            C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
            D could teach E;So D E are eligible to study on the same broomstick;
            Using this method , we need 2 broomsticks.
            Another method:
            D could teach A; So A D are eligible to study on the same broomstick.
            C could teach B; So B C are eligible to study on the same broomstick.
            E with no teacher or student are eligible to study on one broomstick.
            Using the method ,we need 3 broomsticks.
            ……

            After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
             

            Input
            Input file contains multiple test cases. 
            In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
            Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
             

            Output
            For each case, output the minimum number of broomsticks on a single line.
             

            Sample Input
            4 10 20 30 04 5 2 3 4 3 4
             

            Sample Output
            1 2
             

            題目分析:

             

            相對來說這題用字典樹的效率比較高些.....遺憾的是我現在只會做一些字典樹的 水題....對字典樹的理解現在還不是很好......所以,呵呵

            這題我就直接篩選過了........

             

            代碼如下:

             /*

            MiYu原創, 轉帖請注明 : 轉載自 ______________白白の屋

                      http://www.cnblog.com/MiYu

            Author By : MiYu

            Test      : 1

            Program   : 1800

            */


            #include <iostream>

            #include <algorithm>

            using namespace std;

            int num[3002];

            bool hash[3002];

            bool cmp ( const int &a, const  int &b )

            {

                 return a > b; 

            }

            int main ()

            {

                int N;

                while ( scanf ( "%d", &N ) != EOF )

                {

                       memset ( num, 0, 12008 );

                       memset ( hash, 0, 3002 );

                       for ( int i = 0; i != N; ++ i )

                             scanf ( "%d",num + i );

                       sort ( num, num + N, cmp );

                       int nCount = 0;

                       for ( int i = 0; i < N; ++ i )

                       {

                             if ( !hash[i] )

                             {

                                  nCount ++;

                                  int j = i ,k = j+1;

                                  hash[j] = true;

                                  while ( k < N ) 

                                  {

                                        if ( !hash[k] && num[k] < num[j] )

                                        {

                                             hash[k] = true;

                                             j = k;

                                        }

                                        k++;

                                  } 

                             }

                       } 

                       printf ( "%d\n",nCount );

                }

                return 0;

            }


             

             

            国内精品伊人久久久影院| 看全色黄大色大片免费久久久| 久久精品一本到99热免费| 精品久久久无码21p发布| 欧洲精品久久久av无码电影| 99久久无码一区人妻a黑| 国产三级精品久久| 久久无码国产专区精品| 69国产成人综合久久精品| 日本精品久久久久影院日本| 久久久久成人精品无码中文字幕| 国产亚洲婷婷香蕉久久精品| 亚洲国产精品成人AV无码久久综合影院| 人妻无码αv中文字幕久久琪琪布 人妻无码久久一区二区三区免费 人妻无码中文久久久久专区 | 久久福利青草精品资源站| 久久无码AV中文出轨人妻 | 久久精品国产半推半就| 久久综合色之久久综合| 久久99国产综合精品免费| 一级a性色生活片久久无| 国内精品久久久久| 伊人久久综合无码成人网 | 久久精品国产亚洲沈樵| 亚洲综合日韩久久成人AV| 国产精品久久久久久久午夜片| 亚洲AV日韩AV永久无码久久| 手机看片久久高清国产日韩| 久久免费高清视频| 99久久精品国内| 99re这里只有精品热久久| 久久久久久亚洲AV无码专区| 精品无码久久久久国产动漫3d| 一级a性色生活片久久无| 四虎国产精品成人免费久久| 久久亚洲高清综合| 久久久久亚洲av成人无码电影| 天天综合久久久网| 老司机国内精品久久久久| 亚洲午夜久久影院| 国产99久久久国产精品~~牛| 99久久精品国产综合一区|