HDOJ 1969 HDU 1969 Pie ACM 1969 IN HDU
Posted on 2010-08-11 14:37 MiYu 閱讀(1084) 評(píng)論(0) 編輯 收藏 引用 所屬分類: ACM ( 搜索 ) 、ACM ( 數(shù)學(xué)題/幾何 )MiYu原創(chuàng), 轉(zhuǎn)帖請(qǐng)注明 : 轉(zhuǎn)載自 ______________白白の屋
題目地址:
http://acm.hdu.edu.cn/showproblem.php?pid=1969
題目描述:
題目分析:
代碼如下:
題目地址:
http://acm.hdu.edu.cn/showproblem.php?pid=1969
題目描述:
Pie
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 229 Accepted Submission(s): 65
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 229 Accepted Submission(s): 65
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
題目分析:
2分求解.
題目大意是要辦生日Party,有n個(gè)餡餅,有f個(gè)朋友,接下來是n個(gè)餡餅的半徑。然后是分餡餅了,
注意咯自己也要,大家都要一樣大,形狀沒什么要求,但都要是一整塊的那種,也就是說不能從兩個(gè)餅中
各割一小塊來湊一塊,像面積為10的和6的兩塊餅(餅的厚度是1,所以面積和體積相等),
如果每人分到面積為5,則10分兩塊,6切成5,夠分3個(gè)人,如果每人6,則只能分兩個(gè)了!
題目要求我們分到的餅盡可能的大!
只要注意精度問題就可以了,一般WA 都是精度問題.
題目大意是要辦生日Party,有n個(gè)餡餅,有f個(gè)朋友,接下來是n個(gè)餡餅的半徑。然后是分餡餅了,
注意咯自己也要,大家都要一樣大,形狀沒什么要求,但都要是一整塊的那種,也就是說不能從兩個(gè)餅中
各割一小塊來湊一塊,像面積為10的和6的兩塊餅(餅的厚度是1,所以面積和體積相等),
如果每人分到面積為5,則10分兩塊,6切成5,夠分3個(gè)人,如果每人6,則只能分兩個(gè)了!
題目要求我們分到的餅盡可能的大!
只要注意精度問題就可以了,一般WA 都是精度問題.
代碼如下:
#include <iostream>
#include <cmath>
using namespace std;
double a[10005];
int N,f;
double pi = acos ( -1.0 );
bool test ( double x )
{
int count = 0;
for ( int i = 1; i <= N; ++ i )
{
count += int ( a[i] / x );
}
if ( count >= f + 1 )
{
return true;
}
else
{
return false;
}
}
int main()
{
int T;
scanf ( "%d", &T );
while ( T -- )
{
double sum = 0;
double rad;
scanf("%d%d",&N,&f);
for ( int i = 1; i <= N; ++ i )
{
scanf ( "%lf", &rad );
a[i] = rad * rad * pi;
sum += a[i];
}
double max = sum / ( f + 1 );
double l = 0.0;
double r = max;
double mid = 0.0;
while ( r - l > 1e-6 )
{
mid = ( l + r ) / 2;
if ( test ( mid ) )
{
l = mid;
}
else
{
r = mid;
}
}
printf("%.4lf\n",mid);
}
return 0;
}
#include <cmath>
using namespace std;
double a[10005];
int N,f;
double pi = acos ( -1.0 );
bool test ( double x )
{
int count = 0;
for ( int i = 1; i <= N; ++ i )
{
count += int ( a[i] / x );
}
if ( count >= f + 1 )
{
return true;
}
else
{
return false;
}
}
int main()
{
int T;
scanf ( "%d", &T );
while ( T -- )
{
double sum = 0;
double rad;
scanf("%d%d",&N,&f);
for ( int i = 1; i <= N; ++ i )
{
scanf ( "%lf", &rad );
a[i] = rad * rad * pi;
sum += a[i];
}
double max = sum / ( f + 1 );
double l = 0.0;
double r = max;
double mid = 0.0;
while ( r - l > 1e-6 )
{
mid = ( l + r ) / 2;
if ( test ( mid ) )
{
l = mid;
}
else
{
r = mid;
}
}
printf("%.4lf\n",mid);
}
return 0;
}