Parity game
Time Limit:1000MS Memory Limit:65536K
Total Submit:748 Accepted:310
Description
Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.
You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input
The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).
Output
There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd
Sample Output
3
Source
CEOI 1999
Step 1: 由于端點(diǎn)數(shù)目遠(yuǎn)遠(yuǎn)小于數(shù)據(jù)范圍 給于數(shù)據(jù)范圍離散化
Step 2:將區(qū)間問(wèn)題轉(zhuǎn)化成單點(diǎn) sum[a,b] = sum[0,b] - sum[0, a-1];
Step 3: 構(gòu)造并查集,設(shè)置一個(gè)屬性prt代表和父結(jié)點(diǎn)的XOR值。即:
如果父結(jié)點(diǎn)為偶 prt = true 則本節(jié)點(diǎn)為奇
同理可推知其他情況 構(gòu)建并查集的目的是為了是查詢能夠在有聯(lián)系的兩個(gè)節(jié)點(diǎn)之間通過(guò)其他結(jié)點(diǎn)迅速判斷奇偶性
對(duì)于一個(gè)詢問(wèn)(l, r, p):若l-1與r是屬于同一個(gè)集合,則檢查l-1與r相對(duì)于根o的奇偶性差異P[l -1, o]與P[r, o]。看這兩個(gè)差異值的差異是不是就是p,即P[l-1, o] xor P[r, o]是不是等于p,不是則矛盾。若l-1與r是不屬于同一個(gè)集合,則將l-1與r所在樹(shù)的根節(jié)點(diǎn)合并起來(lái),這兩個(gè)根結(jié)點(diǎn)間奇偶性差異為P[l-1,o] xor P[r, o] xor p。
有構(gòu)建的方式可以看出 這個(gè)并查集是可以路徑壓縮的
1
2
3
4
//pku1733 Parity game
5
//by oyjpArt
6
#include <map>
7
#include <iostream>
8
#include <string>
9
using namespace std;
10
const int N = 5010;
11
int x[N], y[N];
12
bool odd[N];
13
int p[2 * N];
14
bool prt[2 * N];
15
int Root(int x, bool & e)
16
{
17
int r = x, t = x;
18
bool res = prt[x];
19
while(p[r] != r)
20
{
21
r = p[r];
22
res = res ^ prt[r];
23
}
24
e = res;
25
return r;
26
}
27
void Union(int a, int b, bool e)
28
{
29
p[a] = b;
30
prt[a] = e;
31
}
32
bool chk(int idx)
33
{
34
int a = x[idx], b = y[idx];
35
bool e = odd[idx], ea, eb;
36
int ra = Root(a, ea), rb = Root(b, eb);
37
if(ra == rb)
38
{
39
if( (ea ^ eb) != e) return false;
40
}
41
else
42
{
43
Union(ra, rb, (ea ^ eb ^ e) );
44
}
45
return true;
46
}
47
int main()
48
{
49
// freopen("t.in", "r", stdin);
50
map<int, int> m;
51
int l, i, ncmd, a, b, idx;
52
string s;
53
cin >> l >> ncmd;
54
for(i = 0, idx = 0; i < ncmd; ++i)
55
{
56
cin >> a >> b >> s;
57
if(a > b) swap(a, b);
58
--a;
59
if(a < 0)
60
while(1) printf("1");
61
if(!m.count(a)) m[a] = idx++;
62
if(!m.count(b)) m[b] = idx++;
63
x[i] = m[a]; y[i] = m[b];
64
odd[i] = s[0] == 'o';
65
}
66
for(i = 0; i < idx; ++i) { p[i] = i; prt[i] = false; }
67
for(i = 0; i < ncmd; ++i) {
68
if(!chk(i))
69
break;
70
}
71
printf("%d\n", i);
72
return 0;
73
}
74
75
76
77