• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設計空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            PKU 1328 Radar Installation

            Posted on 2007-06-22 20:00 oyjpart 閱讀(2992) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC或其他比賽

            Radar Installation
            Time Limit:1000MS  Memory Limit:10000K
            Total Submit:2704 Accepted:564

            Description
            Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

            We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


            Figure A Sample Input of Radar Installations



             

            Input
            The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

            The input is terminated by a line containing pair of zeros

            Output
            For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

            Sample Input

            3 2
            1 2
            -3 1
            2 1
            1 2
            0 2
            0 0
            

             

            Sample Output

            Case 1: 2
            Case 2: 1
            

             

            Source
            Beijing 2002


            Algorithm: Greedy
            Step 1: 輸入數據 如果有一個點的y坐標大于d 直接輸出-1 長生相應的區間(在某一個區間里任意放置一個Radar 則是這個Island可視)
            Step 2: 按照左端點排序(如果左端點相等 則必須按右邊反向排序, 理由在于下一步為了篩選出包含的 必須的把大范圍的放到前面) 注意這里面最好要用浮點判斷規則
            Step 3: 利用Stack對這些區間做預處理 把被包含的區間標識出來
            Step 4: 貪心選擇右端的點

            #include <stdio.h>
            #include <string.h>
            #include <algorithm>
            #include <math.h>
            using namespace std;

            const int N = 1000;
            const double EPS = 1e-7;

            struct E { double a, b; } e[N];
            int n, d;
            bool ava[N];
            double p[N];

            inline int dblcmp(double a, double b) {
             if( fabs(a-b) < EPS ) return 0;
             if( a-b > 0 ) return 1;
             return -1;
            }

            bool operator<(const E& a, const E& b) {
             if(dblcmp(a.a, b.a) == 0)
              return dblcmp(a.b, b.b) == 1;
             return dblcmp(a.a, b.a) == -1;
            }


            int main() {
             int i, j, x, y;
             int tc = 0;
             while(scanf("%d %d", &n, &d), n + d) {
              tc++;
              int ok = 1;
              for(i = 0; i < n; ++i) {
               scanf("%d %d", &x, &y);
               if(y > d) ok = 0;
               double offset = sqrt ( d * d - y * y );
               e[i].a = x - offset, e[i].b = x + offset;
               ava[i] = 1;
              }
              if(!ok) { printf("Case %d: -1\n", tc); continue; }
              sort(e, e + n);
              int stack[N], top = 0;
              stack[top++] = 0;
              for(i = 1; i < n; ++i) {
               while(top > 0 && dblcmp(e[stack[top-1]].b, e[i].b) != -1)  {
                ava[stack[--top]] = 0;
               }
               stack[top++] = i;
              }
              
              for(i = 0; !ava[i]; ++i);
              p[i] = e[i].b;
              int cnt = 1;
              for(i = i+1; i < n; ++i) if(ava[i]) {
               for(j = i-1; !ava[j]; j--);
               if(p[j] >= e[i].a)  p[i] = p[j];
               else { p[i] = e[i].b; cnt++; }
              }
              printf("Case %d: %d\n", tc, cnt);
             }
             return 0;
            }

            精品久久久久久无码专区不卡| 久久无码中文字幕东京热| 婷婷伊人久久大香线蕉AV| 色狠狠久久AV五月综合| www.久久热| 久久99精品久久久久久野外| 久久精品女人天堂AV麻| 久久午夜无码鲁丝片秋霞| 久久综合九色综合97_久久久| 国产精品xxxx国产喷水亚洲国产精品无码久久一区 | 欧美亚洲另类久久综合婷婷| 精品久久久一二三区| 国产午夜精品久久久久免费视| 国产免费福利体检区久久| 囯产精品久久久久久久久蜜桃 | 国产69精品久久久久观看软件| 欧美丰满熟妇BBB久久久| 久久精品国产精品亚洲下载| 午夜欧美精品久久久久久久| 国产精品成人99久久久久 | 亚洲精品乱码久久久久久自慰| 88久久精品无码一区二区毛片| 久久人人爽人人爽人人av东京热| 久久国产亚洲精品麻豆| 伊人久久大香线蕉亚洲五月天| 曰曰摸天天摸人人看久久久| 日产精品久久久久久久性色| 久久亚洲精品国产精品婷婷| 久久久久一区二区三区| 亚洲中文字幕无码久久2017| 久久最新免费视频| 国产精品青草久久久久福利99| 久久久久亚洲Av无码专| 精品熟女少妇AV免费久久| 日韩久久无码免费毛片软件| 久久久久这里只有精品| 久久久无码精品午夜| 久久青青国产| 亚洲欧美一区二区三区久久| 久久经典免费视频| 亚洲人成无码网站久久99热国产 |