• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設(shè)計空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            PKU1948 Triangular Pastures

            Posted on 2007-02-15 15:51 oyjpart 閱讀(959) 評論(1)  編輯 收藏 引用

            Triangular Pastures
            Time Limit:1000MS? Memory Limit:30000K
            Total Submit:1213 Accepted:291

            Description
            Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite.

            I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length.

            Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments.

            Input
            * Line 1: A single integer N

            * Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique.

            Output
            A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed.

            Sample Input

            5
            1
            1
            3
            3
            4
            

            Sample Output

            692
            

            Hint
            [which is 100x the area of an equilateral triangle with side length 4]

            Source
            USACO 2002 February

            由于數(shù)據(jù)量不大 利用可行性的狀態(tài) 進行DP Heron公式
            搜索也能過 呵呵 需要預(yù)先找到一個較好解 大->小搜 加一定的剪枝

            #include <stdio.h>
            #include <algorithm>
            #include <functional>
            #include <math.h>
            using namespace std;
            const int N = 40;
            const int M = 1000; //邊的最大可能長度(三角形性質(zhì))
            bool s[N][M][M];
            int seg[N+1];

            inline double heron(double a, double b, double c) {
            ?double p = (a+b+c)/2.0;
            ?return sqrt(p*(p-a)*(p-b)*(p-c));
            }

            int main() {
            ?int i, j, k, ns, tot = 0;
            ?double best = 0, tmp;
            ?scanf("%d", &ns);
            ?for(i = 1; i <= ns; i++) {?scanf("%d", seg+i);?tot += seg[i];?}
            ?s[0][0][0] = 1;
            ?int bound = tot/2+1;
            ?for(i = 1; i <= ns; i++)
            ??for(j = 0; j<=bound; j++)
            ???for(k = 0; k <=bound; k++)
            ????s[i][j][k] = s[i-1][j][k] || j >= seg[i] && s[i-1][j-seg[i]][k] || k >= seg[i] && s[i-1][j][k-seg[i]];
            ?for(j = 1; j<=bound; j++)
            ??for(k = 1; k <=bound; k++) {
            ???int m = tot-j-k;
            ???if(s[ns][j][k] && j + k > m && j + m > k && m + k > j && (tmp = heron(j, k, m)) > best)
            ????best = tmp;
            ??}
            ?if(best == 0) printf("-1\n");
            ?else printf("%d\n", (int)(best*100));
            ?return 0;
            }

            Feedback

            # re: PKU1948 Triangular Pastures   回復(fù)  更多評論   

            2007-04-22 13:10 by oiuy
            原來是這樣dp的,謝謝~
            99久久免费国产精品| 久久r热这里有精品视频| 久久综合中文字幕| 久久精品午夜一区二区福利| 囯产精品久久久久久久久蜜桃| 久久香蕉国产线看观看猫咪?v| 久久伊人色| 久久精品久久久久观看99水蜜桃| 一本色道久久88综合日韩精品| 日韩AV毛片精品久久久| 久久亚洲熟女cc98cm| 亚洲色大成网站WWW久久九九| 久久精品国产亚洲AV高清热| 久久国产乱子精品免费女| 很黄很污的网站久久mimi色| 欧美成a人片免费看久久| 一本久道久久综合狠狠爱| 久久国产免费观看精品3| Xx性欧美肥妇精品久久久久久 | 久久青青草视频| 99久久免费国产精品特黄| 国产成人精品免费久久久久| 亚洲国产精品久久久久婷婷软件 | 一本一道久久a久久精品综合| 亚洲色欲久久久综合网东京热| 久久精品国产99国产精偷 | 久久亚洲精品无码aⅴ大香 | 91性高湖久久久久| 人妻无码精品久久亚瑟影视| 精品久久一区二区三区| 久久噜噜久久久精品66| 久久国产精品无码HDAV| 久久婷婷色综合一区二区| 久久精品亚洲中文字幕无码麻豆| 久久久久亚洲精品天堂久久久久久| 少妇久久久久久被弄高潮| 狠狠色丁香婷婷综合久久来来去| 精品久久人人爽天天玩人人妻| 品成人欧美大片久久国产欧美... 品成人欧美大片久久国产欧美 | 色99久久久久高潮综合影院| 国产一久久香蕉国产线看观看|