• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            oyjpArt ACM/ICPC算法程序設計空間

            // I am new in programming, welcome to my blog
            I am oyjpart(alpc12, 四城)
            posts - 224, comments - 694, trackbacks - 0, articles - 6

            PKU1465 Multiple

            Posted on 2007-01-15 15:11 oyjpart 閱讀(1637) 評論(2)  編輯 收藏 引用 所屬分類: ACM/ICPC或其他比賽

            Multiple
            Time Limit:1000MS? Memory Limit:32768K
            Total Submit:992 Accepted:221

            Description
            a program that, given a natural number N between 0 and 4999 (inclusively), and M distinct decimal digits X1,X2..XM (at least one), finds the smallest strictly positive multiple of N that has no other digits besides X1,X2..XM (if such a multiple exists).

            Input
            The input has several data sets separated by an empty line, each data set having the following format:

            On the first line - the number N
            On the second line - the number M
            On the following M lines - the digits X1,X2..XM.

            Output
            For each data set, the program should write to standard output on a single line the multiple, if such a multiple exists, and 0 otherwise.

            An example of input and output:

            Sample Input

            22
            3
            7
            0
            1
            
            2
            1
            1

            Sample Output

            110
            0
            思路:
            設基數為X
            首先 如果兩個數對bs取模相等(為M) 則
            A = aX + M
            B = bX + M
            那么只要其中一個可以取到結果 即
            (10*(bX + M)+ C)MOD X = 0
            也就是(10*M)MOD X?+ C MOD X = 0
            則另一個必定也可以整除 X
            這樣在搜索的時候如果只需要搜索A (假設A<B) 就可以了
            也就是說如果我們按照BFS擴展 把狀態設置為MOD值 則只需要M的長度的隊列就可以完成這個搜索了
            無解的情況如何?自然就是無法擴展的情況。至于是否要優化最后一層(即搜索到了所有的非0 mod值 我認為沒有必要)
            注意不要把一個5000的字符串和其mod數封裝在一起作為隊列元素 會TLE的 呵呵
            Solution:
            //by Optmistic
            #include <algorithm>
            using namespace std;
            const int N = 5010;
            struct E{char num; int m; E * f;};
            E q[N];
            int cd[10], X;
            bool chk[N];
            void print(const E& e) {
            ?if(e.f)?{
            ??print(*e.f);
            ??printf("%c", e.num);
            ?}
            }
            int main() {
            ?int i, nc;
            ?while(scanf("%d", &X)!=EOF) {
            ??scanf("%d", &nc);
            ??memset(chk, 0, sizeof(chk));
            ??for(i = 0; i<nc; i++)
            ???scanf("%d", cd+i);
            ??if(X == 0) {printf("0\n");continue;}
            ??sort(cd, cd+nc);
            ??int qs = 0, qe = 1;
            ??q[0].m = 0;
            ??q[0].f = NULL;
            ??E * first = &q[0];
            ??while(qs < qe) {
            ???E cur = q[qs];
            ???E now;
            ???now.f = &q[qs];
            ???int m = cur.m;
            ???for(i = 0; i< nc; i++) {
            ????int s = (10*m+cd[i])%X;
            ????if(!chk[s] && (now.f != first || cd[i] > 0) ) {
            ?????now.m = s;
            ?????now.num = cd[i]+'0';
            ?????q[qe++] = now;
            ?????chk[s] = 1;
            ?????if(s == 0) {
            ??????print(now);
            ??????putchar('\n');
            ??????goto HERE;
            ?????}
            ????}
            ???}
            ???qs++;
            ??}
            HERE:??if(qs == qe) printf("0\n");
            ?}
            ?return 0;
            }
            寫這個的時候發現一首很好聽的歌
            《No promises》
            shayne ward

            Hey baby, when we are together, doing things that we love.
            Every time you're near I feel like I’m in heaven, feeling high
            I don’t want to let go, girl.
            I just need you to know girl.
            I don’t wanna run away, baby you’re the one I need tonight,
            No promises.
            Baby, now I need to hold you tight, I just wanna die in your arms
            Here tonight
            Hey baby, when we are together, doing things that we love.
            Everytime you're near I feel like I’m in heaven, feeling high
            I don’t want to let go, girl.
            I just need you you to know girl.
            I don’t wanna run away, baby you’re the one I need tonight,
            No promises.
            Baby, now I need to hold you tight, I just wanna die in your arms
            I don’t want to run away, I want to stay forever, thru Time and Time..
            No promises
            I don’t wanna run away, I don’t wanna be alone
            No Promises
            Baby, now I need to hold you tight, now and forever my love
            No promises
            I don’t wanna run away, baby you’re the one I need tonight,
            No promises.
            Baby, now I need to hold you tight, I just wanna die in your arms
            I don’t wanna run away, baby you’re the one I need tonight,
            No promises.
            Baby, now I need to hold you tight, I just wanna die in your arms
            Here tonight..

            Feedback

            # re: PKU1465 Multiple   回復  更多評論   

            2008-06-23 20:28 by sdfond
            shayne ward的歌有幾首都不錯^^

            # re: PKU1465 Multiple   回復  更多評論   

            2008-10-04 19:57 by
            好像有缺陷
            97久久精品人人做人人爽| 欧美精品乱码99久久蜜桃| 国内精品伊人久久久久777| 漂亮人妻被黑人久久精品| 久久最近最新中文字幕大全| 久久se这里只有精品| 久久人人爽人人爽人人片AV不| 爱做久久久久久| 狠狠干狠狠久久| AV狠狠色丁香婷婷综合久久| 久久亚洲av无码精品浪潮| 99国产精品久久久久久久成人热| 伊人色综合久久天天网| 久久综合九色综合欧美就去吻| 一本色道久久99一综合| 久久精品国产亚洲5555| 久久精品国产亚洲Aⅴ香蕉| 久久婷婷五月综合97色一本一本| 久久夜色撩人精品国产| 国产精品9999久久久久| 伊人热热久久原色播放www| 国产成人香蕉久久久久| AV色综合久久天堂AV色综合在| 日韩精品久久久久久久电影| 一本色综合久久| 久久综合精品国产一区二区三区| 亚洲国产成人久久精品影视| 一本一道久久综合狠狠老| 色综合久久天天综线观看| 久久久久人妻精品一区三寸蜜桃| a级成人毛片久久| 久久精品www| 久久精品成人免费看| 精品永久久福利一区二区| 99久久婷婷免费国产综合精品| 久久天天躁狠狠躁夜夜avapp| 少妇人妻88久久中文字幕| 青草影院天堂男人久久| 久久久久久久尹人综合网亚洲| 久久国产精品久久精品国产| 中文字幕亚洲综合久久2|