• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            隨筆 - 87  文章 - 279  trackbacks - 0
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            潛心看書研究!

            常用鏈接

            留言簿(19)

            隨筆分類(81)

            文章分類(89)

            相冊

            ACM OJ

            My friends

            搜索

            •  

            積分與排名

            • 積分 - 216652
            • 排名 - 117

            最新評論

            閱讀排行榜

            評論排行榜

            解題報告:http://www.mydrs.org/program/list.asp?id=583

            Bridging Signals

            Time limit: 1 Seconds?? Memory limit: 32768K??
            Total Submit: 946?? Accepted Submit: 495??

            'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

            Figure 1. To the left: The two blocks' ports and their signal mapping (4, 2, 6, 3, 1, 5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

            A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the ith number specifies which port on the right side should be connected to the ith port on the left side. Two signals cross if and only if the straight lines connecting the two ports of each pair do.


            Input

            On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:

            On the ith line is the port number of the block on the right side which should be connected to the ith port of the block on the left side.


            Output

            For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.


            Sample Input

            4
            6
            4
            2
            6
            3
            1
            5
            10
            2
            3
            4
            5
            6
            7
            8
            9
            10
            1
            8
            8
            7
            6
            5
            4
            3
            2
            1
            9
            5
            8
            9
            2
            3
            1
            7
            4
            6

            Sample Output

            3
            9
            1
            4

            #include? < iostream>
            using
            ? namespace?std;

            const ? int ?MAXN? = ? 40001;

            void?Solve()
            {
            ????
            int?n;
            ????
            int?i,?j,?k;
            ????
            int?l,?r,?m;
            ????
            int?t;
            ????
            int ?d[MAXN]? = ? { 0 };
            ????
            int?a[MAXN];
            ????
            int ?len? = ? 0;
            ????scanf(
            " %d " ,? &n);
            ????
            for ?(i = 1 ;?i <= n;?i ++)?
            ????????scanf(
            " %d " ,? &a[i]);
            ????
            for ?(i = 1 ;?i <= n;?i ++)
            ????
            {
            ????????
            if ?(a[i]? >?d[len])
            ????????
            {
            ????????????len?
            += ? 1;
            ????????????d[len]?
            =?a[i];
            ????????}

            ????????
            else
            ????????
            {
            ????????????l?
            = ? 1;
            ????????????r?
            =?len;
            ????????????
            while ?(l? < ?r? - ? 1)
            ????????????
            {
            ????????????????m?
            = ?(l? + ?r)? / ? 2;
            ????????????????
            if ?(d[m]? <?a[i])
            ????????????????????l?
            =?m;
            ????????????????else
            ????????????????????r?
            =?m;
            ????????????}

            ????????????if
            ?(d[l]?>?a[i])?
            ????????????????d[l]?
            =?a[i];
            ????????????else
            ????????????????d[r]?
            =?a[i];
            ????????}

            ????}

            ????printf("
            %d\n ",?len);????????
            }



            int?main()
            {
            ????
            int?caseTime;
            ????scanf(
            " %d " ,? &caseTime);
            ????
            while ?(caseTime -- ? != ? 0)
            ????
            {
            ????????Solve();
            ????}

            ????system("pause
            ");
            ????
            return ?0;
            }






            posted on 2006-10-04 12:20 閱讀(581) 評論(0)  編輯 收藏 引用 所屬分類: ACM題目
            伊人久久大香线蕉av一区| 66精品综合久久久久久久| 要久久爱在线免费观看| 久久久精品国产免大香伊| 久久国产精品无码一区二区三区| 久久精品国产久精国产思思| 久久无码国产| 99久久无码一区人妻a黑| 久久亚洲AV无码西西人体| 国产亚洲精品美女久久久| 久久高潮一级毛片免费| 国内精品伊人久久久久av一坑 | 国产精品久久久久久五月尺| 久久综合狠狠综合久久综合88| 久久免费美女视频| 亚洲国产另类久久久精品黑人| 美女久久久久久| 国产成人无码精品久久久免费| 久久精品国产第一区二区三区 | 国产精品久久久久a影院| 久久精品男人影院| 亚洲中文字幕久久精品无码APP | 精品欧美一区二区三区久久久| 亚洲午夜久久久影院伊人| 久久精品极品盛宴观看| 久久综合狠狠综合久久97色| 青青青国产精品国产精品久久久久 | 精品国产一区二区三区久久久狼| 久久综合九色综合网站| 亚洲国产精品狼友中文久久久| 久久精品国产免费一区| 国产精品久久久久久福利69堂| 久久久久久亚洲精品成人| 一本一本久久aa综合精品| 久久亚洲AV成人无码软件| 国产A三级久久精品| 精品一二三区久久aaa片| 亚洲欧美成人综合久久久| 欧美丰满熟妇BBB久久久| 国产一久久香蕉国产线看观看| 久久精品无码一区二区无码|