• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 3692 Kindergarten 二分圖最大獨立集

            Description

            In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

            Input

            The input consists of multiple test cases. Each test case starts with a line containing three integers
            G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
            the number of pairs of girl and boy who know each other, respectively.
            Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
            The girls are numbered from 1 to G and the boys are numbered from 1 to B.

            The last test case is followed by a line containing three zeros.

            Output

            For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

            Sample Input

            2 3 3
            1 1
            1 2
            2 3
            2 3 5
            1 1
            1 2
            2 1
            2 2
            2 3
            0 0 0

            Sample Output

            Case 1: 3
            Case 2: 4

            Source


                 

            本題是要求圖中的最大完全子圖(最大團)中頂點的個數。由于原圖的補圖是一個二分圖,其最大完全數等價于其補圖的最大獨立集中元素的個數,于是可以根據二分圖的性質求出這個最大獨立集。而普通圖的最大團則是一個NP問題。

            定理:二分圖最大獨立集=頂點數-二分圖最大匹配

            最大完全數:圖中最大完全子圖的頂點個數。

            獨立集:圖中任意兩個頂點都不相連的頂點集合。

            #include <iostream>
            using namespace std;

            const int MAXN = 201;
            bool visit[MAXN];
            int n,m,k,mark[MAXN];
            bool map[MAXN][MAXN];

            bool dfs(int u){
                
            int i;
                
            for(i=1;i<=m;i++)
                    
            if(map[u][i] && !visit[i]){
                        visit[i]
            =true;
                        
            if(mark[i]==-1 || dfs(mark[i])){
                            mark[i]
            =u;
                            
            return true;
                        }

                    }

                
            return false;
            }

            int hungary(){
                
            int i,ans=0;
                
            for(i=1;i<=n;i++){
                    memset(visit,
            false,sizeof(visit));
                    
            if(dfs(i)) ans++;
                }

                
            return ans;
            }

            int main(){
                
            int i,j,x,y,id=1;
                
            while(scanf("%d %d %d",&n,&m,&k),n||m||k){
                    
            for(i=1;i<=n;i++for(j=1;j<=m;j++) map[i][j]=true;
                    
            while(k--){
                        scanf(
            "%d %d",&x,&y);
                        map[x][y]
            =false;
                    }

                    memset(mark,
            -1,sizeof(mark));
                    printf(
            "Case %d: %d\n",id++,n+m-hungary());
                }

                
            return 0;
            }

            posted on 2009-06-02 15:14 極限定律 閱讀(2073) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年8月>
            2627282930311
            2345678
            9101112131415
            16171819202122
            23242526272829
            303112345

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久精品?ⅴ无码中文字幕| 久久99精品久久久久久秒播| 国产偷久久久精品专区| 亚洲国产精品成人久久蜜臀| 色综合久久中文综合网| 很黄很污的网站久久mimi色| AV狠狠色丁香婷婷综合久久| 久久久www免费人成精品| 亚洲国产另类久久久精品| 国产精品99久久免费观看| 久久香蕉国产线看观看乱码| 久久精品国产亚洲av麻豆色欲| 激情伊人五月天久久综合| 久久婷婷国产麻豆91天堂| 久久无码国产| 国产午夜久久影院| 亚洲精品美女久久久久99| 人人狠狠综合久久亚洲88| 最新久久免费视频| 国内精品久久久久久不卡影院 | 久久亚洲国产精品五月天婷| 国产综合成人久久大片91| 久久亚洲精品成人无码网站| 偷窥少妇久久久久久久久| 精品久久久久久中文字幕| 亚洲精品成人网久久久久久| 久久99热这里只频精品6| 国产精品久久永久免费| 久久综合久久综合亚洲| 国产精品久久久久影院色| 香蕉久久永久视频| 日韩电影久久久被窝网| 久久天天躁狠狠躁夜夜躁2O2O | 亚洲国产精品无码久久| 成人a毛片久久免费播放| 色妞色综合久久夜夜| 午夜视频久久久久一区| 精品国产91久久久久久久a| MM131亚洲国产美女久久| 伊人久久大香线蕉av不变影院| 国产A级毛片久久久精品毛片|