• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            ZOJ 1276 Optimal Array Multiplication Sequence 經典DP問題

            Given two arrays A and B, we can determine the array C = A B using the standard definition of matrix multiplication:

             

            The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let's say that rows(A) and columns(A) are the number of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(A) columns(B) columns(A). For example, if A is a 10 x 20 array, and B is a 20 x 15 array, it will take 10 x 15 x 20, or 3000 multiplications to compute the C array.


            To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if X, Y, and Z are arrays, then to compute X Y Z we could either compute (X Y) Z or X (Y Z). Suppose X is a 5 x 10 array, Y is a 10 x 20 array, and Z is a 20 x 35 array. Let's look at the number of multiplications required to compute the product using the two different sequences:

             

            (X Y) Z


            5 x 20 x 10 = 1000 multiplications to determine the product (X Y), a 5 x 20 array.

            Then 5 x 35 x 20 = 3500 multiplications to determine the final result.

            Total multiplications: 4500.

            X (Y Z)

            10 x 35 x 20 = 7000 multiplications to determine the product (Y Z), a 10 x 35 array.

            Then 5 x 35 x 10 = 1750 multiplications to determine the final result.

            Total multiplications: 8750.

            Clearly we'll be able to compute (X Y) Z using fewer individual multiplications.

            Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplcations required.


            Input

            For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates the end of the input. N will be no larger than 10.


            Output

            Assume the arrays are named A1, A2, ..., AN. Your output for each input case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.


            Sample Input

            3
            1 5
            5 20
            20 1
            3
            5 10
            10 20
            20 35
            6
            30 35
            35 15
            15 5
            5 10
            10 20
            20 25
            0


            Sample Output

            Case 1: (A1 x (A2 x A3))
            Case 2: ((A1 x A2) x A3)
            Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))


            Source: North Central North America 1996
                

                設計算矩陣A[i:j],1<=i<=j<=n,所需要的最少乘法次數為m[i,j],則原問題的最優值為m[1,n]。
                當i=j時,A[i:j]=Ai,m[i,i]=0,i=1,2,...,n;
                當i<j時,m[i,j]=m[i,k]+m[k+1][j]+pi-1*pk*pj,i<=k<j。
            #include<iostream>
            using namespace std;

            void MatrixChain(int n,int p[],int m[][11],int s[][11]){
                
            int i,j,k,r,t;
                
            for(i=1;i<=n;i++) m[i][i]=0;
                
            for(r=2;r<=n;r++)
                    
            for(i=1;i<=n-r+1;i++){
                        j
            =i+r-1;
                        m[i][j]
            =m[i+1][j]+p[i-1]*p[i]*p[j];
                        s[i][j]
            =i;
                        
            for(k=i+1;k<j;k++){
                            t
            =m[i][k]+m[k+1][j]+p[i-1]*p[k]*p[j];
                            
            if(t<m[i][j]){
                                m[i][j]
            =t;
                                s[i][j]
            =k;
                            }

                        }

                    }

            }

            void output(int i,int j,int s[][11]){
                
            if(i==j)
                    printf(
            "A%d",i);
                
            else{
                    printf(
            "(");
                    output(i,s[i][j],s);
                    printf(
            " x ");
                    output(s[i][j]
            +1,j,s);
                    printf(
            ")");
                }

            }

            int main(){
                
            int i,n,ca=1,p[11],m[11][11],s[11][11];
                
            while(scanf("%d",&n),n){
                    
            for(i=1;i<=n;i++) scanf("%d %d",&p[i-1],&p[i]);
                    MatrixChain(n,p,m,s);
                    printf(
            "Case %d: ",ca++);
                    output(
            1,n,s);
                    printf(
            "\n");
                }

                
            return 0;
            }

            posted on 2009-06-19 09:27 極限定律 閱讀(1192) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2015年9月>
            303112345
            6789101112
            13141516171819
            20212223242526
            27282930123
            45678910

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久综合丁香激情久久| 三级片免费观看久久| 97热久久免费频精品99| AV无码久久久久不卡网站下载| 久久精品亚洲精品国产色婷| 久久精品国产影库免费看| 久久精品亚洲福利| 中文字幕热久久久久久久| 精品综合久久久久久888蜜芽| 青青青青久久精品国产| 午夜精品久久久久久久无码| 欧美牲交A欧牲交aⅴ久久| 国产无套内射久久久国产| 久久久国产精华液| 久久亚洲精品中文字幕三区| 色播久久人人爽人人爽人人片AV| 久久精品无码午夜福利理论片| 国产精品伦理久久久久久| 久久无码AV中文出轨人妻| 激情综合色综合久久综合| 7777久久久国产精品消防器材| 激情综合色综合久久综合| 69久久夜色精品国产69| 人人妻久久人人澡人人爽人人精品| 99久久精品影院老鸭窝| 亚洲AV日韩AV天堂久久| 青青热久久国产久精品| 国产福利电影一区二区三区久久久久成人精品综合 | 亚洲国产成人久久综合野外| 久久99国产亚洲高清观看首页| 丁香色欲久久久久久综合网| 久久一区二区三区99| 国产精品欧美久久久久天天影视| 久久久久久毛片免费播放| 久久久久久精品无码人妻| 亚洲伊人久久综合影院| 欧美国产精品久久高清| 国产成人精品久久亚洲| 久久精品无码一区二区app| 精品久久久久中文字幕一区| 狠狠色伊人久久精品综合网 |