• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 2115 模線性方程 ax=b(mod n)

            Description

            A Compiler Mystery: We are given a C-language style for loop of type
            for (variable = A; variable != B; variable += C)
            
            statement;

            I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

            Input

            The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

            The input is finished by a line containing four zeros.

            Output

            The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

            Sample Input

            3 3 2 16
            3 7 2 16
            7 3 2 16
            3 4 2 16
            0 0 0 0
            

            Sample Output

            0
            2
            32766
            FOREVER

            Source


                推論1:方程ax=b(mod n)對于未知量x有解,當且僅當gcd(a,n) | b。
                推論2:方程ax=b(mod n)或者對模n有d個不同的解,其中d=gcd(a,n),或者無解。
                定理1:設d=gcd(a,n),假定對整數x和y滿足d=ax+by(比如用擴展Euclid算法求出的一組解)。如果d | b,則方程ax=b(mod n)有一個解x0滿足x0=x*(b/d) mod n 。特別的設e=x0+n,方程ax=b(mod n)的最小整數解x1=e mod (n/d),最大整數解x2=x1+(d-1)*(n/d)。
                定理2:假設方程ax=b(mod n)有解,且x0是方程的任意一個解,則該方程對模n恰有d個不同的解(d=gcd(a,n)),分別為:xi=x0+i*(n/d) mod n 。
                以上定理的具體證明見《算法導論》。
            #include <iostream>
            using namespace std;

            long long ext_gcd(long long a,long long b,long long &x,long long &y){
                
            long long t,ret;
                
            if(!b){
                    x
            =1,y=0;
                    
            return a;
                }

                ret
            =ext_gcd(b,a%b,x,y);
                t
            =x,x=y,y=t-a/b*y;
                
            return ret;
            }

            long long modular_linear(long long a,long long b,long long n){
                
            long long d,e,x,y;
                d
            =ext_gcd(a,n,x,y);
                
            if(b%d)
                    
            return -1;
                e
            =x*(b/d)%n+n;
                
            return e%(n/d);
            }

            int main(){
                
            long long d,a,b,c,k;
                
            while(scanf("%lld %lld %lld %lld",&a,&b,&c,&k),a||b||c||k){
                    d
            =modular_linear(c,b-a,1LL<<k);
                    
            if(d==-1)
                        puts(
            "FOREVER");
                    
            else
                        printf(
            "%lld\n",d);
                }

                
            return 0;
            }

            posted on 2009-06-12 19:24 極限定律 閱讀(2659) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2015年9月>
            303112345
            6789101112
            13141516171819
            20212223242526
            27282930123
            45678910

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            国产偷久久久精品专区| 久久久久久国产精品美女| 99麻豆久久久国产精品免费| 久久人人爽人人爽人人片AV麻豆| 久久青青草视频| 久久国产热精品波多野结衣AV| 91精品国产91久久久久久青草| 久久99精品国产麻豆婷婷| 亚洲va久久久噜噜噜久久狠狠| 国内精品久久久久影院网站| 亚洲欧美国产日韩综合久久| 国内精品免费久久影院| 无码精品久久久天天影视| 精品九九久久国内精品| 精品国产乱码久久久久久郑州公司 | 四虎亚洲国产成人久久精品| 亚洲国产一成人久久精品| 国产精品久久久久国产A级| 四虎久久影院| 日韩亚洲欧美久久久www综合网| 亚洲中文字幕无码一久久区| 99久久精品免费看国产免费| 久久中文字幕人妻熟av女| 亚洲国产高清精品线久久| 99久久精品毛片免费播放| 香蕉久久永久视频| 久久久免费观成人影院| 久久er热视频在这里精品| 伊人久久五月天| 香蕉aa三级久久毛片| 午夜精品久久久内射近拍高清| 国产精品美女久久久网AV| 国产精品久久久久国产A级| 中文字幕久久精品无码| 久久综合亚洲色一区二区三区| 理论片午午伦夜理片久久 | 久久婷婷五月综合色99啪ak| 久久免费视频网站| 国产L精品国产亚洲区久久 | 四虎影视久久久免费| 久久精品卫校国产小美女|