• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 3692 Kindergarten 二分圖最大獨立集

            Description

            In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

            Input

            The input consists of multiple test cases. Each test case starts with a line containing three integers
            G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
            the number of pairs of girl and boy who know each other, respectively.
            Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
            The girls are numbered from 1 to G and the boys are numbered from 1 to B.

            The last test case is followed by a line containing three zeros.

            Output

            For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

            Sample Input

            2 3 3
            1 1
            1 2
            2 3
            2 3 5
            1 1
            1 2
            2 1
            2 2
            2 3
            0 0 0

            Sample Output

            Case 1: 3
            Case 2: 4

            Source


                 

            本題是要求圖中的最大完全子圖(最大團)中頂點的個數。由于原圖的補圖是一個二分圖,其最大完全數等價于其補圖的最大獨立集中元素的個數,于是可以根據二分圖的性質求出這個最大獨立集。而普通圖的最大團則是一個NP問題。

            定理:二分圖最大獨立集=頂點數-二分圖最大匹配

            最大完全數:圖中最大完全子圖的頂點個數。

            獨立集:圖中任意兩個頂點都不相連的頂點集合。

            #include <iostream>
            using namespace std;

            const int MAXN = 201;
            bool visit[MAXN];
            int n,m,k,mark[MAXN];
            bool map[MAXN][MAXN];

            bool dfs(int u){
                
            int i;
                
            for(i=1;i<=m;i++)
                    
            if(map[u][i] && !visit[i]){
                        visit[i]
            =true;
                        
            if(mark[i]==-1 || dfs(mark[i])){
                            mark[i]
            =u;
                            
            return true;
                        }

                    }

                
            return false;
            }

            int hungary(){
                
            int i,ans=0;
                
            for(i=1;i<=n;i++){
                    memset(visit,
            false,sizeof(visit));
                    
            if(dfs(i)) ans++;
                }

                
            return ans;
            }

            int main(){
                
            int i,j,x,y,id=1;
                
            while(scanf("%d %d %d",&n,&m,&k),n||m||k){
                    
            for(i=1;i<=n;i++for(j=1;j<=m;j++) map[i][j]=true;
                    
            while(k--){
                        scanf(
            "%d %d",&x,&y);
                        map[x][y]
            =false;
                    }

                    memset(mark,
            -1,sizeof(mark));
                    printf(
            "Case %d: %d\n",id++,n+m-hungary());
                }

                
            return 0;
            }

            posted on 2009-06-02 15:14 極限定律 閱讀(2073) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年4月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            无码人妻久久久一区二区三区| 久久久久无码精品国产app| 欧美一区二区三区久久综合| 久久天天躁狠狠躁夜夜躁2O2O| 国产精品久久久久久影院| 久久亚洲精品无码播放| 久久人人爽人人爽人人AV东京热| 亚洲国产精品久久久久久| 欧美激情精品久久久久久久| 蜜臀av性久久久久蜜臀aⅴ| 久久免费香蕉视频| 少妇高潮惨叫久久久久久| 久久91这里精品国产2020| 久久久久AV综合网成人 | 国产成人香蕉久久久久| 午夜精品久久久久9999高清| 久久婷婷五月综合色奶水99啪| 亚洲国产成人久久一区久久| 国产精品久久国产精麻豆99网站| 久久午夜无码鲁丝片秋霞| 观看 国产综合久久久久鬼色 欧美 亚洲 一区二区 | 亚洲欧洲精品成人久久曰影片| 精品久久久无码人妻中文字幕豆芽| 色综合久久中文字幕综合网| 久久婷婷国产麻豆91天堂| 天天爽天天狠久久久综合麻豆| 国产欧美久久久精品影院| 久久99精品久久久久久9蜜桃 | 狠狠精品干练久久久无码中文字幕| 久久久久人妻一区精品性色av| 亚洲另类欧美综合久久图片区| 国内精品久久久久久久久| 亚洲国产精久久久久久久| 国产成人久久精品区一区二区| 色婷婷综合久久久久中文 | 久久综合伊人77777| 久久久精品人妻无码专区不卡| 久久国产美女免费观看精品| 精品久久久久久久中文字幕| 午夜精品久久久久9999高清| 日韩精品久久久久久久电影|