Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.
The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input
2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output
Case 1: 3
Case 2: 4
Source
本題是要求圖中的最大完全子圖(最大團)中頂點的個數。由于原圖的補圖是一個二分圖,其最大完全數等價于其補圖的最大獨立集中元素的個數,于是可以根據二分圖的性質求出這個最大獨立集。而普通圖的最大團則是一個NP問題。
定理:二分圖最大獨立集=頂點數-二分圖最大匹配
最大完全數:圖中最大完全子圖的頂點個數。
獨立集:圖中任意兩個頂點都不相連的頂點集合。
#include <iostream>
using namespace std;

const int MAXN = 201;
bool visit[MAXN];
int n,m,k,mark[MAXN];
bool map[MAXN][MAXN];


bool dfs(int u)
{
int i;
for(i=1;i<=m;i++)

if(map[u][i] && !visit[i])
{
visit[i]=true;

if(mark[i]==-1 || dfs(mark[i]))
{
mark[i]=u;
return true;
}
}
return false;
}

int hungary()
{
int i,ans=0;

for(i=1;i<=n;i++)
{
memset(visit,false,sizeof(visit));
if(dfs(i)) ans++;
}
return ans;
}

int main()
{
int i,j,x,y,id=1;

while(scanf("%d %d %d",&n,&m,&k),n||m||k)
{
for(i=1;i<=n;i++) for(j=1;j<=m;j++) map[i][j]=true;

while(k--)
{
scanf("%d %d",&x,&y);
map[x][y]=false;
}
memset(mark,-1,sizeof(mark));
printf("Case %d: %d\n",id++,n+m-hungary());
}
return 0;
}