Description
A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p
max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c
max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l
max(u,v) of power delivered by u to v. Let Con=Σ
uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p
max(u)=y. The label x/y of consumer u shows that c(u)=x and c
max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l
max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4
Sample Output
15
6
Hint
The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.
輸入分別為m個點,a個發電站,b個用戶,n條邊;接下去是n條邊的信息(u,v)cost,cost表示邊(u,v)的最大流量;a個發電站的信息(u)cost,cost表示發電站u能提供的最大流量;b個用戶的信息(v)cost,cost表示每個用戶v能接受的最大流量。
典型的最大網絡流中多源多匯的問題,在圖中添加1個源點S和匯點T,將S和每個發電站相連,邊的權值是發電站能提供的最大流量;將每個用戶和T相連,邊的權值是每個用戶能接受的最大流量。從而轉化成了一般的最大網絡流問題,然后求解。
#include <iostream>
#include <queue>
using namespace std;

const int MAXN = 110;
const int INF = 0x7FFFFFFF;
int n,m,start,end;
int path[MAXN],flow[MAXN],map[MAXN][MAXN];
queue<int> q;


int bfs()
{
int i,t;
while(!q.empty()) q.pop();
memset(path,-1,sizeof(path));
path[start]=0,flow[start]=INF;
q.push(start);

while(!q.empty())
{
t=q.front();
q.pop();
if(t==end) break;

for(i=1;i<=m;i++)
{

if(i!=start && path[i]==-1 && map[t][i])
{
flow[i]=flow[t]<map[t][i]?flow[t]:map[t][i];
q.push(i);
path[i]=t;
}
}
}
if(path[end]==-1) return -1;
return flow[end];
}

int Edmonds_Karp()
{
int max_flow=0,step,now,pre;

while((step=bfs())!=-1)
{
max_flow+=step;
now=end;

while(now!=start)
{
pre=path[now];
map[pre][now]-=step;
map[now][pre]+=step;
now=pre;
}
}
return max_flow;
}

int main()
{
int i,a,b,u,v,cost;

while(scanf("%d %d %d %d",&m,&a,&b,&n)!=EOF)
{
getchar();
memset(map,0,sizeof(map));

for(i=0;i<n;i++)
{
while(getchar()!='(');
scanf("%d,%d)%d",&u,&v,&cost);
map[u+1][v+1]=cost;
}

for(start=m+1,i=0;i<a;i++)
{
while(getchar()!='(');
scanf("%d)%d",&u,&cost);
map[start][u+1]=cost;
}

for(end=m+2,i=0;i<b;i++)
{
while(getchar()!='(');
scanf("%d)%d",&v,&cost);
map[v+1][end]=cost;
}
m=m+2;
printf("%d\n",Edmonds_Karp());
}
return 0;
}