• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 3264 RMQ問題

            Description

            For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

            Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

            Input

            Line 1: Two space-separated integers, N and Q.
            Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
            Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

            Output

            Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

            Sample Input

            6 3
            1
            7
            3
            4
            2
            5
            1 5
            4 6
            2 2

            Sample Output

            6
            3
            0

            Source

                題目大意:有N頭牛,對于第i頭牛,它的高度是h[i];有Q個查詢,每次查詢給定一個區間[a,b],求第a頭牛到第b頭牛中最高的和最矮的相差多少。對于這種典型的RMQ問題,可以建立一棵線段樹,然后查詢。
            #include <iostream>

            #define max(a,b) (a>b?a:b)
            #define min(a,b) (a<b?a:b)
            const int MAXN = 50001;

            struct segment{
                
            int left,right;
                
            int high,low;
            }
            tree[MAXN*2];
            int t,s,height[MAXN];

            void create(int l,int r,int index){
                tree[index].left
            =l,tree[index].right=r;
                
            if(l==r){
                    tree[index].high
            =height[l];
                    tree[index].low
            =height[l];
                    
            return;
                }

                
            int mid=(l+r)>>1;
                create(l,mid,
            2*index);
                create(mid
            +1,r,2*index+1);
                tree[index].high
            =max(tree[2*index].high,tree[2*index+1].high);
                tree[index].low
            =min(tree[2*index].low,tree[2*index+1].low);
            }

            void update(int l,int r,int index){
                
            if(tree[index].left==&& tree[index].right==r){
                    
            if(tree[index].high>t) t=tree[index].high;
                    
            if(tree[index].low<s) s=tree[index].low;
                    
            return;
                }

                
            int mid=(tree[index].left+tree[index].right)>>1;
                
            if(r<=mid)
                    update(l,r,
            2*index);
                
            else if(l>mid)
                    update(l,r,
            2*index+1);
                
            else{
                    update(l,mid,
            2*index);
                    update(mid
            +1,r,2*index+1);
                }

            }

            int main(){
                
            int i,n,q,x,y;
                scanf(
            "%d %d",&n,&q);
                
            for(i=1;i<=n;i++) scanf("%d",&height[i]);
                create(
            1,n,1);
                
            for(i=1;i<=q;i++){
                    scanf(
            "%d %d",&x,&y);
                    t
            =0,s=10000000;
                    update(x,y,
            1);
                    printf(
            "%d\n",t-s);
                }

                
            return 0;
            }

            posted on 2009-05-14 16:05 極限定律 閱讀(367) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年8月>
            2627282930311
            2345678
            9101112131415
            16171819202122
            23242526272829
            303112345

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久国产成人| 久久九九精品99国产精品| 天天爽天天爽天天片a久久网| 精品久久久久久国产牛牛app| 热综合一本伊人久久精品 | 国产高潮国产高潮久久久91 | 久久精品国产精品亚洲精品| 久久久青草久久久青草| 久久人人爽人人爽人人AV东京热| 2020最新久久久视精品爱 | 久久r热这里有精品视频| 久久精品国产亚洲AV无码娇色| 久久久久久久97| aaa级精品久久久国产片| 国产精品99久久久久久董美香| 久久精品国产精品青草app| 久久精品草草草| 亚洲欧洲精品成人久久奇米网| 久久婷婷五月综合97色直播| 亚洲国产成人久久精品99| 久久狠狠高潮亚洲精品| 久久久久九国产精品| 嫩草影院久久99| 99久久久精品| 91精品国产综合久久久久久| 久久久亚洲精品蜜桃臀| 久久久久99精品成人片三人毛片| 中文字幕久久精品| 亚洲精品无码久久久| 久久久久国色AV免费观看| 国产亚洲精久久久久久无码AV| 久久精品国产亚洲AV无码偷窥| 东京热TOKYO综合久久精品| 久久久久99精品成人片欧美| 精品久久久久久亚洲精品| 国色天香久久久久久久小说 | 亚洲精品成人久久久| 91精品国产91久久久久久| 久久最新精品国产| 伊人久久综合无码成人网| av国内精品久久久久影院|