• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 3264 RMQ問題

            Description

            For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

            Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

            Input

            Line 1: Two space-separated integers, N and Q.
            Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
            Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

            Output

            Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

            Sample Input

            6 3
            1
            7
            3
            4
            2
            5
            1 5
            4 6
            2 2

            Sample Output

            6
            3
            0

            Source

                題目大意:有N頭牛,對(duì)于第i頭牛,它的高度是h[i];有Q個(gè)查詢,每次查詢給定一個(gè)區(qū)間[a,b],求第a頭牛到第b頭牛中最高的和最矮的相差多少。對(duì)于這種典型的RMQ問題,可以建立一棵線段樹,然后查詢。
            #include <iostream>

            #define max(a,b) (a>b?a:b)
            #define min(a,b) (a<b?a:b)
            const int MAXN = 50001;

            struct segment{
                
            int left,right;
                
            int high,low;
            }
            tree[MAXN*2];
            int t,s,height[MAXN];

            void create(int l,int r,int index){
                tree[index].left
            =l,tree[index].right=r;
                
            if(l==r){
                    tree[index].high
            =height[l];
                    tree[index].low
            =height[l];
                    
            return;
                }

                
            int mid=(l+r)>>1;
                create(l,mid,
            2*index);
                create(mid
            +1,r,2*index+1);
                tree[index].high
            =max(tree[2*index].high,tree[2*index+1].high);
                tree[index].low
            =min(tree[2*index].low,tree[2*index+1].low);
            }

            void update(int l,int r,int index){
                
            if(tree[index].left==&& tree[index].right==r){
                    
            if(tree[index].high>t) t=tree[index].high;
                    
            if(tree[index].low<s) s=tree[index].low;
                    
            return;
                }

                
            int mid=(tree[index].left+tree[index].right)>>1;
                
            if(r<=mid)
                    update(l,r,
            2*index);
                
            else if(l>mid)
                    update(l,r,
            2*index+1);
                
            else{
                    update(l,mid,
            2*index);
                    update(mid
            +1,r,2*index+1);
                }

            }

            int main(){
                
            int i,n,q,x,y;
                scanf(
            "%d %d",&n,&q);
                
            for(i=1;i<=n;i++) scanf("%d",&height[i]);
                create(
            1,n,1);
                
            for(i=1;i<=q;i++){
                    scanf(
            "%d %d",&x,&y);
                    t
            =0,s=10000000;
                    update(x,y,
            1);
                    printf(
            "%d\n",t-s);
                }

                
            return 0;
            }

            posted on 2009-05-14 16:05 極限定律 閱讀(367) 評(píng)論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年4月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            導(dǎo)航

            統(tǒng)計(jì)

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評(píng)論

            閱讀排行榜

            評(píng)論排行榜

            www亚洲欲色成人久久精品| 久久妇女高潮几次MBA| 色婷婷综合久久久中文字幕| 狠狠人妻久久久久久综合| 国产精品久久久久天天影视| 久久亚洲精品国产精品| 久久久久女人精品毛片| 国内精品久久久久影院日本| 日韩人妻无码一区二区三区久久| 亚洲精品乱码久久久久久久久久久久 | 漂亮人妻被黑人久久精品| 婷婷久久久亚洲欧洲日产国码AV| 色偷偷偷久久伊人大杳蕉| 久久亚洲中文字幕精品有坂深雪 | 精品国产乱码久久久久软件| 免费精品久久天干天干| 久久久久亚洲AV成人网人人网站| 久久精品无码专区免费青青| 性做久久久久久久| 久久精品中文騷妇女内射| 精品久久久久久久久中文字幕| 精品久久久久国产免费| 中文精品久久久久人妻不卡| 久久伊人精品一区二区三区| 久久精品人人做人人爽97| 久久亚洲欧洲国产综合| 久久久久久午夜精品| 久久精品国产99久久久| 亚洲日本va午夜中文字幕久久| 久久久久高潮毛片免费全部播放| 一级做a爰片久久毛片人呢| 日本欧美国产精品第一页久久| 久久99国内精品自在现线| 久久久不卡国产精品一区二区| 无码人妻久久一区二区三区免费丨| 亚洲午夜久久久精品影院| 日日躁夜夜躁狠狠久久AV| 久久午夜综合久久| 97精品久久天干天天天按摩| 久久夜色撩人精品国产| 1000部精品久久久久久久久|