• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 1050 To the MAX(最大子矩陣問題)

            Problem Description
            Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

            As an example, the maximal sub-rectangle of the array:

            0 -2 -7 0
            9 2 -6 2
            -4 1 -4 1
            -1 8 0 -2

            is in the lower left corner:

            9 2
            -4 1
            -1 8

            and has a sum of 15.
             

            Input
            The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
             

            Output
            Output the sum of the maximal sub-rectangle.
             

            Sample Input
            4
            0 -2 -7 0 9 2 -6 2
            -4 1 -4 1 -1
            8 0 -2
             

            Sample Output
            15
            給定一個N*N的矩陣,要求一個子矩陣,使得該矩陣的元素和最大。轉為為最大連續子序列問題。
             1 #include <iostream>
             2 
             3 const int N = 101;
             4 const int inf = INT_MIN;
             5 int a[N][N],b[N];
             6 
             7 int MaxSum(int n,int a[]){
             8     int i,sum=inf,b=0;
             9     for(i=1;i<=n;i++){
            10         b=(b+a[i])>a[i]?(b+a[i]):a[i];
            11         sum=sum>b?sum:b;
            12     }
            13     return sum;
            14 }
            15 int main(){
            16     int n,i,j,k,max,ans;
            17     while(scanf("%d",&n)!=EOF){
            18         for(i=1;i<=n;i++)
            19             for(j=1;j<=n;j++)
            20                 scanf("%d",&a[i][j]);
            21         for(max=inf,i=1;i<=n;i++){
            22             memset(b,0,sizeof(b));
            23             for(j=i;j<=n;j++){
            24                 for(k=1;k<=n;k++)
            25                     b[k]+=a[j][k];
            26                 ans=MaxSum(n,b);
            27                 max=max>ans?max:ans;
            28             }
            29         }
            30         printf("%d\n",max);
            31     }
            32     return 0;
            33 }

            posted on 2009-04-25 12:30 極限定律 閱讀(1738) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年6月>
            31123456
            78910111213
            14151617181920
            21222324252627
            2829301234
            567891011

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久ww精品w免费人成| 国产精品一区二区久久精品涩爱 | 久久综合九色综合久99| 久久久久亚洲AV无码专区首JN| 色婷婷狠狠久久综合五月| 青青热久久国产久精品| 欧美久久天天综合香蕉伊| 国内精品久久久久影院亚洲| 亚洲精品无码久久不卡| 久久99精品国产麻豆宅宅| 久久精品人人做人人妻人人玩 | 少妇高潮惨叫久久久久久| 色综合久久无码中文字幕| 精品国产乱码久久久久久郑州公司| 精品久久人妻av中文字幕| 久久最新精品国产| 久久精品国产精品亚洲艾草网美妙| 欧美麻豆久久久久久中文| 久久精品卫校国产小美女| 97久久超碰国产精品2021| 亚洲午夜久久影院| 国内精品久久国产| 国产69精品久久久久777| 美女久久久久久| 久久综合亚洲欧美成人| 国产99久久久国产精品~~牛 | 国内高清久久久久久| 久久99精品久久久久久hb无码| 精品国产青草久久久久福利| 久久午夜夜伦鲁鲁片免费无码影视| av无码久久久久不卡免费网站 | 国内精品伊人久久久久妇| 久久99精品国产99久久6男男| 精品久久久久久无码国产| 亚洲AV无一区二区三区久久| 色噜噜狠狠先锋影音久久| 久久国语露脸国产精品电影| 成人精品一区二区久久| 久久久一本精品99久久精品66| 久久天天躁狠狠躁夜夜2020| 久久99国产精一区二区三区|