• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 1050 To the MAX(最大子矩陣問題)

            Problem Description
            Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

            As an example, the maximal sub-rectangle of the array:

            0 -2 -7 0
            9 2 -6 2
            -4 1 -4 1
            -1 8 0 -2

            is in the lower left corner:

            9 2
            -4 1
            -1 8

            and has a sum of 15.
             

            Input
            The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
             

            Output
            Output the sum of the maximal sub-rectangle.
             

            Sample Input
            4
            0 -2 -7 0 9 2 -6 2
            -4 1 -4 1 -1
            8 0 -2
             

            Sample Output
            15
            給定一個N*N的矩陣,要求一個子矩陣,使得該矩陣的元素和最大。轉為為最大連續子序列問題。
             1 #include <iostream>
             2 
             3 const int N = 101;
             4 const int inf = INT_MIN;
             5 int a[N][N],b[N];
             6 
             7 int MaxSum(int n,int a[]){
             8     int i,sum=inf,b=0;
             9     for(i=1;i<=n;i++){
            10         b=(b+a[i])>a[i]?(b+a[i]):a[i];
            11         sum=sum>b?sum:b;
            12     }
            13     return sum;
            14 }
            15 int main(){
            16     int n,i,j,k,max,ans;
            17     while(scanf("%d",&n)!=EOF){
            18         for(i=1;i<=n;i++)
            19             for(j=1;j<=n;j++)
            20                 scanf("%d",&a[i][j]);
            21         for(max=inf,i=1;i<=n;i++){
            22             memset(b,0,sizeof(b));
            23             for(j=i;j<=n;j++){
            24                 for(k=1;k<=n;k++)
            25                     b[k]+=a[j][k];
            26                 ans=MaxSum(n,b);
            27                 max=max>ans?max:ans;
            28             }
            29         }
            30         printf("%d\n",max);
            31     }
            32     return 0;
            33 }

            posted on 2009-04-25 12:30 極限定律 閱讀(1738) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年4月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            亚洲精品无码久久久久久| 久久毛片免费看一区二区三区| 合区精品久久久中文字幕一区| 久久精品人妻一区二区三区| 无夜精品久久久久久| 欧美喷潮久久久XXXXx| 久久99国产精品二区不卡| 久久综合五月丁香久久激情| 99久久精品免费看国产一区二区三区| 久久久久女教师免费一区| 久久精品一本到99热免费| 国产成人无码精品久久久久免费| 婷婷久久综合| 99久久99久久| 国产精品久久婷婷六月丁香| 亚洲成人精品久久| 久久综合亚洲色HEZYO社区| 99久久精品国产一区二区| 久久天天躁夜夜躁狠狠| 久久精品综合一区二区三区| 久久精品国产亚洲77777| 国产A级毛片久久久精品毛片| 蜜桃麻豆www久久| 久久亚洲天堂| 国产精品xxxx国产喷水亚洲国产精品无码久久一区 | 精品综合久久久久久88小说| 无码日韩人妻精品久久蜜桃| 久久久亚洲欧洲日产国码是AV| 一本伊大人香蕉久久网手机| 久久99国产综合精品免费| 伊人久久综合成人网| 久久AV高潮AV无码AV| 一本久久综合亚洲鲁鲁五月天| 91精品观看91久久久久久| 91精品国产91久久久久久蜜臀| 久久线看观看精品香蕉国产| 精品久久久久久国产| 久久综合久久综合久久| 久久国产综合精品五月天| 久久精品国产一区二区三区| 久久精品免费大片国产大片|