• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            poj 2524 Ubiquitous Religions 【并查集】

            Ubiquitous Religions
            Time Limit: 5000MS Memory Limit: 65536K
            Total Submissions: 12445 Accepted: 5900

            Description

            There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

            You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

            Input

            The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

            Output

            For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

            Sample Input

            10 9
            1 2
            1 3
            1 4
            1 5
            1 6
            1 7
            1 8
            1 9
            1 10
            10 4
            2 3
            4 5
            4 8
            5 8
            0 0
            

            Sample Output

            Case 1: 1
            Case 2: 7
            第一個并查集程序,最小生成樹不算。
             n個點,給你m條邊,求最大能有多少個連通分量。
            #include<iostream>
            using namespace std;
            const int MAX=50001;
            int fa[MAX];

            int find(int x)
            {
                
            return fa[x]==x?x:find(fa[x]);
            }

            void Union(int x, int y)
            {
                 fa[find(x)]
            =find(y);
            }
            int main()
            {
                
            int n,m;
                
            for(int tt=1; ; tt++)
                { 
                          cin
            >>n>>m;
                         
            if( n==0&&m==0)break;
                         
                         
            for(int i=1; i<=n; i++)
                                 fa[i]
            =i; 
                                 
                         
            int max=n;              
                         
            for(int i=1,s,t; i<=m; i++)
                                 {
                                     cin
            >>s>>t;
                                     
            if(find(s)!=find(t))max=max-1;
                                     Union(s,t);              
                                 }
                                 
                         cout
            <<"Case "<<tt<<':'<<' '<<max<<endl;
                         
                }
                
                system(
            "pause");    
                
            return 0;
            }


            posted on 2010-08-26 19:20 田兵 閱讀(316) 評論(0)  編輯 收藏 引用 所屬分類: 算法筆記

            <2010年8月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            導航

            統計

            常用鏈接

            留言簿(2)

            隨筆分類(65)

            隨筆檔案(65)

            文章檔案(2)

            ACM

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            亚洲成色999久久网站| 久久精品麻豆日日躁夜夜躁| 久久香蕉国产线看观看乱码| 久久美女网站免费| 久久综合伊人77777麻豆| 亚洲国产精品无码成人片久久| 久久天堂AV综合合色蜜桃网| 99久久精品费精品国产 | 欧美一区二区三区久久综| 久久精品国产网红主播| 久久久久亚洲av成人无码电影| 人妻无码αv中文字幕久久| 久久99精品九九九久久婷婷 | 久久久精品人妻一区二区三区蜜桃 | 人妻少妇久久中文字幕| 久久久精品国产亚洲成人满18免费网站 | 亚洲精品tv久久久久| 亚洲av成人无码久久精品| 久久久无码精品午夜| 91精品国产91久久综合| 亚洲人成网亚洲欧洲无码久久| 国产成人精品久久综合| 成人国内精品久久久久影院| 中文成人无码精品久久久不卡| 伊人色综合久久天天| 久久精品国产亚洲av麻豆色欲| 久久99热这里只频精品6| 很黄很污的网站久久mimi色| 97精品国产91久久久久久| 日韩av无码久久精品免费| 亚洲伊人久久精品影院| 久久99久久99精品免视看动漫| 久久强奷乱码老熟女网站| 国产精品99久久久久久宅男| 国产精品久久久天天影视| 99久久成人国产精品免费| 九九久久99综合一区二区| 久久91精品国产91久久麻豆 | 久久综合视频网站| 欧美精品乱码99久久蜜桃| 久久夜色精品国产亚洲|