• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            poj 2524 Ubiquitous Religions 【并查集】

            Ubiquitous Religions
            Time Limit: 5000MS Memory Limit: 65536K
            Total Submissions: 12445 Accepted: 5900

            Description

            There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

            You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

            Input

            The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

            Output

            For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

            Sample Input

            10 9
            1 2
            1 3
            1 4
            1 5
            1 6
            1 7
            1 8
            1 9
            1 10
            10 4
            2 3
            4 5
            4 8
            5 8
            0 0
            

            Sample Output

            Case 1: 1
            Case 2: 7
            第一個并查集程序,最小生成樹不算。
             n個點,給你m條邊,求最大能有多少個連通分量。
            #include<iostream>
            using namespace std;
            const int MAX=50001;
            int fa[MAX];

            int find(int x)
            {
                
            return fa[x]==x?x:find(fa[x]);
            }

            void Union(int x, int y)
            {
                 fa[find(x)]
            =find(y);
            }
            int main()
            {
                
            int n,m;
                
            for(int tt=1; ; tt++)
                { 
                          cin
            >>n>>m;
                         
            if( n==0&&m==0)break;
                         
                         
            for(int i=1; i<=n; i++)
                                 fa[i]
            =i; 
                                 
                         
            int max=n;              
                         
            for(int i=1,s,t; i<=m; i++)
                                 {
                                     cin
            >>s>>t;
                                     
            if(find(s)!=find(t))max=max-1;
                                     Union(s,t);              
                                 }
                                 
                         cout
            <<"Case "<<tt<<':'<<' '<<max<<endl;
                         
                }
                
                system(
            "pause");    
                
            return 0;
            }


            posted on 2010-08-26 19:20 田兵 閱讀(316) 評論(0)  編輯 收藏 引用 所屬分類: 算法筆記

            <2010年8月>
            25262728293031
            1234567
            891011121314
            15161718192021
            22232425262728
            2930311234

            導航

            統計

            常用鏈接

            留言簿(2)

            隨筆分類(65)

            隨筆檔案(65)

            文章檔案(2)

            ACM

            搜索

            積分與排名

            最新隨筆

            最新評論

            閱讀排行榜

            亚洲精品高清国产一线久久| 久久99精品久久久久久久不卡| 国产精品久久亚洲不卡动漫| 国产亚洲美女精品久久久久狼| 久久美女网站免费| 久久久久久极精品久久久| 久久久久青草线蕉综合超碰| 国产Av激情久久无码天堂 | 国产精品久久久久久久午夜片| 国产99久久九九精品无码| 久久人与动人物a级毛片| 色综合久久天天综合| 99久久综合国产精品免费| 久久99国产精品久久99果冻传媒| 久久久久久免费视频| 伊人色综合久久天天| 色偷偷88888欧美精品久久久| 久久国产高清一区二区三区| 久久中文骚妇内射| 久久人人爽人人爽人人片av麻烦| 国产精品成人久久久久久久| 欧美一区二区三区久久综| 中文字幕精品无码久久久久久3D日动漫 | 久久99精品久久久久久齐齐| 97精品依人久久久大香线蕉97 | 亚洲国产成人久久一区WWW| 99久久99久久精品免费看蜜桃| 日本五月天婷久久网站| 国产日韩久久久精品影院首页| 99国产欧美精品久久久蜜芽 | 久久久午夜精品福利内容| 久久最新精品国产| 日本福利片国产午夜久久| 99久久99久久| www性久久久com| 成人免费网站久久久| 国内精品伊人久久久久AV影院| 色88久久久久高潮综合影院| 亚洲精品乱码久久久久久蜜桃图片 | 热99RE久久精品这里都是精品免费 | 国产99久久久国产精免费|