• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            HDOJ 1016 Prime Ring Problem

            Problem Description
            A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

            Note: the number of first circle should always be 1.


             

            Input
            n (0 < n < 20).
             

            Output
            The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

            You are to write a program that completes above process.

            Print a blank line after each case.
             

            Sample Input
            6
            8
             

            Sample Output
            Case 1:
            1 4 3 2 5 6
            1 6 5 2 3 4
            Case 2:
            1 2 3 8 5 6 7 4
            1 2 5 8 3 4 7 6
            1 4 7 6 5 8 3 2
            1 6 7 4 3 8 5 2
                素數環:由1到n個數構成一個環,其中環內任意2個相鄰的數字之和是素數。
                比較經典的搜索題,由于n<20,可以先預處理出前40個自然數中的素數,然后深搜某個位置的未被訪問過的數字和它相鄰位置的數字之和是否為素數,搜索退出的條件為最后一個位置的數字circle[n]+1是否為素數。一次搜索完成后,要回溯,否則只會輸出一組解。
            #include <iostream>
            using namespace std;

            const int MAXN = 41;
            bool visit[MAXN];
            int n,p[MAXN],circle[MAXN];

            void prime(){
                
            int i,j;
                memset(p,
            true,sizeof(p));
                
            for(i=2;i<MAXN;i++)
                    
            for(j=2;i*j<MAXN;j++)
                        p[i
            *j]=false;
            }

            void dfs(int c,int cnt){
                
            if(cnt==&& p[circle[1]+circle[n]]){
                    
            for(int i=1;i<n;i++)
                        printf(
            "%d ",circle[i]);
                    printf(
            "%d\n",circle[n]);
                }

                
            for(int i=c+1;i<MAXN;i++)
                    
            if(p[i] && i-c<=&& !visit[i-c]){
                        circle[cnt
            +1]=i-c;
                        visit[i
            -c]=true;
                        dfs(i
            -c,cnt+1);
                        visit[i
            -c]=false;
                    }

            }

            int main(){
                
            int c=1;
                prime();
                
            while(scanf("%d",&n)!=EOF){
                    memset(visit,
            false,sizeof(visit));
                    printf(
            "Case %d:\n",c++);
                    visit[
            1]=true,circle[1]=1;
                    dfs(
            1,1);
                    printf(
            "\n");
                }

                
            return 0;
            }

            posted on 2009-05-24 13:37 極限定律 閱讀(1171) 評論(1)  編輯 收藏 引用 所屬分類: ACM/ICPC

            評論

            # re: HDOJ 1016 Prime Ring Problem 2009-08-04 09:53

            謝了 !!!!!!!!!!1  回復  更多評論   

            <2009年6月>
            31123456
            78910111213
            14151617181920
            21222324252627
            2829301234
            567891011

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            亚洲人AV永久一区二区三区久久| 久久精品国产清高在天天线| 久久精品国产只有精品66| 国产L精品国产亚洲区久久| 午夜视频久久久久一区 | 熟妇人妻久久中文字幕| 久久美女人爽女人爽| 国产精品免费久久久久久久久| 国产一区二区久久久| 精品久久久噜噜噜久久久| 欧美大战日韩91综合一区婷婷久久青草| 久久综合久久综合亚洲| 精品九九久久国内精品| 要久久爱在线免费观看| 欧美日韩中文字幕久久伊人| 久久精品亚洲AV久久久无码| 久久精品国产99久久久香蕉| 久久发布国产伦子伦精品| 青青草国产97免久久费观看| 久久综合狠狠综合久久激情 | 久久国产免费直播| 思思久久99热免费精品6| 青青国产成人久久91网| 久久国产精品无码HDAV| 亚洲中文字幕久久精品无码喷水| 青青青青久久精品国产h久久精品五福影院1421 | 久久久久亚洲精品日久生情| 久久av免费天堂小草播放| 国产精品一久久香蕉产线看| 久久婷婷国产综合精品| 久久婷婷色综合一区二区| 久久夜色精品国产噜噜亚洲a| 久久男人AV资源网站| 国内精品免费久久影院| 久久精品中文字幕第23页| 中文字幕久久欲求不满| 国产精品伦理久久久久久| 久久久久国产精品三级网| 理论片午午伦夜理片久久| 四虎影视久久久免费观看| 久久久久久久女国产乱让韩|