• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            POJ 2195 Going Home 二分圖完美匹配

            Description

            On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

            Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

            You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

            Input

            There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

            Output

            For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

            Sample Input

            2 2
            .m
            H.
            5 5
            HH..m
            .....
            .....
            .....
            mm..H
            7 8
            ...H....
            ...H....
            ...H....
            mmmHmmmm
            ...H....
            ...H....
            ...H....
            0 0
            

            Sample Output

            2
            10
            28
            

            Source


                題目大意:有m個人要進h間房子,從當前位置(x1,y1)進入房子(x2,y2)的時間為|x1-x2|+|y1-y2|,問這m個人都進入房間所需的最小時間是多少。問題可以轉化為帶權二分圖的最小權匹配,以sample 2為例先建立二分圖:
             
            (m1,h1)=4,(m1,h2)=3,(m1,h3)=4,(m2,h1)=4,(m2,h2)=5,(m2,h3)=4,(m3,h1)=5,(m3,h2)=4,(m3,h3)=3.
            然后用KM算法求解,代碼中的注釋部分為最大權匹配。
            #include <iostream>

            const int MAX = 101;
            const int MAXN = 10001;
            const int inf = 0x7FFFFFFF;
            struct point{
                
            int x,y;
            }
            man[MAXN],home[MAXN];
            bool vx[MAX],vy[MAX];
            int m,h,map[MAX][MAXN],lx[MAX],ly[MAX],match[MAX];

            bool dfs(int u){
                
            int i;
                
            for(vx[u]=true,i=0;i<h;i++)
                    
            if(!vy[i] && lx[u]+ly[i]==map[u][i]){
                        vy[i]
            =true;
                        
            if(match[i]==-1 || dfs(match[i])){
                            match[i]
            =u;
                            
            return true;
                        }

                    }

                
            return false;
            }

            int kuhn_munkras(){
                
            int i,j,k,min,ans;
                
            for(i=0;i<m;i++)
                    
            for(lx[i]=inf,j=0;j<h;j++)
                        
            if(map[i][j]<lx[i]) lx[i]=map[i][j];
              
            //for(i=0;i<m;i++)
              
            //    for(lx[i]=-inf,j=0;j<h;j++)
              
            //        if(map[i][j]>lx[i]) lx[i]=map[i][j]; 最大權匹配
                for(i=0;i<h;i++) ly[i]=0;
                memset(match,
            -1,sizeof(match));
                
            for(i=0;i<m;i++){
                    
            while(true){
                        memset(vx,
            false,sizeof(vx));
                        memset(vy,
            false,sizeof(vy));
                        min
            =inf;
                        
            if(dfs(i)) break;
                        
            for(j=0;j<m;j++){
                            
            if(vx[j]){
                                
            for(k=0;k<h;k++)
                                    
            if(!vy[k] && map[j][k]-lx[j]-ly[k]<min)
                                        min
            =map[j][k]-lx[j]-ly[k];
                                  
            //if(!vy[k] && lx[j]+ly[k]-map[j][k]<min)
                                  
            //    min=map[j][k]-lx[j]-ly[k]; 最大權匹配
                            }

                        }

                        
            for(j=0;j<m;j++if(vx[j]) lx[j]+=min;
                        
            for(j=0;j<h;j++if(vy[j]) ly[j]-=min;
                    }

                }

                
            for(ans=i=0;i<h;i++) ans+=map[match[i]][i];
                
            return ans;
            }

            int main(){
                
            char ch;
                
            int i,j,row,colum;
                
            while(scanf("%d %d",&row,&colum),row||colum){
                    
            for(getchar(),m=h=i=0;i<row;i++){
                        
            for(j=0;j<colum;j++){
                            ch
            =getchar();
                            
            if(ch=='m')
                                man[m].x
            =i,man[m].y=j,m++;
                            
            else if(ch=='H')
                                home[h].x
            =i,home[h].y=j,h++;
                        }

                        getchar();
                    }

                    memset(map,
            0,sizeof(map));
                    
            for(i=0;i<m;i++)
                        
            for(j=0;j<h;j++)
                            map[i][j]
            =abs(man[i].x-home[j].x)+abs(man[i].y-home[j].y);
                    printf(
            "%d\n",kuhn_munkras());
                }

                
            return 0;
            }

            posted on 2009-06-03 12:45 極限定律 閱讀(809) 評論(0)  編輯 收藏 引用 所屬分類: ACM/ICPC

            <2009年4月>
            2930311234
            567891011
            12131415161718
            19202122232425
            262728293012
            3456789

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            色综合久久精品中文字幕首页 | 国产免费福利体检区久久| 精品国产VA久久久久久久冰| 热re99久久精品国产99热| 久久久久一本毛久久久| 欧美久久久久久| 91精品久久久久久无码| 久久无码专区国产精品发布| 久久综合给合久久国产免费| 国产香蕉97碰碰久久人人| 午夜精品久久久久久久| 大香网伊人久久综合网2020| 久久精品亚洲AV久久久无码| 国产精品久久国产精麻豆99网站| 激情久久久久久久久久| 亚洲色大成网站www久久九 | 久久亚洲国产成人影院| 国产精品久久自在自线观看| 综合久久一区二区三区 | 精品999久久久久久中文字幕| 欧美亚洲国产精品久久| 久久99亚洲综合精品首页| 久久久久人妻一区精品性色av| 国产精品久久久久乳精品爆| 欧美牲交A欧牲交aⅴ久久| 日日狠狠久久偷偷色综合免费| 国产成年无码久久久久毛片| 久久成人小视频| 伊人久久大香线蕉AV一区二区 | 久久精品国产亚洲av高清漫画 | 国产99久久久国产精品小说| 99久久婷婷国产综合精品草原 | 国产精品久久新婚兰兰| 国产成人精品久久亚洲| 精品久久久久久国产91| 国产亚洲综合久久系列| 欧美黑人激情性久久| 国产精品久久久久免费a∨| 久久亚洲2019中文字幕| 久久久WWW免费人成精品| 99久久国产亚洲高清观看2024|