• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            HDOJ 1698 Just A Hook 線段樹

            Problem Description
            In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



            Now Pudge wants to do some operations on the hook.

            Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
            The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

            For each cupreous stick, the value is 1.
            For each silver stick, the value is 2.
            For each golden stick, the value is 3.

            Pudge wants to know the total value of the hook after performing the operations.
            You may consider the original hook is made up of cupreous sticks.
             

            Input
            The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
            For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
            Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
             

            Output
            For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
             

            Sample Input
            1
            10
            2
            1 5 2
            5 9 3
             

            Sample Output
            Case 1: The total value of the hook is 24.
             

            Source

            #include <iostream>
            using namespace std;

            const int MAXN = 100001;
            struct segment{
                
            int left,right,color;
                
            bool cover;
            }
            tree[MAXN*3];

            void create(int l,int r,int step){
                tree[step].left
            =l,tree[step].right=r;
                tree[step].color
            =tree[step].cover=1;
                
            if(l==r) return ;
                
            int mid=(l+r)>>1;
                create(l,mid,
            2*step);
                create(mid
            +1,r,2*step+1);
            }

            void update(int l,int r,int c,int step){
                
            if(l==tree[step].left&&r==tree[step].right){
                    tree[step].color
            =c;
                    tree[step].cover
            =1;
                    
            return;
                }

                
            if(tree[step].cover){
                    tree[step].cover
            =0;
                    tree[
            2*step].cover=tree[2*step+1].cover=1;
                    tree[
            2*step].color=tree[2*step+1].color=tree[step].color;
                }

                
            if(r<=tree[2*step].right)
                    update(l,r,c,
            2*step);
                
            else if(l>=tree[2*step+1].left)
                    update(l,r,c,
            2*step+1);
                
            else{
                    update(l,tree[
            2*step].right,c,2*step);
                    update(tree[
            2*step+1].left,r,c,2*step+1);
                }

            }

            int query(int step){
                
            if(tree[step].cover) 
                    
            return tree[step].color*(tree[step].right-tree[step].left+1);
                
            else 
                    
            return query(2*step)+query(2*step+1);
            }

            int main(){
                
            int i,t,n,q,l,r,c;
                scanf(
            "%d",&t);
                
            for(i=1;i<=t;i++){
                    scanf(
            "%d %d",&n,&q);
                    create(
            1,n,1);
                    
            while(q--){
                        scanf(
            "%d %d %d",&l,&r,&c);
                        update(l,r,c,
            1);
                    }

                    printf(
            "Case %d: The total value of the hook is %d.\n",i,query(1));
                }

                
            return 0;
            }

            posted on 2009-05-12 16:32 極限定律 閱讀(506) 評論(1)  編輯 收藏 引用 所屬分類: ACM/ICPC

            評論

            # re: HDOJ 1698 Just A Hook 線段樹 2009-08-13 21:02 zeus

            good 剛剛做了也是1y
            呵呵你寫什么都很詳細啊 學習了  回復  更多評論   

            <2013年2月>
            272829303112
            3456789
            10111213141516
            17181920212223
            242526272812
            3456789

            導航

            統計

            常用鏈接

            留言簿(10)

            隨筆分類

            隨筆檔案

            友情鏈接

            搜索

            最新評論

            閱讀排行榜

            評論排行榜

            久久天天躁狠狠躁夜夜躁2O2O| 青青草国产精品久久| 91麻豆国产精品91久久久| 久久精品国产乱子伦| 久久Av无码精品人妻系列| 精品乱码久久久久久夜夜嗨| 国产精品99久久久久久宅男小说| 久久精品国产精品亚洲精品| 久久精品国产精品青草app| 久久婷婷五月综合色奶水99啪| 久久99国产综合精品女同| 日韩精品无码久久一区二区三| 人妻无码αv中文字幕久久琪琪布 人妻无码久久一区二区三区免费 人妻无码中文久久久久专区 | 亚洲va国产va天堂va久久| 狠狠色噜噜狠狠狠狠狠色综合久久| 色偷偷88欧美精品久久久| 久久国产乱子精品免费女| 无码精品久久久久久人妻中字| 精品欧美一区二区三区久久久 | 97久久婷婷五月综合色d啪蜜芽 | 狠狠色丁香婷婷综合久久来| 久久青青草视频| 久久99精品久久久久久野外| www.久久99| 无码精品久久久久久人妻中字| 亚洲AⅤ优女AV综合久久久| 97超级碰碰碰碰久久久久| 性色欲网站人妻丰满中文久久不卡| 精品久久人人做人人爽综合 | 久久久精品2019免费观看| 亚洲中文字幕久久精品无码喷水 | 久久久免费精品re6| 久久久久波多野结衣高潮| 色悠久久久久久久综合网| 久久久国产一区二区三区| 国产成人99久久亚洲综合精品| 97久久天天综合色天天综合色hd| 97久久国产露脸精品国产| 久久精品中文无码资源站| 99久久精品免费看国产一区二区三区| 亚洲欧洲久久av|