• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            The 2010 ACM-ICPC Asia Chengdu Regional Contest - C Binary Number 水題,枚舉~

            Binary Number

            Time Limit: 2 Seconds      Memory Limit: 65536 KB

            For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1, f(0, 3)=2, f(5, 10)=4.

            Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integers in set A, choose the smallest one.

            Input

            The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

            Output

            For each test case you should output n lines, each of which contains the result for each query in a single line.

            Sample Input

            2
            2 5
            1
            2
            1
            2
            3
            4
            5
            5 2
            1000000
            9999
            1423
            3421
            0
            13245
            353
            

             

            Sample Output

            1
            2
            1
            1
            1
            9999
            0
            
            不解釋了,N2
            
             1# include <iostream>
             2# include <algorithm>
             3using namespace std;
             4int a[101],n,m;
             5int main()
             6{
             7    int t;
             8    cin>>t;
             9    while(t--)
            10    {
            11        cin>>n>>m;
            12        for(int i=0;i<n;i++)
            13           cin>>a[i];
            14        sort(a,a+n);
            15        for(int i=0;i<m;i++)
            16        {
            17           int t,res=0xfffffff,num;
            18           cin>>t;
            19           for(int j=0;j<n;j++)
            20           {
            21              int tmp1=a[j],tmp2=t,diff=0;
            22              while(tmp1||tmp2)
            23              {
            24                 diff+=((tmp1&1)!=(tmp2&1));
            25                 tmp1>>=1;
            26                 tmp2>>=1;
            27              }

            28              if(diff<res) res=diff,num=a[j];
            29           }

            30           cout<<num<<endl;
            31        }

            32    }

            33  //  system("pause");
            34    return 0;
            35}

            36

            posted on 2010-11-16 00:35 yzhw 閱讀(337) 評論(0)  編輯 收藏 引用 所屬分類: simple problem~

            <2010年12月>
            2829301234
            567891011
            12131415161718
            19202122232425
            2627282930311
            2345678

            導航

            統計

            公告

            統計系統

            留言簿(1)

            隨筆分類(227)

            文章分類(2)

            OJ

            最新隨筆

            搜索

            積分與排名

            最新評論

            閱讀排行榜

            久久久久亚洲av无码专区导航| 国产精品综合久久第一页| 精品久久久久久无码不卡| 国产精品久久久久a影院| 久久天天躁狠狠躁夜夜96流白浆| 精品一区二区久久| 亚洲成av人片不卡无码久久| 亚洲国产精品无码久久SM| 久久久久国产精品熟女影院| 国产巨作麻豆欧美亚洲综合久久 | 久久综合丁香激情久久| 成人精品一区二区久久久| 国内精品久久久久影院薰衣草 | 少妇久久久久久被弄到高潮| 久久久久高潮毛片免费全部播放 | 日韩欧美亚洲国产精品字幕久久久| 天堂久久天堂AV色综合| 久久精品一区二区三区中文字幕| 久久久久久精品成人免费图片| 成人国内精品久久久久影院VR| 综合久久国产九一剧情麻豆| 国产精品免费久久久久电影网| 人妻无码久久一区二区三区免费 | 99热都是精品久久久久久| 亚洲伊人久久精品影院| 蜜臀久久99精品久久久久久| 久久99精品综合国产首页| 亚洲精品无码久久千人斩| 久久影院午夜理论片无码 | 99久久综合国产精品免费| 久久精品国产99久久久香蕉| 久久综合久久综合久久| 久久久久一区二区三区| 精品999久久久久久中文字幕| 三上悠亚久久精品| 成人午夜精品无码区久久| 三级三级久久三级久久| 亚洲精品美女久久久久99小说| 青草久久久国产线免观| 色婷婷狠狠久久综合五月| 久久99精品久久久久久不卡|