• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>

            The 2010 ACM-ICPC Asia Chengdu Regional Contest - C Binary Number 水題,枚舉~

            Binary Number

            Time Limit: 2 Seconds      Memory Limit: 65536 KB

            For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1, f(0, 3)=2, f(5, 10)=4.

            Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integers in set A, choose the smallest one.

            Input

            The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

            Output

            For each test case you should output n lines, each of which contains the result for each query in a single line.

            Sample Input

            2
            2 5
            1
            2
            1
            2
            3
            4
            5
            5 2
            1000000
            9999
            1423
            3421
            0
            13245
            353
            

             

            Sample Output

            1
            2
            1
            1
            1
            9999
            0
            
            不解釋了,N2
            
             1# include <iostream>
             2# include <algorithm>
             3using namespace std;
             4int a[101],n,m;
             5int main()
             6{
             7    int t;
             8    cin>>t;
             9    while(t--)
            10    {
            11        cin>>n>>m;
            12        for(int i=0;i<n;i++)
            13           cin>>a[i];
            14        sort(a,a+n);
            15        for(int i=0;i<m;i++)
            16        {
            17           int t,res=0xfffffff,num;
            18           cin>>t;
            19           for(int j=0;j<n;j++)
            20           {
            21              int tmp1=a[j],tmp2=t,diff=0;
            22              while(tmp1||tmp2)
            23              {
            24                 diff+=((tmp1&1)!=(tmp2&1));
            25                 tmp1>>=1;
            26                 tmp2>>=1;
            27              }

            28              if(diff<res) res=diff,num=a[j];
            29           }

            30           cout<<num<<endl;
            31        }

            32    }

            33  //  system("pause");
            34    return 0;
            35}

            36

            posted on 2010-11-16 00:35 yzhw 閱讀(337) 評論(0)  編輯 收藏 引用 所屬分類: simple problem~

            <2010年11月>
            31123456
            78910111213
            14151617181920
            21222324252627
            2829301234
            567891011

            導航

            統計

            公告

            統計系統

            留言簿(1)

            隨筆分類(227)

            文章分類(2)

            OJ

            最新隨筆

            搜索

            積分與排名

            最新評論

            閱讀排行榜

            www.久久热.com| 国产精品99久久久精品无码| 亚洲中文字幕久久精品无码APP| 久久精品无码一区二区日韩AV | 精品人妻伦九区久久AAA片69| 伊人色综合久久天天| 99久久精品免费看国产| 精品久久久久久久久久久久久久久 | 亚洲国产成人久久一区WWW| 97久久婷婷五月综合色d啪蜜芽 | 久久精品国产久精国产思思| 久久久久久久综合日本亚洲| 久久久久久久亚洲精品| 久久人爽人人爽人人片AV| 国产成人精品久久亚洲高清不卡| 欧美激情精品久久久久久久九九九| 中文字幕久久精品无码| 国产精品99久久精品爆乳| 伊人久久大香线蕉AV色婷婷色| 色综合久久久久网| 午夜天堂av天堂久久久| 久久婷婷色综合一区二区| 2022年国产精品久久久久| 欧美日韩中文字幕久久久不卡 | 人人狠狠综合88综合久久| 国产精品青草久久久久婷婷| 欧美国产成人久久精品| 精品水蜜桃久久久久久久| 欧美黑人又粗又大久久久| 伊人久久国产免费观看视频| 日本福利片国产午夜久久| 久久精品www人人爽人人| 久久人人爽人人爽人人片AV高清| 国产精品一区二区久久精品无码 | 99久久免费国产特黄| 伊人久久久AV老熟妇色| 7777精品伊人久久久大香线蕉| 久久精品亚洲福利| 久久婷婷五月综合色99啪ak| 国产精品99久久久久久www| 99久久婷婷国产综合精品草原|