• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            隨筆 - 87  文章 - 279  trackbacks - 0
            <2025年5月>
            27282930123
            45678910
            11121314151617
            18192021222324
            25262728293031
            1234567

            潛心看書研究!

            常用鏈接

            留言簿(19)

            隨筆分類(81)

            文章分類(89)

            相冊

            ACM OJ

            My friends

            搜索

            •  

            積分與排名

            • 積分 - 216468
            • 排名 - 117

            最新評論

            閱讀排行榜

            評論排行榜

            The Triangle
            Time Limit:1000MS  Memory Limit:10000K

            Description

            7
            
            3 8
            8 1 0
            2 7 4 4
            4 5 2 6 5

            (Figure 1)

            Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

            Input
            Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

            Output
            Your program is to write to standard output. The highest sum is written as an integer.

            Sample Input

            5
            7
            3 8
            8 1 0 
            2 7 4 4
            4 5 2 6 5

            Sample Output

            30

            Source
            IOI 1994

            #include<iostream>
            using namespace std;

            int main()
            {
                
            int n,digital_num;
                
            int result[100][100];
                
            int *num;
                
            int max = 0;
                
            int i,j;
                cin
            >>n;
                digital_num 
            = n;
                num 
            = new int[digital_num];

                
            for (i = 0; i<n; i++)
                
            {
                    
            for (j = 0; j<=i; j++)
                    
            {
                        cin
            >>num[j];
                        
            if (i==0)
                            result[i][j] 
            = num[j];
                        
            if (i>0)
                        
            {
                            
            if (j==0)
                                result[i][j] 
            = result[i-1][j]+num[j];
                            
            if (j==i)
                                result[i][j] 
            = result[i-1][j-1]+num[j];
                            
            if (j>0&&j<i)
                            
            {
                               
            if (result[i-1][j]>result[i-1][j-1])
                                   result[i][j] 
            = result[i-1][j]+num[j];
                               
            else
                                   result[i][j] 
            = result[i-1][j-1]+num[j];
                            }

                        }

                    }

                }

                
                
            for (i = 0; i<n; i++)
                    
            if (result[n-1][i]>max)
                        max 
            = result[n-1][i];

                cout
            <<max<<endl;
                
            return 0;
            }
            上面是通過的原程序。140k,15MS。


            這道題目,過得好辛苦,從開始的遞歸,到遞推加回溯,到窮舉,到窮舉加剪枝,結果就從TLE->TLE->TLE->WA.  一直用著要保留路徑的方法,所以怎么也做不出來,后來換了個思維角度,保存每一步的結果,動態規劃,終于就AC了。做了這題,另我復習了好幾種方法,也對DP有了深得認識,可以說這是搞競賽的好題目,經典,推薦??!
            posted on 2006-02-21 13:09 閱讀(1603) 評論(6)  編輯 收藏 引用 所屬分類: 算法&ACM

            FeedBack:
            # re: 終于做出了一題IOI了,有點心得。 2006-02-21 20:58 
            又忘記 delete []num 了!~~  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-02-25 09:29 imlazy
            加油。  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-03-11 11:01 空明流轉
            很好啊,再接再厲!
            我的動態規劃一直學的不好。。。  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-03-12 11:09 
            感謝 空明流轉 的支持!
            我已經領略到acm的恐怖了,但是我不會輕易放棄的:)  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-08-12 21:15 Optimistic
            加油!  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2007-05-03 00:27 App
            inline int calpos(int row,int col)
            {

            return row*(row-1)/2+col;
            }
            int tmem[5051]={-1,7,3,8,8,1,0,2,7,4,4,4,5,2,6,5};
            int bestroute[5051]={-1};
            int height=5;

            int highestroute(int row,int col)
            {
            if (row>height)
            {
            return 0;
            }
            int pos=calpos(row,col);

            if (bestroute[pos]>0)
            {
            return bestroute[pos];
            }
            int nr[]={1,0,1,1};
            int max=0;
            int i;
            for (i=0;i<4;i+=2)
            {
            int tmp=highestroute(row+nr[i],col+nr[i+1]);
            if (tmp>max)
            {
            max=tmp;
            }
            }
            max+=tmem[pos];
            bestroute[pos]=max;
            return max;
            }
            亂寫的,感覺遞歸邏輯更加清晰:-)  回復  更多評論
              
            久久美女人爽女人爽| 亚洲欧美一级久久精品| 精品免费tv久久久久久久| 久久免费视频观看| 久久频这里精品99香蕉久| 亚洲第一极品精品无码久久| 国产精品久久久久久吹潮| 国产精品无码久久久久| 亚洲精品国产字幕久久不卡| 欧美综合天天夜夜久久| 亚洲日韩欧美一区久久久久我| 999久久久无码国产精品| 久久精品桃花综合| 88久久精品无码一区二区毛片| 久久受www免费人成_看片中文| 婷婷综合久久狠狠色99h| 久久精品国产日本波多野结衣| 久久这里只精品国产99热 | 天天综合久久久网| 一本久道久久综合狠狠爱| 久久99精品国产麻豆不卡| 久久99国产乱子伦精品免费| 三级片免费观看久久| 国产成人精品久久亚洲高清不卡 国产成人精品久久亚洲高清不卡 国产成人精品久久亚洲 | 精品久久人人爽天天玩人人妻| 久久精品草草草| 久久99精品久久久久子伦| 国产精品久久久久久久app| 久久精品三级视频| 国产精品久久久99| 国内精品久久久久久不卡影院| 久久精品国产亚洲av麻豆色欲| 国产精品乱码久久久久久软件| 久久高潮一级毛片免费| 国产成人综合久久精品尤物| 99久久久久| 国产精品免费久久久久电影网| 精品国产综合区久久久久久| 国产精品一区二区久久精品无码| 一级做a爱片久久毛片| 狠狠人妻久久久久久综合蜜桃|