• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            隨筆 - 87  文章 - 279  trackbacks - 0
            <2006年2月>
            2930311234
            567891011
            12131415161718
            19202122232425
            2627281234
            567891011

            潛心看書研究!

            常用鏈接

            留言簿(19)

            隨筆分類(81)

            文章分類(89)

            相冊

            ACM OJ

            My friends

            搜索

            •  

            積分與排名

            • 積分 - 216473
            • 排名 - 117

            最新評論

            閱讀排行榜

            評論排行榜

            The Triangle
            Time Limit:1000MS  Memory Limit:10000K

            Description

            7
            
            3 8
            8 1 0
            2 7 4 4
            4 5 2 6 5

            (Figure 1)

            Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

            Input
            Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

            Output
            Your program is to write to standard output. The highest sum is written as an integer.

            Sample Input

            5
            7
            3 8
            8 1 0 
            2 7 4 4
            4 5 2 6 5

            Sample Output

            30

            Source
            IOI 1994

            #include<iostream>
            using namespace std;

            int main()
            {
                
            int n,digital_num;
                
            int result[100][100];
                
            int *num;
                
            int max = 0;
                
            int i,j;
                cin
            >>n;
                digital_num 
            = n;
                num 
            = new int[digital_num];

                
            for (i = 0; i<n; i++)
                
            {
                    
            for (j = 0; j<=i; j++)
                    
            {
                        cin
            >>num[j];
                        
            if (i==0)
                            result[i][j] 
            = num[j];
                        
            if (i>0)
                        
            {
                            
            if (j==0)
                                result[i][j] 
            = result[i-1][j]+num[j];
                            
            if (j==i)
                                result[i][j] 
            = result[i-1][j-1]+num[j];
                            
            if (j>0&&j<i)
                            
            {
                               
            if (result[i-1][j]>result[i-1][j-1])
                                   result[i][j] 
            = result[i-1][j]+num[j];
                               
            else
                                   result[i][j] 
            = result[i-1][j-1]+num[j];
                            }

                        }

                    }

                }

                
                
            for (i = 0; i<n; i++)
                    
            if (result[n-1][i]>max)
                        max 
            = result[n-1][i];

                cout
            <<max<<endl;
                
            return 0;
            }
            上面是通過的原程序。140k,15MS。


            這道題目,過得好辛苦,從開始的遞歸,到遞推加回溯,到窮舉,到窮舉加剪枝,結果就從TLE->TLE->TLE->WA.  一直用著要保留路徑的方法,所以怎么也做不出來,后來換了個思維角度,保存每一步的結果,動態規劃,終于就AC了。做了這題,另我復習了好幾種方法,也對DP有了深得認識,可以說這是搞競賽的好題目,經典,推薦!!
            posted on 2006-02-21 13:09 閱讀(1603) 評論(6)  編輯 收藏 引用 所屬分類: 算法&ACM

            FeedBack:
            # re: 終于做出了一題IOI了,有點心得。 2006-02-21 20:58 
            又忘記 delete []num 了!~~  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-02-25 09:29 imlazy
            加油。  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-03-11 11:01 空明流轉
            很好啊,再接再厲!
            我的動態規劃一直學的不好。。。  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-03-12 11:09 
            感謝 空明流轉 的支持!
            我已經領略到acm的恐怖了,但是我不會輕易放棄的:)  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2006-08-12 21:15 Optimistic
            加油!  回復  更多評論
              
            # re: 終于做出了一題IOI了,有點心得。 2007-05-03 00:27 App
            inline int calpos(int row,int col)
            {

            return row*(row-1)/2+col;
            }
            int tmem[5051]={-1,7,3,8,8,1,0,2,7,4,4,4,5,2,6,5};
            int bestroute[5051]={-1};
            int height=5;

            int highestroute(int row,int col)
            {
            if (row>height)
            {
            return 0;
            }
            int pos=calpos(row,col);

            if (bestroute[pos]>0)
            {
            return bestroute[pos];
            }
            int nr[]={1,0,1,1};
            int max=0;
            int i;
            for (i=0;i<4;i+=2)
            {
            int tmp=highestroute(row+nr[i],col+nr[i+1]);
            if (tmp>max)
            {
            max=tmp;
            }
            }
            max+=tmem[pos];
            bestroute[pos]=max;
            return max;
            }
            亂寫的,感覺遞歸邏輯更加清晰:-)  回復  更多評論
              
            久久国产精品99久久久久久老狼 | 久久男人Av资源网站无码软件| 久久中文精品无码中文字幕| 欧美大战日韩91综合一区婷婷久久青草| 三级韩国一区久久二区综合 | 伊人久久大香线蕉综合网站| 老男人久久青草av高清| www.久久精品| 婷婷久久五月天| 国产精品免费福利久久| 久久久久久国产精品美女 | 久久99精品久久久久久久久久| 日本久久久久久中文字幕| 四虎久久影院| 久久精品国产精品青草| 免费精品久久天干天干| 久久青青草原精品影院| 久久人妻少妇嫩草AV无码专区| 久久久久久久综合综合狠狠| AAA级久久久精品无码片| 一本久久免费视频| 久久久久亚洲AV成人网人人软件| 国产亚洲精久久久久久无码| 中文字幕无码免费久久| 亚洲人成网站999久久久综合| 久久无码人妻一区二区三区| 久久亚洲国产成人影院| 久久综合色区| 女人高潮久久久叫人喷水| 97久久精品人人澡人人爽| 久久国产乱子伦精品免费强| 99re久久精品国产首页2020| 久久影院综合精品| 欧美丰满熟妇BBB久久久| 婷婷五月深深久久精品| 亚洲精品乱码久久久久久蜜桃不卡| 综合久久给合久久狠狠狠97色 | 亚洲va国产va天堂va久久| 亚洲AV无一区二区三区久久| 久久夜色精品国产噜噜亚洲a| 亚洲乱码日产精品a级毛片久久|