• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 195,  comments - 30,  trackbacks - 0

            Energy


            Status In/Out TIME Limit MEMORY Limit Submit Times Solved Users JUDGE TYPE
            stdin/stdout 3s 10240K 717 196 Standard

            Mr. Jojer is a very famous chemist. He is doing a research about behavior of a group of atoms. Atoms may have different energy and energy can be positive or negative or zero, e.g. 18 or -9. Absolute value of energy can not be more than 100. Any number of continuous atoms can form an atom-group. Energy of an atom-group is defined by the sum of energy of all the atoms in the group. All the atoms form an atom-community which is a line formed by all the atoms one by one. Energy of an atom-community is defined by the greatest energy of an atom-group that can be formed by atoms in the atom-community. The problem is, given an atom-community, to calculate its energy.

            Input

            The input contains several test cases. Each test case consists of two lines describing an atom-community. The first line of each test case contains an integer N(N<=1000000), the number of atoms in the atom-community. The second line of each test case contains N integers, separated by spaces, each representing energy of an atom, given in the order according to the atom-community. The last test case marks by N=-1, which you should not proceed.

            Output

            For each test case(atom-community description), print a single line containing the energy.

            Sample Input

            5
            8 0 6 4 -1
            -1

            Sample Output

            18


            理解題意很重要,題目的意思是說 在m個中選   連續的n個atom能量值 使其最大。
            程序中sumtemp,sum。sumtemp確定的是其左邊界,sum確定其右邊界。
            sumtemp確定左邊前n個數之和為負的最大的n,且第n個數顯然為負,然后從n+1開始選數。
            sum確定了右邊界使其最大。
            求和最大都可以用這種思路?。。。。。。。。?!
            舉例
            1,2,-4,4,2,-2,1,5,-6,5,-3,8,10
            請看sumt1=1,sum=1
            sumt2=2;sum=1+2=3;
            sum3=sum2-4=-1;則sumtemp=0;sum不變。
            sum4=sumtemp+4;sum<sum4,sum=4;
            sum5=sumtemp+2;sum<sum5,sum=6
            總之sum只有在sum<sumtemp時才修改。sumtemp<0則清0.
            一維dp.
            #include"stdio.h"
            int main()
            {
             freopen("s.txt","r",stdin);
              freopen("key.txt","w",stdout);
             int n;
             int a;
             while(scanf("%ld",&n),n!=-1)
             { 
                  long long  sum=-0x7fffffff,sumtemp=-0x7fffffff;
               for(long i=0;i<n;i++)
               { 
                scanf("%d",&a);
                if(sumtemp>0)
               sumtemp+=a;
                else
               sumtemp=a;
                if(sumtemp>sum)
               sum=sumtemp;

               }
               printf("%lld\n",sum);

             }
             return 0;
            }

            posted on 2009-07-04 09:27 luis 閱讀(544) 評論(0)  編輯 收藏 引用 所屬分類: 動態規劃 、給我啟發題 、貪心*二分
            <2012年11月>
            28293031123
            45678910
            11121314151617
            18192021222324
            2526272829301
            2345678

            常用鏈接

            留言簿(3)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            友情鏈接

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            女同久久| 成人午夜精品无码区久久| 久久国产精品99精品国产987| 久久精品蜜芽亚洲国产AV| 一本久久久久久久| 久久青青草原精品国产软件 | 青青青青久久精品国产h| 久久久久亚洲av成人无码电影 | 热RE99久久精品国产66热| 亚洲色大成网站www久久九| 久久九九全国免费| 中文无码久久精品| 久久久久18| 狠狠狠色丁香婷婷综合久久五月| 中文字幕久久精品| 国产精品成人99久久久久91gav | 91久久精品电影| 漂亮人妻被黑人久久精品| 欧美一级久久久久久久大| 精品无码久久久久久尤物| 精品伊人久久久| 久久精品这里只有精99品| 欧美久久综合性欧美| 久久亚洲美女精品国产精品| 久久九九兔免费精品6| 色婷婷综合久久久久中文字幕| 国产亚州精品女人久久久久久| 国产高潮国产高潮久久久| 久久午夜无码鲁丝片秋霞| 一本综合久久国产二区| 中文字幕精品久久久久人妻| 一本色道久久88综合日韩精品 | 亚洲国产精久久久久久久| 久久亚洲私人国产精品vA| 亚洲精品乱码久久久久久 | 久久精品国产亚洲av麻豆色欲| 久久精品国产AV一区二区三区| 狠狠综合久久AV一区二区三区| 久久久久久精品成人免费图片| 久久精品国产色蜜蜜麻豆| 国内精品久久久久久久久电影网 |