• <ins id="pjuwb"></ins>
    <blockquote id="pjuwb"><pre id="pjuwb"></pre></blockquote>
    <noscript id="pjuwb"></noscript>
          <sup id="pjuwb"><pre id="pjuwb"></pre></sup>
            <dd id="pjuwb"></dd>
            <abbr id="pjuwb"></abbr>
            posts - 195,  comments - 30,  trackbacks - 0
            After culling his most favorite fruits from the trees in an orchard,Keen AS, a mischievous monkey, is confused of the way in which he can combine these piles of fruits into one in the most laborsaving manner. Each turn he can merely combine any two piles into a larger one. Obviously, by combining N-1 times for N piles of fruits, one pile results eventually. It always takes AS a certain quantity of units of stamina, which equals to the sum of the amounts of fruits in each of the two piles combined, to complete a combination. For instance, given three piles of fruits, containing 1, 2, and 9 fruits respectively, the combination of 1 and 2 would cost 3=1+2 units of stamina, and two piles-3 and 9-are resulted; finally, combining them would cost another 12=3+9 units of stamina, and the total units of stamina taken in the whole procedure is 15=3+12. Surely there are many a possible means to combine these three piles; however, it can be proved that 15 is the minimum amount of units of stamina in demand, and that is what your program is required to do. in this problem ,the fruits are put in a strait line. A pile of fruits 'P' can only combined with the rightest pail on the left of P or the leftest on the right of P, and the united pile will at the position of the bigger one.

            Input

            The input file consists of many test cases. The first line contains an integer N (<=100), indicating the number of piles, and the second line contains N integers, each of which represents the amount of fruits in a pile. no integer will more than 10000, the sequence of integer also means the location of the piles.

            Output

            Your program should print the minimum amount of units of stamina that are required to combine these piles of fruits into one on request.

            Sample Input

            3
            1 2 9
            

            Sample Output

            15
            

            典型的石子合并問題。
            #include<stdio.h>
            int a[101][101],sum[101];
            int stone[101];
            int main()
            {
                int n,i,j,k,flag,l,t;
                while(scanf("%d",&n)!=EOF)
                {
                    for(i=1;i<=n;i++)
                    scanf("%d",&stone[i]);
                    sum[0]=0;
                    for(i=1;i<=n;i++)
                    {
                        sum[i]=sum[i-1]+stone[i];      
                        a[i][i]=0;
                    }
                    for(l=1;l<=n-1;l++)
                    for(i=1;i<=n-l;i++)
                    {
                        flag=0;
                        j=i+l;
                        for(k=i;k<j;k++)                              
                        {
                            t=a[i][k]+a[k+1][j]+sum[j]-sum[i-1];
                            if(!flag)
                            {
                                flag=1;
                                a[i][j]=t;
                            }
                            else if(t<a[i][j])
                            a[i][j]=t;
                        }
                    }
                    printf("%d\n",a[1][n]);
                }
                return 0;
            }
            posted on 2009-06-30 21:01 luis 閱讀(473) 評論(0)  編輯 收藏 引用 所屬分類: 動態規劃
            <2012年6月>
            272829303112
            3456789
            10111213141516
            17181920212223
            24252627282930
            1234567

            常用鏈接

            留言簿(3)

            隨筆分類

            隨筆檔案

            文章分類

            文章檔案

            友情鏈接

            搜索

            •  

            最新評論

            閱讀排行榜

            評論排行榜

            亚洲乱亚洲乱淫久久| 国产精品99久久久久久人| 欧美国产成人久久精品| 亚洲欧美另类日本久久国产真实乱对白| 久久久久亚洲AV综合波多野结衣| 99久久人人爽亚洲精品美女| 亚洲日本久久久午夜精品| 久久青青草原精品国产| 久久免费99精品国产自在现线 | 伊人久久大香线蕉成人| 久久亚洲中文字幕精品有坂深雪| 日日躁夜夜躁狠狠久久AV| 久久91精品国产91久久小草| 亚洲乱码日产精品a级毛片久久 | 久久综合狠狠综合久久| 国产精久久一区二区三区| 亚洲成色WWW久久网站| 久久综合成人网| 97精品国产91久久久久久| 99久久99久久精品国产片果冻| 国産精品久久久久久久| 久久se精品一区二区| 亚洲成色www久久网站夜月| 亚洲天堂久久久| 亚洲?V乱码久久精品蜜桃| 久久精品国产欧美日韩| 99久久精品国产综合一区| 久久免费精品一区二区| 国产精品99精品久久免费| 国产精品对白刺激久久久| 99久久精品国产一区二区| 亚洲欧美一级久久精品| 久久播电影网| 久久久久久国产精品免费免费 | 99久久这里只精品国产免费| 久久久国产一区二区三区| 久久精品国产亚洲精品| 国产精品免费久久| 国产精品美女久久久久av爽| 久久久久18| 国内精品综合久久久40p|